Previous 1 2 3 4 Next 46 Replies Latest reply: Mar 25, 2013 5:36 PM by turingtest2
David Wolf1 Level 1 (15 points)
How to fix the ping junk for Mac has been floating around for a bit, but so far, no one has posted how to fix it on Windows... Until now!

So, here's how:

Enter the following commands in a Command Prompt window or the 'Run' dialog box.

"C:\Program Files\iTunes\iTunes.exe" /setPrefInt hide-ping-dropbown 1
"C:\Program Files\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 1
"C:\Program Files\iTunes\iTunes.exe" /setPrefInt disablePingSidebar 1

If you're on a 64-bit version of windows, use this instead:

"C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt hide-ping-dropbown 1
"C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 1
"C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt disablePingSidebar 1

Hope this helps a few people!

Message was edited by: David Wolf1

Windows 7
  • An Clar Level 1 (0 points)
    THANK YOU, THANK YOU, THANK YOU!!! I've been looking for this ever since I updated to 10.0.1

    FYI there is a typo in your command lines...it should be dropdown, not dropbown...otherwise it works like a charm. Now if only we could get the Genius sidebar back.
  • David Wolf1 Level 1 (15 points)
    aw, cr*p... Yeah, the RIGHT commands are:

    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt hide-ping-dropdown 1
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 1
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt disablePingSidebar 1

    If you're on a 64-bit version of windows, use this instead:

    "C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt hide-ping-dropdown 1
    "C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 1
    "C:\Program Files (x86)\iTunes\iTunes.exe" /setPrefInt disablePingSidebar 1

    Getting dsyelixc in my old age apparently.. LOL
  • dtae Level 1 (0 points)
    Didn't work for me. Ping is still there. I tried re-running the three commands and rebooting as well.
    Windows 7 Pro 64-bit
    iTunes 10.0.0.68
    Maybe I need to upgrade to 10.0.1
  • dtae Level 1 (0 points)
    Just installed the upgrade to 10.0.1.22 and ran the three commands again. **** ping is still there.

    Thanks for the crap apple..when I find a good replacement for podcasting, I think I will be ditching iTunes and my iPod.
  • brian555 Level 1 (25 points)
    David,

    *Thank you!* I just tried this on Win 7 x64 and it worked! The Ping buttons are now gone from each row!

    Ping still shows in the left menu in iTunes Store (which doesn't matter much to me) and I have the Ping sidebar hidden. The Ping sidebar can be brought up at any time and, unfortunately, Ping is still there if you right-click on a song. I guess Apple REALLY wants one to use Ping!!!

    For those that say this set of commands is not working for them, have you turned Ping off? You have to go to Store > View My Account > Ping = Off.
  • An Clar Level 1 (0 points)
    Folks...bear in mind that what these commands do will not, unfortunately, completely remove "Ping the Obnoxious". What they will do is:

    1. Hide the Ping sidebar (which you can do from within iTunes also).
    2. Eliminate the Ping dropdown buttons that appear next to any of the music in your library when you select a song.
    3. Restore the old-style arrows in your music list that will, when clicked, take you to the album listing in the iTunes store.

    These commands will not remove the Ping choice from the left hand iTunes store menu. The only way to do that at present is to disable the iTumes store in Parental Controls. Of course this will also make it impossible to sync apps with your mobile devices.

    The other thing they won't do, and what Apple really needs to give us back is the option to use the Genius sidebar instead of the "Ping the Obnoxious" sidebar. Keep hammering Apple about this and MAYBE they'll give it back to us.
  • brian555 Level 1 (25 points)
    I understand that. What I wanted to do was remove the obnoxious Ping dropdown button that appear next to any selected song. It did that for me and I was made happy
  • nabilalk Level 1 (20 points)
    I'm on 64 bit Windows and used these commands since I don't have a iTunes folder in x86. Maybe iTunes has finally gone true 64 bit?:
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt hide-ping-dropdown 1
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 1
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt disablePingSidebar 1

    Also, for anyone who does not want the iTunes store arrows enter this:
    "C:\Program Files\iTunes\iTunes.exe" /setPrefInt show-store-link-arrows 0

    where the command is the same as the 2nd one listed, and the "1" is changed to a "0"

    Thanks
    David Wolf1 and brian555

    Message was edited by: nabilalk
  • nabilalk Level 1 (20 points)
    How would you suggest we appeal to Apple directly? Thanks.
  • evilhippo Level 1 (0 points)
    VERILY you rock Sir... that worked for me like a charm Many thanks... the odious ping buttons are banished!
  • Naix Level 1 (0 points)
    I was so excited to download this update because I thought Apple got the feedback and made ping less intrusive.

    Oh boy was I wrong, seriously, what ****, Apple?

    They made ping more intrusive. Nice.

    I greatly appreciate your post and await the day we can remove ping from the sidebar.

    Regards.
  • bug67 Level 3 (980 points)
    nabilalk wrote:
    How would you suggest we appeal to Apple directly? Thanks.


    http://www.apple.com/feedback/itunesapp.html
  • nabilalk Level 1 (20 points)
    submitted my requests

    optional Ping
    optional Genius including side bar
  • the Ice Devil Level 1 (0 points)
    Try including the quotation marks ". I tried the first time without them and it didn't work. I tried again, including the beginning quotation marks and walla! No more stupid Ping buttons!
Previous 1 2 3 4 Next