Previous 1 5 6 7 8 9 Next 132 Replies Latest reply: Dec 19, 2015 11:31 PM by jmooseman Go to original post
  • niccodeamus Level 1 (5 points)

    My USB 3 drives also unmount.  Latest iMac (late 2013 3.5 27").  I find the problem is related to Aperture and/or iPhoto.  The drives spontaneously unmount and immediately remount when these apps are doing a prolonged process like copying a library.  The job fails as a result and also anything else that is using the drive.  It has caused the Lightroom library, for instance, to lose all it's image addresses for the images held on these external USB 3 drives.


    I have no answer to the problem except don't use the apps that cause it, or keep their libraries on a different drive connection

  • Cnkeith Level 1 (0 points)

    I've been having thise problem with an external firewire drive.  I have a one year old Mac Mini and I am completely up-to-date with OS changes.  I've modified the power saving preferences to leave the drives alone (didn't help).  I'd thought the unmounting of the Time Machine drive was due to the drive firmware, etc but I've just switched to a WD 4 TB USB3 drive and partitioned it to have a Time Machine partition (Mac OS Extended Journaled).  I've also left the Firewire drive attached for normal storage.


    Now, the new partition (not the full drive!) unmounts overnight!   No other drive unmounts.  This is new hardware.  This HAS to be something to do with Time Machine unmounting the drive!!

  • LajkaBoss Level 1 (0 points)

    All, I'm having the same issue on rmbp with haswell. This happens with a samsung 640Gb usb 3 and adata 640Gb usb 2 external hdds.


    I can not copy large files, the drives unmount after ca 10 minutes.

    Hdd sleep is disabled, mac does not go to sleep, dont use timemachine, cables are ok.


    Its a stock mac, the external hdds have just some old data, videos and photos and I want to copy new videos from my camcorder there.


    I just switched to mac but this is very frustrating and want it to work like on crappy windows.


    Any suggestions how to fix this is GREATLY appreciated


  • DC Steve Level 1 (25 points)

    I think that the the spontaneous ejections are the computer's response to something it doesn't like -- a large file or (what it thought was) a corrupted file.  I suppose that this is a good safety feature but it would be nice if Apple told us about it.

  • Cnkeith Level 1 (0 points)

    I discovered that the app TimeMachineScheduler got broken by the switch to 10.9 and was the culprit, so I uninstalled it and the problem was solved.


    I'd love to get an app that identifies all such cruft that I have installed and forgotten about over the years

  • marrlin Level 2 (165 points)

    Try this [from macfixit].


    To do this, you will need to open the system's hidden database folder, by going to the Finder's Go menu and entering the following as the target folder:


    When this folder opens, locate the file called volinfo.database and remove it, and then get information on your hard drives and set their permissions awareness accordingly.

    1 external drive unmounting regularly, no other fixes worked.


    This has worked now for 36hours. Hopefully will continue to work.

  • Kenneth Cohen1 Level 1 (70 points)

    Make sure you don't have an app such as Jettison (there are several others also) installed - its purpose is to automatically unmount all specified volumes when a computer goes to sleep.

  • Larry the O Level 1 (0 points)

    I have a very old Mac Pro running 10.6.8. I've had this unmounting problem for years with an external FireWire drive. I fairly recently added a second FW drive (Seagate), and very recently added at 2TB GTech Green FW drive. What I see very often happens at boot time, which is that the FW drives do not appear on the desktop, then I get an error message telling me drives were not unmounted (after a normal shut down procedure), and, about five minutes later, they mount.


    I see no clear solution here, but the dialog and the discussion lead me to try explicitly unmounting FW drives before invoking shut down. If that works, boy howdy will I post it!

  • Go suck start a 45 on fb Level 1 (0 points)

    just this past week this issue has been occurring. i have a 3yr old book (has its own power plug), a 3yr old pocket drive (is self powered off the usb cable), a 10+yr old ipod nano (that has been thru **** and back, reset and it keeps on working) as well as a 3yr old dvd drive (plugged directly into the computers usb ports) all plugged into a 3yr old mac mini. i replaced the usb hub, reassigned the usb plugs into different ports, but it does not matter. they keep randomly unmounting (tho-they do all unmount at the same time and remount again in a minute, on their own), even while computer is being actively used. time machine has never been on. ive turned off sleep drives in energy saver. odd other thing too, i now have a movie dvd in the apple-brand dvd drive and the drive no longer unmounts with the rest of them.
    one more note: mouse and keyboard are PC and i can use the direct ports or the hub and these items are functioning normally. monitor is PC with converter for the hdmi port on the mac mini. the irony is that i allowed an update just prior to these unmounting issues as well. im not a big techo whiz in terminal or xcode and i dont dabble in there at all. ive read 4 of these 9 pages in this thread and i dont believe its the cables, it is not the usb hub either. it cant be with all external drives doing it, even the apple dvd burner. my concern is is i dont have the resources presently to just pay for a new mac mini and im thinking the computer's usb's are going bad. at the same time im concerned the update (at 10.9.4) is the culprit and i would need a pro to hold my hand in backing up to the prior system. for now, im keeping all external drives unmounted and unplugged until i need them. any help? thank you in advance.

  • Franzeee Level 1 (0 points)

    I am jumping in here. Same issue; but my drive is a brand new secondary drive I installed in my 2012 MBP. I have had this happen 4 times now trying various things. It has only happened while trying to copy my iPhoto library (57K+ photos 347+GB) to the drive. I have copied other large quantities of files with no issue.

    I am going bonkers. Going to try to put the drive in an external case and see if I can copy that way next.

    Has anyone had ANY luck with this issue?

  • ChrisBorjon Level 1 (5 points)

    This worked for me.


    To read about and get more context here is the MacFixIt article


    If the kill the link, do a Google search on "CNET How to fix drive-permissions problem in OS X"

  • InspiredLife Level 1 (15 points)

    I get the same issue. Seems to have always been that way.

    I have a MBP 17" Mid-2010.

    I use FireWire (400 & 800) drives (daisy-chained) and a number of USB drives. All are powered by the BUS (none with external power). These are all pocket/portable drives.


    When I put my computer to sleep, upon return, I'll get warned by OS X that my drives were not unmounted before disconnecting. I've had this issue on all versions of OS X since mid-2010, right through to 10.10.2 on the machine now.

    I notice the USB drives remain powered when the MBP is sleeping. I see an illuminated blue light on the one with a light. I can't say whether they eventually have their power dropped by the computer (I've not sat around watching).


    As far as I can tell, it's a relatively common issue. Here's just one (of many) articles mentioning it:


    I am in the process of looking for a way to automatically dismount and remount all external drives when going in and out of sleep, respectively. Seems like the only viable solution to me.

  • jmooseman Level 1 (0 points)

    For WD drives the problem of dismounting drives can be solved by removing the WD app but you must use the WD  uninstaller as settings need to be made by the uninstaller.

Previous 1 5 6 7 8 9 Next