Previous 1 2 3 4 5 Next 205 Replies Latest reply: Jun 3, 2014 1:37 PM by FRICS Go to original post
  • SantaSadler Level 1 Level 1 (0 points)
    I found my problem! Turns out you need to select an iPhoto source under iTunes Advanced Menu -> Chose Photos to Share. Once I selected the iPhoto option then it worked.

    I think this Home Sharing thing needs some work making it more intuitive and adding something to the Troubleshooting FAQ. To me it is not obvious that you need to do iPhoto sharing setup in iTunes especially when iPhoto has Sharing selections under its preferences. This can be confusing. Also, it seems like you can only share one photo thing at a time - either one folder or one iPhotos library and not both and not more than one folder. I see no need for these limitations. Hope HomeSharing/AppleTV developers take note and fill in some gaps and make it easier to understand and use.

    Right now I'm a little disappointed with ATV since the main reason I bought ATV is for photo viewing. And of course it sure would be nice if there was an ability to do some web browsing as well. It would be useful when some ad or promo comes on TV with a reference to a web site, to right there and then go look at the web site and do some browsing. Technically I am sure this is doable.
  • bullta Level 1 Level 1 (0 points)
    I manually open itunes and everything works
  • Abhir Level 1 Level 1 (0 points)
    I have lost 2 days of my life with this ATV2. I have followed all suggestions, rebooted PC, Router, ATV, set up Home Sharing on iTunes etc. and can actually play my library and even use the iPhone app to control music.

    BUT.... I cannot get Home Sharing to work. When I reboot ATV2, it gets stuck on Looking for Network Services, even while my libray is playing ok. The wireless Router is recognised ok, but when I input ID and password it still is not recognised. What am I missing here?
  • Robert Farthing Level 1 Level 1 (65 points)
    O.k., So I've has ATV2 for 2 days now........

    I also had problems with ATV loosing the library's when it woke up from sleep.

    I tried (many) power off resets, router resets, etc. etc., but eventually ATV always looses it's memory again.

    I phoned apple support, and was connected to their "higher level support". I was asked if I could see the device in the devices column in iTunes?!!!!! (ATV2 doesn't work that way, it uses Home sharing).

    After trying to convince me that it was acceptable to do a power reset (unplug/plug in) every time I use the device (and that was "normal for a network device"), I explained that many other people were having the same problem, and that he should check the support discussions site.

    He said he'd look into it and get back to me.

    An hour or so later, he left me a message to ask me to check the Firewalls. My firewall only blocks incoming traffic, and allows application sharing, so that isn't the issue here.

    I've mailed him back.........I'll report any updates on this.

    What happened to the "it just works"?

    Bob.
  • flyindavid Level 1 Level 1 (0 points)
    "What happened to the "it just works"?"

    GOOD question Robert!

    I've been a PC guy most of my life, and have heard often heard that phrase from Mac folks, so I bought a MacBook Pro and ATV2 last month to edit and play my HD videos.

    Ooops... Found out Apple TV 2 JUST DOESN'T!

    ;^(
  • SoundForSound Level 1 Level 1 (15 points)
    I see similar issues:

    1) Home Sharing:
    (a) Apple TV shows my Computer listed, but when I click on it, it just spins forever.
    (b) Also at times, it seems that Home Sharing just completely goes down. Using the remote app on my iPad shows no Apple TVs (should show 3) and does not show the iTunes library from my PC either.

    I've found that closing and re-opening iTunes on the Computer fixes both of these issues.

    2) Selecting photos from my Computer takes a considerable amount of time before anything is shown. It does eventually show the albums, but after a few mins. Unlike (1) where it would just spin forever. **

    ** Note that I hate how Apple TV does not support sub-folders in albums. For instance I have my photos organized like this:
    d:\pictures
    d:\pictures\christmas
    d:\pictures\christmas\2005
    d:\pictures\christmas\2006
    d:\pictures\disney
    d:\pictures\disney\2005
    d:\pictures\disney\2006

    ** It collapses all the christmas pictures into one album. Same for disney. Wife hates this, as do I. Wish they just had a "folder" view that supported sub-folders and such. Would be awesome then! See a lot of complaints on this around the net.
  • Jeremy Photographer Level 1 Level 1 (0 points)
    Same problem in Australia. It will play podcasts and previews, but will not allow me to turn on home sharing. I ordered my Apple TV over a month ago. It only arrived yesterday and does not work! What an anti climax.

    My support at Apple was not able to suggest anything and they have not returned my call as promised. I assume they have programmers trying to work out how to fix this flaw.

    *Apple as a company has gone from the professionals choice of computer to a main stream toy company, more advertising than R+D.... and as such..... it's now unreliable!*
  • Darryl Adams1 Level 1 Level 1 (15 points)
    I have read all the posts and experienced this same problem - ATV not finding my library although it finds the library from my laptop. (ATV sometimes found my library but would not download the photos, etc. ) My Mac to Mac sharing works fine. I believe I have solved the problem and the problem was in my third party Virus Barrier which blocked internal addresses that demonstrated high activity. The problem was the ATV sending a "flood" of requests to download the library and the Virus Barrier software blocked the address as an intruder. I removed the 192.168.100.xxx address from the virus barrier "connection flood" blocked address, and all works just fine. Hope this solution pertains to others.
  • Funmunke Level 1 Level 1 (0 points)
    I still can't get ATV2 to work consistently but I did find that my library showed up more frequently after I turned off my firewall. I had my firewall setup with some fairly open settings but it seems like it was still blocking ATV2.

    I didn't turn off my firewall to fix the ATV2 problem. I turned it off because it was blocking my TC. Now my TC works great and my ATV2 kinda works.

    I really think the main issue is how the firewall works in OSX 5 to OSX 6.
  • Robert Farthing Level 1 Level 1 (65 points)
    I've had no update from Apple at all today for this problem, I guess they're stumped!

    It's strange, I got it to connect last night, and it was still working this morning, I then put ATV2 to sleep for 30 seconds, and it couldn't find my library when it woke up, and hasn't been able to all day.

    Yesterday, I switched Home Sharing off in iTunes, then back on again, and this brought up the Library on ATV2, but I've tried doing the same many times since then, and it just doesn't work. Odd!

    When they eventually sort out the problems, it will be really good (and I'll buy another couple), but until then, it's a waste of space (and money)!

    Bob.
  • timbo_baggins Level 1 Level 1 (50 points)
    It's working fine here but it's quirky.

    If I open iTunes and enable Home Sharing and authenticate, then "Home Sharing" appears in the Shared section of the left hand pane (same pane that lists Devices, Playlists, etc.

    If I then click "Done" on the main screen view this "Home Sharing" listing disappears and I can't see the library on the ATV2.

    However, if I don't click "Done" and carry one then all's well. I can move around iTunes and do all the normal stuff but as long as I don't close that Home Sharing screen view it works fine.

    Maybe someone can try on their system and see if this is consistent?

    Tim
  • Robert Farthing Level 1 Level 1 (65 points)
    Hey, I've just tried that, and it's exactly the same for me.
    I haven't clicked "Done", and the home sharing stays up in the devices, and I can see my library on ATV2.
    I've put ATV2 to sleep, then woken it up, and my library is still there.
    I'll monitor the situation and report back if this has been a permanent fix.
    Thanks.
    Bob.
  • Robert Farthing Level 1 Level 1 (65 points)
    Ah, problem...........
    When you quit iTunes, then open it again, the "Home Sharing" disappears, so quitting must also hit the "Done" button.
    Back to square 1!
  • timbo_baggins Level 1 Level 1 (50 points)
    That's a bug then - the sharing state really ought to be maintained through a quit or a reboot even.

    Tim
  • Robert Farthing Level 1 Level 1 (65 points)
    Roll on the first ATV2 software update...........

    However, saying that.........this appears to be a problem in iTunes, if it's home sharing doesn't remain open........

    Bob.
Previous 1 2 3 4 5 Next