Previous 1 2 3 4 Next 793 Replies Latest reply: Sep 14, 2013 9:32 AM by larrylintz Go to original post
  • a brody Level 9 (65,365 points)
    All I can say is even with a 7Mbps connection, streaming is unreliable with my Sony Bravia XBR9 TVs. It works sometimes all the way through a 2 hour movie, when other times it stalls on a 1 hour TV show midway through, and repeatedly thereafter.

    DSL normally is less than 7Mbps, so anyone with DSL trying to connect to Netflix, I would attribute it more to the connection speed than anything else, as well as the Netflix programming for the streaming.

    I would contact Netflix and let them know not everyone has Cable or Fiberoptic to be able to handle high speeds, and many stuck with 384 kbps DSL still. I would certainly hope that with any streaming device they can handle the minimum broadband speed. Cause if they can't what hope do we have for 3G devices such as iPad 3G? I don't expect dialup to work, but at least minimal DSL shouldn't have that much trouble. Way back when, when I had a 384 kbps DSL, I was able to stream the Quicktime trailers in Mac OS 9 of some movies. No reason Netflix can't talk Microsoft into improving Silverlight to handle streaming better. We as customers who have slow broadband internet just need to let them know when they aren't serving everyone with broadband.
  • Tim Campbell1 Level 3 (575 points)
    a brody wrote:
    All I can say is even with a 7Mbps connection, streaming is unreliable with my Sony Bravia XBR9 TVs. It works sometimes all the way through a 2 hour movie, when other times it stalls on a 1 hour TV show midway through, and repeatedly thereafter.

    This is all about the video bitrate. Bitrate in video playback is always variable because it's based on the compression level of the frames that happen to be playing +at the time+. Frames where not much is in motion, or where the detail is low (fairly flat & plain) will compress very well. Frames where everything is in motion and have a lot of detail wont compress as well. Then there's the overall compression level that was used when the movie was rendered. You've probably seen shows where there's no defect on your playback device, but the background looks a bit boxy & pixelated (typically obvious in dark shadowy areas or when there's a single "color" with levels of tonality (e.g. the sky where it's varying tones of blues.) A high bit-rate film wont have those boxy & pixelated artifacts.

    I picked a random TV episode from my iTunes library (it happened to be Grey's Anatomy) and did the math. That episode would require an "average" network speed of just about 6Mbps to stream.

    But it's dangerous to assume that "average" is adequate because bitrate is always variable in video playback. You might only need 3-4Mbps in one area only to have it spike to 9-10Mbps at some other point in the same video. The network connection really needs to be sized to handle the "peaks" or you'll experience some playback pauses while it "buffers" the content. Also this assumes the bandwidth is actually available to you. If someone else gets on your network and starts doing something that uses bandwidth, that's going to reduce the portion of bandwidth available to you because you are sharing the connection.

    Wikipedia has an article on video bitrates which depicts a typical HDTV with MPEG-4 AVC (which I think is close to what Apple TV uses) would need a bitrate of 8-15Mbps for playback (but that's high-quality ... not heavy compression. My guess is Netflix compresses a bit more aggressively.)
  • Desert Boynsea Level 1 (0 points)

    I had all kinds of problems with music until plugged my crappy old qwest DSL into an exteme base station and put two airports in the house...thick adobe walls. Plugged in the Apple TV an it streams everything without problems. Netfilix, Music and Photos. I don't know if I am just lucky or the wifi in the base station an airports just works better. It cetainly is not my superior DSL connection with Qwest.
  • Tim Campbell1 Level 3 (575 points)
    Apple routers are better... I've had years of experience with just about every popular brand... Linksys, Netgear, D-Link, Belkin, the list goes on. Apple's routers have consistently outperformed & outlasted everything else I've tried... not just signal strength, but reliability, compliance to standards, etc. It's a clear case of "sometimes you really DO get what you pay for".

    Meanwhile... if your old router was using 802.11g, you'll find 802.11n is significantly faster and has a much better range (e.g. a weak signal from a 'g' router in your home would probably give a much stronger signal after swapping it out for an 'n' router even though you haven't changed the location of your router or the client.)

    802.11n is good enough that often a house that would have required two 802.11g routers can make due with just one 802.11n router. It's actually better than that... 802.11n clients can usually be about 3x as far from the base station as compared with 802.11g.
  • Gaugevox Level 1 (0 points)
    I just got my new ATV today and am disappointed to be experiencing some netflix issues. I tried playing a couple episodes of a show and every time it would go back to the menu after a few seconds of playing. I am wired into my router and had tried a restore and power cycle to no avail. I tried a movie and it did the same thing, but eventually jumped back into playing. I went back to the shows and fast forwarded past the part where it usually dropped out, and this time it worked.
  • sriramk Level 1 (0 points)
    I spoke to Netflix support and they helped me fix this issue.

    Solution: Switch from your automatic DNS settings to Google's DNS server. General->Network->Configure TCP/IP->Manual and pick

    Now, I was stumped a bit since I have an XBox 360 on the same network with no issues. The support guy said that Apple TV connects to their licensing servers a bit differently so this should fix the issue.
  • DewFreak Level 1 (0 points)
    Netflix works great over my Verizon MiFi. Only about 1.5Mbps
  • dazexone Level 1 (0 points)
    Thanks so much sriramk! This fixed my problem. I was going crazy trying to figure out what the issue was because I was able to play everything from Apple rental, Youtube, Flickr, etc just fine. I was able to log into Netflix and browse their library just fine. However, upon launching a Netflix title, I get an error message to try again later. I thought my ATV2 was defective because my PS3 was able to play Netflix just fine.

    Upon making the manual DNS change to Google's DNS server: on the ATV2 Netflix works right away. None of my problem did not appear to be a DNS issue because I was able to resolve and access all the other internet services, including Netflix. It was only playing of the actual Netflix video where my problem lies. Additionally, my router was set up to use Google's DNS server already. I wonder if there is a bug with ATV2 and Netflix playback if your router is task with resolving the DNS query?

    One final observation. I read that the lastest iOS for ATV2 is firmware 4.1. However, when I check on my ATV2's about page, it shows that I am running version 4.0. Going to software update from within the ATV2's interface, Apple says I am already running the latest version. That's odd. I may have to run out and pick up a micro b usb cable and force a restore to 4.1 via the computer. Anybody else seeing the same thing?
  • bkmartin Level 1 (0 points)
    The dns change fixed my problem as well. Thanks. I was previously using opendns servers so I imagine a lot of people will hit this (content cannot be played) problem. Apple should put out a bulletin about it.

    Message was edited by: bkmartin
  • alexzapata Level 1 (0 points)
    Just want to report that the manual dns fix worked for me too.
  • dazexone Level 1 (0 points)
    About the firmware problem. I learn that software version reported is likely the version of the Lowtide interface. The firmware version running underneath is already 4.1. I haven't seen anywhere in the UI that shows the firmware version number.
  • Groovyguru Level 1 (0 points)
    Same issues here. I had a dlink router, switched to a new airport in anticipation of the atv. It seemed slower and tests said it was. Tried the new apple tv and it worked well, except any Internet related tasks like netflix. I tried all the suggestions and none worked. Finally setup the old router and removed the airport and Internet speed increased and atv netflix worked well. Given the volume of data for streaming atv, I used a hardwired connection to avoid wireless congestion. I will be returning the apple airport. . The dlink is a dir655, the airport is the latest greatest.

  • a brody Level 9 (65,365 points)
    It would behoove all of us, who notice streaming issues to "report problem" through our Netflix instant queue. With time, it will allow Netflix better optimize buffering on all streaming software firmware.
  • Hurmoth Level 1 (0 points)
    Thank you, thank you, thank you!

    I have a router with dd-wrt and I force all of my DNS traffic to OpenDNS. I switched it to Google's DNS, rebooted the Apple TV and it took right off.

    I've sent a message to OpenDNS' support letting them know of this issue. Hopefully it gets resolved because I enjoy being able to limit what my network users go to (lots of people connect via my internet connection and to thwart malware, I block a lot of bad stuff on my network thanks to OpenDNS).
  • laundry bleach Level 5 (6,885 points)
    Which particular Netflix titles are you having this issue with?

Previous 1 2 3 4 Next