Previous 1 49 50 51 52 53 Next 793 Replies Latest reply: Sep 14, 2013 9:32 AM by larrylintz Go to original post
  • sefit Level 1 Level 1 (0 points)

    When I first got my ATV it worked perfect out of the box i was playing netflix movies with no problems, then one of my neighbours had bought the same router as mine. ( and it was running on the same frequency or channel, as my roughter did ) after that my ATV had so many problems trying to play movies from netflix that i took it to the Apple store. They told me alot of things that could be wrong with it but one of the things he told me was that my router could be running on the same frequency as another router, so i went back home and changed the channel my router was running on and after that i had no problems.... i know this wont apply to everyone but if you change the chanel on the router that just might do the trick. GOOD LUCK

  • J.Ross Level 1 Level 1 (0 points)

    Mine only seems to have this issue with TV shows. i'll be watching for hours then i'll try to start the next episode and thats what i'll get 'neflix is unavailable'. it always happens between episodes. my ATV3 is cabled in and no change from cable to wifi.

    I turn on netflix on my xbox and never have problems. i basically paid for an ATV3 for Airplay at this point, which i use more than netflix so i'm not completely disappointed.

  • Pete 727 Level 1 Level 1 (0 points)

    Just to pile on and catalog problems, I have a few using Netflix with Apple tv that I don't have with my PS3.

    First: I cannot remove items from my instant queue using Apple tv.  There is a button that should swap between "+ queue" and "remove" depending on whether an item is in my queue already, but after the last update it always reads "+ queue", even when an item is already in my queue.

    Second: When there's an item with multiple episodes (a tv who or miniseries or whatever), it sometimes defaults to an episode I've already watched.  (When it works correctly, it should default to the next unviewed episode).  Again - never saw this glitch with PS3.

    Third: Like many others, I see quality issues using Netflix on Apple tv that I don't see either on my computer or on my PS3, all on the same home network.  I even have my Apple tv connected by ethernet at this point, (I didn't always) so I know wireless isn't the issue.

    Finally: I'm getting the "Verify payment information" pop-up screen constantly, even though I'm not trying to buy anything through Apple tv, and even though I've successfully made purchases through iTunes on my computer and my iPhone. 

     

    Added all together, this is freaking ridiculous.

  • Arcamigo Level 1 Level 1 (0 points)

    I agree, this is freaking ridiculous. I've been an Apple fan since my first PowerMac G3, but lately all of their updates have been breaking my products. Whether it was removing Rosetta and forcing me to buy new software, or deleting Google Maps from iOS, or breaking my ATV exactly as you've described. It's reached the point where I fear all updates.

     

     

    I've given up trying to remove items from my queue. That's definitely broken. At first I thought it was a Netflix API thing, because Netflix has been seriously messing around with their API breaking other apps as well, but it works fine on my Xbox.

     

     

    The multiple episodes issue is flaky for me also. It's like the ATV isn't communicating with Netflix properly, because if you check Netflix, you'll notice that the episode you just watched completely on your ATV is appearing as not watched in Netflix (i.e. 0m out of 50m instead of 50m out of 50m). Sometimes restarting the ATV before you start watching helps. My other solution is to start the new episode and watch for a few seconds, so Netflix/ATV remembers it for next time. It's absurd that I need to do these things. I tend to rewind a lot. I wonder if that's part of the problem?

     

     

    Fortunately, I rarely have quality issues. My Netflix video quality is set to Best quality.

     

     

    Finally, the Verify payment information is something that I think I actually solved with Apple iTunes customer support help. Basically, you need to log out of your Apple ID from all your accounts (ATV, iOS devices, iTunes on your computer, etc.) and then edit your account at http://appleid.apple.com. Somehow, this actually appears to have worked for me. I did delete an old address, but unlike some online remedies, I did not purchase anything in iTunes after the edits. I'm posting the full iTunes support email below:

     

     

    Dear XXXXXXXX,

     

     

    Welcome to iTunes Store Customer Support. My name is YYYYYYY and I am glad to assist you.

     

     

    I understand that you are unable to verify the payment information on your Apple TV. I can imagine your eagerness to have this resolved and I will be happy to look into this for you.

     

     

    XXXXXXXX, you'll need to make corrections to your account information. To do this, follow these steps:

     

     

    1) Sign out of the iTunes Store by choosing Sign Out from the Store menu in iTunes.

     

     

    2) Visit the My Apple ID website at:

     

     

    http://appleid.apple.com

     

     

    3) If the site is not displayed in your preferred language, click the flag icon in the lower-right corner of the page, then select your country from the next page.

     

     

    4) Click the "Manage your Apple ID" button.

     

     

    5) Type your iTunes Store account name (which is your Apple ID) in the Apple ID field, type your password in the password field, then click the Sign In button.

     

     

    6) Click "Addresses" in the column on the left. Look at your shipping addresses at the bottom. If you have multiple shipping addresses, remove any out-of-date or duplicate addresses by clicking Delete. Also, make sure the state or province field is filled out correctly for each address. To edit an address, click Edit.

     

     

    7) Now click "Phone Numbers" on the left. The area codes should be in the area code fields and the phone numbers should be in the phone number fields. If an area code is missing, or if it is in a phone number field, your account information may not save properly.

     

     

    8) Make any other necessary corrections, then click the Save Changes button.

     

     

    9) Click Log out in the upper-right corner.

     

     

    When you make your next iTunes Store purchase, you will be asked to review your billing information. At that point, you can change your information or simply click Done. After that, you should be able to purchase items.

     

     

    Should this error persist, please reply with as much detail as possible, and include screen shots of any error messages received so this can be reviewed further.

     

     

    I hope this resolves your issue. Please feel free to contact me for further assistance. We're always happy to help.

     

     

    Thank you for using iTunes Store.

     

     

    Have a great day!

     

     

    Sincerely,

     

     

    YYYYYYY

    iTunes Store Customer Support

    http://www.apple.com/support/itunes/ww/

  • smokre Level 1 Level 1 (0 points)

    Here's how I solved the problem.  I switched to Amazon Prime and use my Xbox to watch shows.  It just works, the Xbox interface is way simpler, and the catalog seems bigger than Netflix.  Good luck.

  • Arcamigo Level 1 Level 1 (0 points)

    I don't think the Xbox interface is simpler, but it does work much better, after I finally reach it. It's almost a game of its own navigating to it from the Xbox home screen with like 20 button pushes. Then I have to do the same stupid repetitive selection between regular Netflix and Netflix for Kids. Of course, it's only a matter of time until the next dreaded ATV update forces me to have to do the same...

  • J.Ross Level 1 Level 1 (0 points)

    Navigating the atv version is simpler but at least the Xbox version is reliable.

    In regards to launching Netflix on Xbox, use the quick play menu. But I too hate the prompt for regular or kids mode. Should be a one time selection.

  • Cybergy Level 1 Level 1 (0 points)

    My ATV2 was driving me nuts with Netflix errors; "try again later" errors, "recently watched" disappears, sometimes forgets my Netflix logon, random reboots, so I moved my PS3 into the main room and run Netflix on that.  Wow!  It just plain works, every single time - either FF or RW without issue.  Love it!

     

    Also, the Netflix video quality on the PS3 is unquestionably better than the ATV2.  Both are wired LAN, Netflix set to highest quality.  The difference must be in the ATV2's inability to receive the stream a a high rate, so Netflix scales down the transfer rate.  Not so with the PS3.  The quality looks as good as broadcast HD.

     

    I will not be going back to the ATV, and frankly - now I have little use for it...

  • icminc Level 1 Level 1 (0 points)

    If you are using an Apple Airport for your wireless connection, you may want to esure you have the latest firmware update installed on it. If not, the latest ATV update can throw them out of sinc with each other. I was having major issues with Netflix on ATV after I updated and discovered that my firmware needed to be updated as well in order to keep them communicating. Since the firmware update, the whole system is working perfect. No issues.

  • hellodrea Level 1 Level 1 (0 points)

    Hi, I am also having issues with getting Netflix to work. Everytime I boot it up on AppleTV, I get the message 'Netflix is currently unavailable. Please try again later.' I have tried rebooting AppleTV, rebooting my router, nada. I tried calling Netflix and Apple for help, nothing.

     

    Very frustrated here. Any thing else you think I should try?

  • Mike231a Level 1 Level 1 (0 points)

    What make router and are you using wireless or ethernet? Check to see if you need ATV software update (or firmware update  if you are using Apple airport.)

  • Karl Fish Level 1 Level 1 (0 points)

    I was so frustrated because I had the same problem (Error 139 on my ATV2). I tried rebooting, updating firmware, refreshing network settings - none of it worked. Here is how I finally fixed the problem:

     

    1) On a computer, go to Netflix, then click on Your Account

    2) Now click on  "Sign out of all devices."

     

    This worked for me, finally, although who knows it could have been a coincidence. I didn't need to reboot ATV2 to make the change work. Hope this helps!

  • larrylintz Level 1 Level 1 (0 points)

    I don't get error message, i get "Netflix currently not available" even though it totally is on my laptop.   arg. 

  • larrylintz Level 1 Level 1 (0 points)

    And then what, Karl, do you somehow sign back in?  I just tried it, it at least let me into the home page, but hwen i clicked on a program it said "netflix is currently not available, try again later."

Previous 1 49 50 51 52 53 Next