Skip navigation

Rosetta Stone/Internal Mic not working

146518 Views 66 Replies Latest reply: Feb 6, 2014 2:16 PM by karstonian RSS
  • kimberly williams1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 27, 2011 1:14 PM (in response to David_Tee)
    This worked great for me for the internal mic. Thanks David_Tee!
  • questionmarq Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2011 8:08 AM (in response to RocknRolla1950)
    This was a very frustrating issue for me! But i found a work around that works perfectly. Only disadvantage is you need to run two little apps.

    1. Get Soundflower: http://cycling74.com/products/soundflower/ and LineIn: http://www.rogueamoeba.com/freebies/
    2. In Soundflower / Audio Setup the "Soundflower (16ch)" should be set to "Input"
    "Format" has 44100 Hz and 16ch-32bit
    3. In LineIn set "Input form" to "Default System Input" and "Output to" to "Soundflower (16ch)"
    4. Click "Pass Thru"
    5. Start Rosetta Stone and in "Set Preferences" / "Audio Settings' select "Soundflower (16ch) - Microphone" and "Apply Changes"
    6. Enjoy Learning with Speech Recognition

    You always have to run the two programs with Rosetta Stone and make sure the pass thru is actvie. I used version 3.4.5.
    I hope this saves you some time and anger.
    MacBook Pro (15-inch, Mid 2010), Mac OS X (10.6.6)
  • 240VoltOutlet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2011 3:19 PM (in response to questionmarq)
    Everything works perfectly now. Thank you. It's kind of ridiculous that I have to run those two programs though.
    Mac OS X (10.6.4)
  • its_rich Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2011 3:16 PM (in response to RocknRolla1950)
    The solution that works best (for me) is the iPhone earphones. You simply plug them into the headphone jack, and the software will use that microphone.

    I tried the other permutations, but I didn't like the idea of shouting at the computer (otherwise the phrases always seemed to be faint), or inserting a tinny-sounding headset that had a persistent buzzing sound.
    Macbook Pro, Mac OS X (10.6.6)
  • cliotech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2011 9:07 AM (in response to mkolegue)
    I have been frustrated by the same problem. RS worked perfectly on my MBP 2008. When I upgraded in December 2010 the speak recognition stopped working. The sound input was garbled even though the sound input in GarageBand, Audacity, Skype, etc. all worked perfectly. Here is how I fixed the problem. On your Mac in System Preferences > Sound > Input select Line In. In RS > Set Preferences > Audio Settings select Built-in Microphone. Or, do it the other way around and select Internal Mic Microphone on your Mac and Built-in Input in in RS. Either way, it resolves the issue with your Mac competing with RS for use of the mic.
    MacBook Pro, Mac OS X (10.6.6), Rosetta Stone Version 3 (3.4.5)
  • Lorienne Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2011 7:58 AM (in response to cliotech)
    I tried this and it worked for sometime, after which it wouldn't recognize what I was saying either..I tried the iPhone headset and it's also not working..Do I have to use headsets with background noise cancellation..?..I know when I use RS with Windows 7, I don't have a problem even if I have a foreign language movie playing in the background..I think I'll try those two apps next..
    Macbook Pro, Mac OS X (10.5.8), iPhone 3G
  • Lizzzzzzzzie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 4, 2011 9:08 PM (in response to questionmarq)
    This was the answer for me, thanks so much! I never reply in forums but this Rosetta Stone thing was so frustrating, if other people are experiencing the same problem, they deserve to know a pretty easy fix.

    (Problem: Skipping recording, not recognizing answers, frustration.)

    Installing Soundflower took a few tries, finally this version (1.5.1) http://soundflower.en.softonic.com/mac worked. Soundflower is an extension NOT an application.

    I'm using iphone headphone/mic or MacBook built in speakers--super easy. The included headset is garbage.

    Thanks again!
    MacBook Pro 7.1, Mac OS X (10.6.7)
  • heyisa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2011 6:17 PM (in response to mkolegue)
    I just want to confirm that setting the mac sound to "Line In" (System Preferences > Sound > Input) and then opening the Rosetta stone program and then setting the Rosetta Mic settings to -Internal Microphone works. I had the stuttering issue until then, but now it seems to be working well.
    Macbook Pro 2010, Mac OS X (10.6.6)
  • hailflex Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2011 9:05 AM (in response to heyisa)

    Sadly i tried everything here and my RS wont even show any microphone options, whatever i try...

  • cliotech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 28, 2011 11:54 AM (in response to hailflex)

    Have you tried uninstalling RS and reinstalling?  If RS isn't even recognizing the microphones, that may be your best bet.  Just be sure you understand how RS deals with reinstalling and such.  Check out http://support.rosettastone.com/ics/support/default.asp?deptID=14042 .  It can be a nightmare if you uninstall and reinstall without first getting a new activation code.  I had that problem when I had to restore my system from a Time Machine backup.  It took almost 8 weeks to get the problem resolved with RS. 

  • jshrader90 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2011 8:36 PM (in response to RocknRolla1950)

    Solution:  Goto Sound Preferences and uncheck use ambient noise reduction.  Worked for me on a Macbook Pro Mid 2009 model.

  • Alex Khesin Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2011 8:24 PM (in response to jshrader90)

    My problem was that both internal and USB microphones were showing up when I went to Rosetta Stone Preferences, but Rosetta could not hear them when I went to Microphone Setup.  This was on Rosetta Stone version 4.  The cause of this was that RosettaStoneDaemon was running under a wrong user (the same computer is shared between adults in our family who do not use Rosetta Stone, and our daughter who does, but she uses a separate account to hopefully avoid breaking the computer).  The fix was to move LaunchAgent for RosettaStoneDaemon to only launch when our daughter logs into her account:

     

    Logged in as her:

    $ cp /Library/LaunchAgents/com.rosettastone.rosettastonedaemon.plist ~/Library/LaunchAgents

     

    Logged into an account that has Admin privleges:

    $ sudo rm /Library/LaunchAgents/com.rosettastone.rosettastonedaemon.plist

  • jrbeaudry Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 3, 2011 11:24 PM (in response to jshrader90)

    Solution:  Goto Sound Preferences and uncheck use ambient noise reduction.  Worked for me on a Macbook Pro Mid 2009 model.

     

    This worked for me, no problems now.

  • Vanderstein Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2011 3:21 PM (in response to RocknRolla1950)

    Thanks for the solution questionmarq, it was very helpful. The soundflower/linein worked like a charm. I found that you still might have to fiddle with the system preferences > sound > input settings as well. Hope everyone enjoys learning a new language!

  • bellabevo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2011 10:24 AM (in response to David_Tee)

    The fix offered by David_Tee worked for me.  RS mic was not working at all with my MB Air, so tossed the RS headset, reset everything per David's post and now it works great!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.