Previous 1 2 3 Next 75 Replies Latest reply: Oct 6, 2015 7:34 PM by shrumohana
RocknRolla1950 Level 1 Level 1
I have recently installed Rosetta Stone Version 3 (language software) on my Macbook Pro. I am having issues using the internal microphone with the software.

When I setup the microphone within the software and then do the test (say 1,2,3,4,5 into the microphone as a test), the program tells me everything is working fine. However, during the lessons, when speech recognition is necessary, the microphone doesn't work.

Firstly, the speaker will say a work, then when it's my turn, it's as if the microphone is not being recognized and is quickly turning on and off as if it's trying to hear something. Secondly, every time the microphone is enabled and disabled, it turns up the microphone input volume (System Preferences > Sound > Input > sliding bar with low to high) one tick until it's at the top of the bar; thus rendering the microphone useless due to an overload of ambient noise.

Any suggestions or tips? I know Mac users must have this working. However, all the info I can find is a bunch of frustrated Mac people and a lot of finger pointing between Apple and Rosetta Stone.


MacBook Pro, Mac OS X (10.6.4)
  • lcmbp Level 1 Level 1
    Hello, did you have any luck with a solution? Thanks!
  • Varunph Level 1 Level 1
    im having the same problem. internal mic not working with rosetta stone 3.4.5

    any suggestions appreciated
  • Pickle Pumpers Level 1 Level 1
    I was having all sorts of problems with stuttering input. Like when I set up the mic it wouldn't let me get to 5, it would say the mic was set up before I even got to 3 and when trying to practice the sound was stuttering horribly.

    Then I had an idea. It seems counter intuitive but what I did to fix it was change my audio input device in System Preferences (under sound) to Line In, in other words not the internal built-in microphone. Then in Rosetta I did pick the built-in microphone as my input. I think what was happening for was the OS and Rosetta were both trying to use the mic and that was the source of my problems.

    Anyway if you have the same symptoms as me try turning off the mic in the System Preferences app and see if that works. It worked great for me.
  • MallardRider Level 1 Level 1
    Mine is a different problem. And this is with a Mac Pro desktop.

    First off, the USB headset never works. I tried the Rosetta Stone-supplied headset and a Logitech G330 (normally used for in-game chatting) and they did not work in the Rosetta program - versions 3 and 4.

    I used an external mic and opted for the line input. Rosetta worked perfectly. I went all the way through Level 2. (Language I am learning is German), and even managed to converse with a German online tutor in Seattle (a feature in Version 4's TOTALe software).

    Until two weeks ago. The line input is now kaput. This might have been related to a recent software update they made. The software update has now broken Rosetta and I cannot use any inputs at all. And "kaputt" is not a German word I want to keep learning about Rosetta's software!

    Already called technical support. I am led to believe that there's something in the software that is refusing to take any input. The tech support call took almost an hour with little progress (I'm sure their technicians have already noted about it). I have nothing against the South Asians here on Apple Discussions, but their tech support team needs work.

    Fluenz, though, had no problems. Fluenz is a competing language learning provider, but unlike Rosetta, only offer five languages - neither of them is German - and does not use speech recognition like Rosetta. However, there were absolutely no problems with Fluenz receiving any audio input.

    Too bad. Rosetta actually worked wonders - when it worked.
  • EmperorPratt Level 1 Level 1
    I had the same problem, but I think I found a helpful (but imperfect) fix. As it turns out, when you set the microphone preference to 'Internal Microphone,' Rosetta Stone takes it upon itself to change the input volume as it pleases--usually to full. This is bad because the computer will hear a pounding, garbled, static-filled mess instead of the simple word you think you're saying. I don't remember how I got to it, but somewhere in Rosetta's preferences you can listen to how you sound (and visually compare your sound wave to the correct answer so as to tweak your intonation and articulation), and this is where I discovered the problem.

    The solution: open System Preferences, go to "Sound," select the "Input" tab, and then set the "Input Volume" to the halfway mark. The computer will hear you much more clearly, and you should do fine on your lessons. Keep System Prefs open throughout the lesson, because Rosetta Stone will actually reset your input volume to full when you first open the program, to 3/4 when you try to calibrate with '1, 2, 3, 4, 5,' and then back up to full if you happen to mess up too many times in a row thereafter.

    It's frustrating to have to keep on adjusting the volume while you're trying to concentrate, I know, but at least it gets to the heart of the issue. Perhaps there's a script floating around that can take care of this, but my (admittedly limited) searches have turned up nothing. Such as it is, I hope this helps!
  • SC72 Level 1 Level 1
    Thanks - worked like a charm!
  • SC72 Level 1 Level 1
    I was referring to Pickle Pumpers fix
  • leggman7 Level 1 Level 1
    I too am having this issue. Rosetta stone 3.2.11, and 10.6.5. I used to be able to use speech with either the built in mic or headset mic, and now can't. This is frustrating.
  • KJK555 Level 4 Level 4
    I solved the mic issues I was having with mac dictate, made by Nuance (dragon) by disregarding
    the plantonics usb adapter and replacing it with a Griffin iMic usb adapter.
  • David_Tee Level 1 Level 1
    I tried to get the headphones working on my MacBook Pro, but didn't manage it. I then unplugged the headset, went back to trying to get the internal microphone working properly and this time selected Input / Line In (Audio Line In Port) from the System Preferences / Sound / Input Menu. I set the volume to 75% and it's working like a dream. I have no idea why!!

    I'm happy that's it's working but given the cost, RS should really have made sure this was all working perfectly straight out of the box.
  • Ladanada1 Level 1 Level 1
    Thanks to the poster who showed how to set the audio input device to line in, as this has worked well on my iMac 27 with Rosetta Stone 3.4.5
  • darkcody Level 1 Level 1
    Pickle Pumpers had it dead on. I set the system preferences mic selection to line in and set rosetta stone to built in mic and that solved the problem for me. Thanks for the advice!
  • Edd Cox Level 1 Level 1
    System preferences / sound
    Set Output to USB VoIP Device and Input to Line In

    This solved it for me.
  • mkolegue Level 1 Level 1
    People keep saying pick Line In in the Input. Is this because you are trying to use the headset?

    Does anyone have another suggestion (besides the constant lowering of volume) if you are not using a headset? I tried it and it is not going very smoothly.

Previous 1 2 3 Next