Previous 1 2 3 Next 77 Replies Latest reply: Feb 21, 2013 6:55 AM by mdominic70
Phil McFarlane Level 2 Level 2 (440 points)
Hi gang,

Setup of my 2nd Gen ATV has gone very smoothly. Only one problem. All movies play as stereo, even when there is a 5.1 surround track. When I go into the Audio settings, if I turn Dolby Digital from Auto to On and then play a movie, my receiver say "Stereo Downmix". My ATV and receiver are connected by an HDMI cable.

Any ideas?

Cheers!

MacBook Pro, Mac OS X (10.6.1)
  • Skrocki Level 1 Level 1 (135 points)
    If you are connected from ATV to TV then to your receiver, your TV may only be capable of outputting a stereo signal. This is the situation with my Samsung plasma TV. In order to get Dolby Digital, I have to connect from ATV directly to the receiver with the optical audio cable.
  • Phil McFarlane Level 2 Level 2 (440 points)
    Thanks Skrocki,

    My setup is Apple TV -> Receiver -> TV. HDMI all the way.

    Cheers!
  • TRado Level 1 Level 1 (0 points)
    I'm having the same exact problem. What is up with 5.1 surround. I've tried ATV > Receiver both with only HDMI, and also with HDMI plus SPDIF for audio. Both only play in stereo here to. Keep me posted if you find a fix.
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    I had the same issue tonight but it magically corrected itself after I played an iTunes-purchased video with 5.1 audio -- in this case, the free series premiere of LAW & ORDER: LOS ANGELES. After trying that one and getting 5.1 sound, I went back to my own Handbrake-encoded movies and TV shows and lo & behold, suddenly the 5.1 audio is working on everything!

    Anyone else have any luck with that?

    JRB
  • Mb1000 Level 1 Level 1 (0 points)
    Try optical!
  • Vassillios Level 1 Level 1 (0 points)
    "Try optical! "

    What a ridiculous statement. The whole point of HDMI is to carry video and multi-channel audio.
  • TRado Level 1 Level 1 (0 points)
    I did (as I stated above) and it doesn't work.
  • Phil McFarlane Level 2 Level 2 (440 points)
    Thanks JRB,

    I tried playing the movie Star Trek, purchased from the Apple Store, and it didn't kick start the 5.1. Maybe I'll try renting something and see if things are different.

    BTW, my old Apple TV worked fine on this setup.

    Cheers!
  • BobPenn Level 1 Level 1 (30 points)
    I had the same problem. My 5.1 purchase of a TV show was coming in stereo. I went to the audio and video part of the menu and saw that the Dolby Digital was set to "auto." I reset it to "on" and 5.1 started working. I assume that the auto setting doesn't detect properly.
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    Interesting that this thread isn't getting more posts... I find it hard to believe that only a few of us aren't getting 5.1 audio playback!

    For those of you my earlier tip didn't work for: You might also try the following tip to enable 5.1 passthrough on your Mac via iTunes... I had actually done that first but it didn't change anything on ATV until I played an iTunes-purchased video and then suddenly all of my Handbrake videos also started playing 5.1, so I think one or the other must have jarred something awake on the ATV. (I should note that I am using only HDMI so I can't vouch for the optical audio out.)

    http://www.macworld.com/article/150554/2010/04/itunes_surround.html

    In any event, it seems that Apple may have some work to do in the next ATV update to correct this situation, but the above worked for me and it's continued to work even after unplugging the ATV and booting it back up, so it's worth a try...

    JRB
  • Phil McFarlane Level 2 Level 2 (440 points)
    OK,

    I think I've made some progress. Turned Dolby Digital ON. When my receiver came up saying "Stereo Downmix", I scrolled through my receiver's surround sound options until it came up Dolby Digital. Now when the Apple TV is in menu mode, my receiver says "Stereo", when a movie plays it says Dolby Digital. Maybe the Apple TV doesn't tell the receiver what type of surround sound it is sending?

    Anyways, seems to work now, but more testing is required.

    Cheers!
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    I think I've stumbled on at least one thing that makes a difference: When the audio language is set to English (ATV settings) I get stereo and no 5.1... when it's set to Default, I get 5.1. It also seems to help to switch the Digital Out from Auto to On as mentioned above...

    JRB
  • MoBoarder Level 1 Level 1 (0 points)
    I've switched around everything. Using optical, but still no 5.1...... argh
  • Phil McFarlane Level 2 Level 2 (440 points)
    Yup, that seems to have fixed it.
    Usually my receiver can detect what kind of surround sound is being fed to it (Dolby Digital 5.1, DTS, etc). In the case of the new Apple TV, the receiver defaulted to Downmix Stereo, but was happy for me to change it manually to Dolby Digital. Now the receiver switches to Dolby Digital on its own when the Apple TV feeds it a surround sound signal.

    It's like the new Apple TV has forgotten to send a signal to the receiver describing the type of surround sound that it is sending, and the receiver has to make a guess. For those with the same problem, try feeding a 5.1 Dolby Digital signal from the Apple TV to your receiver, and then manually change your surround mode to Dolby Digital on the receiver, and see if that works.

    Cheers!
Previous 1 2 3 Next