Previous 1 2 Next 18 Replies Latest reply: Feb 8, 2014 2:57 PM by widestrides
jimthing Level 1 Level 1 (55 points)
Background:
• I've 3 email accounts (1 Gmail, 1 pseudo-Gmail, 1 MobileMe) — all IMAP.
(The "pseudo" is from Virgin Media in the UK, and uses Gmail as it's back-end, just Virgin branding on the front).
• Issue doesn't happen with MobileMe.
• Issue only happens in Mail.app on my Mac (not webmail or iPhone 4).

Issue:
For example, I compose an email and it takes me say 10 mins, then either send or save as draft. If I do either of these things, when I goto the Trash folder on either account, I have auto-save versions appearing in there, which look to be saving every 30 seconds of my typing on the email (I can tell this from the dupe email date+time's, and the text gradually revealing itself as I skim through these dupe emails).

Why is this happening? It's SO annoying!

I have been through the Settings on both Gmail accounts online and on my Mac, with no setting there to deal with this. Why on earth are emails getting auto-saved as I type, and if so, why are they saving as separate emails rather than just saving as a single email.

Virgin Media tech support were of NO help for me as a Mac user (as ever!) and blame Mail.app for the issue which they don't offer tech support for.

As an experienced user, I can't believe I just can't solve this stupid situation. Any help on this greatly appreciated.

2x MBP 2.93GHz, 4GB RAM, OS X 10.6.4 "Snow Leopard"/32GB iPhone 4, OS 4.1
  • jimthing Level 1 Level 1 (55 points)
    Anyone?
    Is there a reason Google email is saving inside mail.app every 30 seconds?
  • jimthing Level 1 Level 1 (55 points)
    bump
  • Toby Cockcroft Level 3 Level 3 (945 points)
    I'm seeing the exact same thing. The trash will show multiple versions of the same email as I'm composing it with the edits and so on along the way. It is a bit annoying.

    At first I thought for some reason it was just randomly deleting emails.
  • jimthing Level 1 Level 1 (55 points)
    Yeah, still doing it, thanks for response. Glad to know I'm not the only one.

    Seems in Mail.app the Gmail sending functions do not work with clients as they clearly should. And Google's help sections do not specify enough detail on correct set-up to make outgoing mail correctly work in clients outside of their webmail services, which users clearly need to use currently (until proper cloud-computing functions hit in the future) in order to unify mailboxes with other non-Google services.

    Gmail Apps (backends to ISP's) & Gmail itself, both have differing settings that on top of this are causing controversy, in that they have differing controls for mailbox behaviours between them.

    Can Apple get on Google's back on these. Though unlikely, as Apple's investing in it's next-wave of MobileMe technology data centres, and (let me guess) couldn't give a toss.

    Simply unacceptable.
  • Toby Cockcroft Level 3 Level 3 (945 points)
    Quick question. Do you have Use IDLE command turned on in the Advanced section of your Gmail account in Mail?

    I just turned it on to see if it made a change and so far stuff isn't showing up in the trash.

    No guarantee that it won't do it again but perhaps it will help.
  • jimthing Level 1 Level 1 (55 points)
    Yes, in order to get emails show as soon as they arrive. (both in Gmail and ntlworld.com "Gmail Apps" accounts.) — this shouldn't be a wrong setting if Google set this to work correctly surely...?

    Mac help says:
    " Use IDLE command if the server supports it:

    Specify that the server should notify Mail when new messages are available for your Inbox. This method is known as “push email.” This option is available only for IMAP accounts.
    When this option is not selected, Mail checks for new messages by connecting to and querying the server at regular intervals. "

    Really nothing to do with wrong functionality, AFAICS.

    Yours still perplexed
  • Toby Cockcroft Level 3 Level 3 (945 points)
    I figured it may have something to do with how often Mail is checking the Gmail box. Perhaps what it is doing is synchronizing and updating the Gmail Drafts mailbox with a copy and then every time it synchronizes it trashes the old copy and uploads a new one.
  • jimthing Level 1 Level 1 (55 points)
    (sorry i edited my previous post, mid your reply)

    Yes, sounds perhaps plausible. If right, it shouldn't be doing this in order to work correctly should it.

    I emailed and commented in the Google help forums, but got no response from either Gmail support staff (do they exist?) nor other users. So who knows any fix?
  • hakunamatita Level 2 Level 2 (215 points)
    Have you already tried Mail:Preference:[Click on your Gmail account]:Mailbox Behaviors:[Uncheck "Store Draft Messages on the Server"]?
  • jimthing Level 1 Level 1 (55 points)
    Tried, it did nothing for this behaviour.
    (Left it ticked, as I actually NEED my drafts to be on the server, otherwise what is the point of IMAP email for cross-device usage!)

    @ Toby, is that the issue? I don't think so personally (though I do notice the "ping" noise on new mail arriving in mail.app doesn't work at the same time as new mail actually arrives, but I think this is a separate bug, as it's the same for my me.com account too :-/ ).
  • jimthing Level 1 Level 1 (55 points)
    Anything new on this, does anybody know?

    (I have reported several times to Virgin Media tech support, and they didn't even know about it. In fact they say tech issues with their email are not even their responsibility but is now Google's? Oh how helpful Virgin!
    What does that mean, you may ask? Well, the last VM tech I spoke to said they have no control of their email problems AT ALL, they just pass them over to Google, and suggest us as THEIR [ie. VIRGIN ?!] customers check the Google Apps forums — do separate non-Gmail "Google Apps" forums even exist: I never found them?!)
  • jimthing Level 1 Level 1 (55 points)
    Still doing it.
    Months pass and this is annoying. Anyone found a solution yet?

    Surely one of you Mac tech heads has found a way of "storing Drafts on server" with Google Apps email accounts (or even plain Gmail accounts, perhaps) without this issue; and if so what settings do you use in Mail.app and/or iPhone ??
  • dcon Level 1 Level 1 (0 points)

    any update on this. have same issue.

  • siliconbreath Level 1 Level 1 (0 points)

    Well, I came accross a blog     http://blog.xiao-ma.com/2011/02/20/make-apple-mail-app-likes-gmail/

     

    and while I found great configuaration help for Mail and Gmail, I think our problem is being answered.

     

    You find it under step for: Do not save Draft on Gmail

    To not save draft on Gmail, go to “Preference” -> “Account” -> “Mailbox Behaviors” and uncheck “Store draft messages on the server”. The risk of doing this is that drafts composed in Apple Mail.app won’t show up in Gmail’s draft box.

Previous 1 2 Next