Previous 1 2 Next 20 Replies Latest reply: Mar 19, 2012 10:16 AM by sotiris
dano007 Level 1 Level 1 (0 points)
I have Apple TV gen 2 connected wirelessly to my home network. I cannot find my iMac library with Home Sharing enabled. All network connections are active and correct. My only question is: How dependent on the internet speed is ATV? If the connection is slow (slightly higher than dial-up), will there be problems syncing libraries?

Any thoughts would be greatly appreciated.

MacBook Air, iMac, ATV, iPad, iPhone, Mac OS X (10.6.4)
  • HeyJP Level 4 Level 4 (2,375 points)
    Dan,

    First, make sure you have enabled Home Sharing on both the Apple TV2 and on your Mac/PC iTunes library. You must use the same iTunes account and password for both.

    Network speed: Your network speed should not have an effect on SEEING the iTunes library, but it certainly will have an impact on how fast the library lists are transferred. On a slow network and a very large (mult-gigabyte) iTunes library, it could take several minutes for them to connect and transfer directories.

    Lastly, I could see you having a slow out-of-house connection to the Internet, but why is your internal WiFi as slow as a dialup? no matter what your technology, the WiFi should be many megabits per second which is all that matters for connecting to an iTunes library. External speed will have no effect.

    Jim
  • dano007 Level 1 Level 1 (0 points)
    Jim,
    Thanks for the info. Just to clarify, the WiFi is fast and runs the house no troubles. The internet connection is the slow part. The library is large. However, I cannot even see the other computers. Will the computer not show up if the library is not loaded? Or will the computer show up and then the library will take time to load?

    I will look for Home Sharing on the ATV. I did not see a setting for that but figured if my iTunes account and password are in it would just work.

    Thanks again.
    Dan
  • dano007 Level 1 Level 1 (0 points)
    I have home sharing enabled on all machines including ATV. I am sitting here on my MacBook Air and, with home sharing enabled, nothing. I believe to have all permission settings correct. Firewall off. I don't know where to check next.

    Any thoughts? It did work once. Once.

    Dan
  • jdalvis Level 1 Level 1 (10 points)
    I had similar problems, and I think it was DNS related.

    My apple tv and macbook were both part of the same network, but my router had external DNS servers set instead of using itself as the DNS server.

    I set my macbook and apple tv to use the router for DNS, and it worked.
    Your router is likely a 192.168.1.1 or 10.0.0.1 address, so setting your atv2 and machine running itunes to use the router for DNS, should solve it.

    Good luck!
  • rikithemonk Level 1 Level 1 (10 points)
    I had this issue, the fix is easy. Go to your computers Itunes and turn home sharing off, then back on again. For some reason, reenabling it allows the apple TV to see it.
  • dano007 Level 1 Level 1 (0 points)
    DNS is the same for every computer. Also, Home Sharing has been rebooted hundreds of times and to no avail.

    Dan
  • rikithemonk Level 1 Level 1 (10 points)
    Thats fine, Im just saying what worked for me.

    I purchased 2 Apple TV's. One for me and one for my parents who live in my same town. Both networks are small and basic. During the unboxing and set up of the apple tv's on both homes, the apple TV's went able to see the shared libraries. Tried reentering the account info on the Apple TV figuring I may have made a typo. No fix. My second thought was rebooting the computer and the AppleTV. Again there was no change. I then disabled the home sharing on the computer and reenabled it. This fixed my issue. Again this happened on both networks and were resolved in the same way.

    Now, here are the variables on both networks.

    Parents network. DSL Modem connects to 4 port Linksys switch (no router) Windows XP SP3 PC connects directly to switch as well. PC, fully patched and all updates current, running latest ver of iTunes. Airport Express connects to switch as well. Airport Express set to bridging mode with WPA2 home security set. Apple TV connects to Airport through WiFi showing full bars. DNS and DHCP coming from the DSL Modem.

    My network. Cable Modem connects to Airport Extreme. Airport Extreme set to firewall, Wifi enabled wit WPA2 Security. DNS and DHCP provided by the Airport. The Airport, two Macs, and two PC's connect to a Linksys 8 port switch via ethernet cables. Both macs have shared libraries and are running latest iTunes and Snow Leopard is fully updated. My Apple TV connects via Wifi to the Airport Extreme and receives full bars.

    Oh, by the way, the firmware is current on both Airports.

    Like I say, my issue with the home sharing is resolved, but i'm giving you this info because it may help you to identify whats going on with yours. If you check my other posts you will see that Im having problems of a different sort now. Its a download delay issue on both of the units, but because both networks check out fine, and the issue doesn't effect netflix, its my opinion that that particular problem is on Apples end.


    Good luck

    Chris
  • xgus68 Level 1 Level 1 (5 points)
    I'm having thesame problem... My Apple TV is not recognizing my iTunes library.. I did the dns thing.. and its set to the same.. still nothing.
  • Jerry M. Level 1 Level 1 (0 points)
    I had the same problem and it turned out that I was not running the newest version of iTunes (10.0.1). It was released around the day Apple TV shipped, but without announcement. Once I update iTunes everything worked fine. Maybe this is the little missing detail?
  • dano007 Level 1 Level 1 (0 points)
    The ATV connected to the iTunes library of both computers. Horray! And then surprise surprise, disconnected and could not find it. I believe that the connectivity to the internet is very important. I don't know what is being sent other than the apple login but it seems to be very important to be connected.

    Does anyone know if it can operate without internet?
  • Dazzler2409 Level 1 Level 1 (0 points)
    I managed to get connected to library without Internet. I have to add it take some doing and some searching ifmthese very forums...

    I set up laptop and ATV at parents house as our broadband not installed yet (just moved home). Activated home sharing via Internet as has to login to iTunes account. Then brought all home and connected to home network and runs pretty much ok. Only problem now is streaming photos doesn't seem to go very deep into folder on random and seems to repeat only first 50 or so photos when running as screen saver or slide show?

    Can't wait for broadband to be installed, 11th Nov is big date and seems an eternity away!!!
  • Madelline Level 1 Level 1 (35 points)
    Some of the tips suggested here have been found to help many people but I'd recommend visiting the following article for a more complete list of troubleshooting tips:

    http://support.apple.com/kb/ts3509
  • Johnnyboy13 Level 1 Level 1 (0 points)
    I have recently bought a new macbook pro 13" and my apple tv (gen 2) is playing up beyond belief. Firewall is off, all home sharing settings and other settings are correct yet ATV keeps telling me I have nothing in my library at all.

    I have had to reset the device, which took 3 attempts.

    Its getting a wee bit annoying now. When I reset the device it worked fine for about 5 mins then just went back to how it previously been.
  • andyek Level 1 Level 1 (0 points)
    I'm having similar problems. I bought the ATV2 as soon as it came out, and had no problem streaming from my library or the internet, and had no problem with the iPad/iPhone remote app controlling either the ATV or the iTunes library on my mac.

    However, the iOS 4.3 update (and the ATV2 4.2 update) have created HUGE communication problems for me. I have not changed my network settings at all and yet I can no longer view my iTunes Library in the "Computers" tab of the ATV, nor can I connect to either iTunes or the Apple TV with the Remote App. What's going on?!

    My network is a little funky, as I use a wireless repeater to boost the signal from our main router. When I connect to the MAIN network (which has a weak signal), all of the devices seem to place nice. However, when I use the boosted signal (which worked until when I just updated my firmware) the devices to not even acknowledge one another. Any idea as to what could be happening?
Previous 1 2 Next