1 47 48 49 50 51 Previous Next 763 Replies Latest reply: May 19, 2014 9:57 AM by FLUXFAZE Go to original post
  • 720. Re: Apple TV HD Rental Streaming Problem
    vazandrew Level 6 Level 6 (14,045 points)

    720P on iTunes requires a 6mbps for instant playback, 1080 requires 8mbps. The device doesn't have storage so of course turning off/restarting it (or accessing other content) will require a reload.

     

    Speed is the first thing to look at and it does matter. Other common factors are interference and using a non ISP DNS.

     

    Youtube content is highly compressed, and often short. Not a good comparison. Netflix uses a method where it adapts based on your connection. iTunes quality is fixed, this is why it requires a wait on a slower connection (it starts once enough has buffered in order for smooth playback)

     

    It does work for the majority so if you're interested in troubleshooting (rather than ranting), and getting it to work that's your choice.

  • 721. Re: Apple TV HD Rental Streaming Problem
    Bradley_NZ Level 1 Level 1 (0 points)

    vazandrew the apple apologist; generally your correct. That said, even on standard res I get the same issue.

    While I'm not disputing your points, clearly there is an buffering issue. If I allow the buffer to the point I get "Play the movie Now" and select "Watch Later", when I resume the movie it'll play right up to the end of the buffer and stop. Same if I start watching it and stop the movie half way and continue it later. It's a well posted issue years old, a lesser problem for some, others put up with it, some don't know because theirs works or they don't do rentals. There is more than enough memory on the Apple TV to buffer this. Standard res would fit the whole thing as a buffered video. Even skipping to a chapter won’t seem to kick start the buffer loading.

    I have yet to find anyone who's had issue post a solution, other than work-around (stream from their PC) or return the box. More than happy to try anything at this point. I requested help from Apple and got an email telling me how to troubleshoot Airplay or download it with iTunes (which requires a re-purchase).

  • 722. Re: Apple TV HD Rental Streaming Problem
    vazandrew Level 6 Level 6 (14,045 points)

    I'm not an Apple apologist, just stating the facts. If there was a flaw on Apples end and even half the user base was experiencing it as a result, I would take notice.  This is not the case. People have solved buffering issues by isolating things on their network and for most cases that is the cause.

     

    What have you done to troubleshoot so far?

  • 723. Re: Apple TV HD Rental Streaming Problem
    Vincent Smith1 Level 1 Level 1 (25 points)

    Just stating the facts also AppleTV is not a consumer friendly product. It should Ll of the configuring/ optimization on its own.

  • 724. Re: Apple TV HD Rental Streaming Problem
    vazandrew Level 6 Level 6 (14,045 points)

    It is as much as it can be, but it's a streaming device so one still has to make sure their network is adequate

  • 725. Re: Apple TV HD Rental Streaming Problem
    LizMacBook Level 1 Level 1 (0 points)

    I so want to make sure my network is adequate. I experience these messages all the time. Download will take 232 minutes etc. All the time, whether HD or standard rental. However if I do the same download on my iPad, same home network, maybe 5 feet away from Apple TV, I get the movie no problem and can watch on my iPad. I received the new Apple TV for Christmas but four months ago and thought that would take care of it, since I had been using a first generation Apple TV with the same issues. However it didn't take care of the problem.. I don't understand why it works on my iPad but not on Apple TV. When I go to settings on Apple TV it shows a strong connection. What should I be checking? I use Comcast and I live in San Francisco. Unfortunately Apple support has no ideas. All they do is reimburse me for a movie if I was never able to watch it. That's a kind gesture, but I'd really like to be able to use their product. Surely I can fix this. Ideas?

  • 726. Re: Apple TV HD Rental Streaming Problem
    vazandrew Level 6 Level 6 (14,045 points)

    Check www.speedtest.net for connection speed

    Check www.istumbler.net (netstumbler for windows) to check interference

     

    Make sure you are using your ISPs DNS

     

    http://support.apple.com/kb/TS3623?viewlocale=en_US&locale=en_US

  • 727. Re: Apple TV HD Rental Streaming Problem
    VancrMarko Level 1 Level 1 (0 points)

    I have an ATV 3 (my second one actually since I returned the first assuming slow downloads were a defect in the machine) with sloooow downloads.  My wifi is never slower than 16 Mbps in the room where the ATV resides.  Sometimes it is up to 26 Mbps. Notwithstanding that it can take 30 minutes before a 45 minute show is ready to watch.  Applecare can't find an issue with my Airport Extreme or my ATV. I am using my ISP's DNS which Applecare said is correct. They say they have no knowledge of whether Apple is having server issues.  What's up?

  • 728. Re: Apple TV HD Rental Streaming Problem
    Graham Brown-Martin Level 1 Level 1 (0 points)

    Here's my solution - I hope it helps at least a few of the people here or points them to a solution for their own set-up.

     

    I've been following this lengthy discussion ever since I first had problems with a migration from ATV 2 from ATV 1.

     

    The ATV 1's always worked pretty much perfectly (with only occasional buffering issues) but as soon as a I switched to ATV 2's I couldn't stream HD or SD movies via the ATV 2's without the constant stop and start of buffering or indeed as many people here have reported not even getting to the point of playing. I'm thinking that the ATV 1's worked because of their internal hard discs which the ATV 2's don't have and this helped with the buffering.

     

    As a temporary fix I was using a Mac Mini as an iTunes server (which serves my audio and photo collection to the ATV 2's plus all my ripped DVD's & Blu-Rays). Using this server I would rent or buy HD movies from iTunes and then stream them from the server to the ATV's without problem although this approach kinda defeats the object of having an inexpensive ATV device.

     

    That said this set-up gave me a clue that something was wrong as I would get strange and wildly variable download times after purchasing a rental or movie. Sometimes the download would stall for a while and sometimes it would suggest very long download times for a 3Gb file such as 20 hours, etc. I found my stopping and starting the download on the server or switching my router on and off things would speed up for a while and so on. So these were clues that something wasn't right.

     

    This was despite a 50Mb cable connection provided by my ISP in the UK VirginMedia. Every other streaming system was working including YouTube, NetFlix, etc but as other have pointed out NetFlix uses a different streaming approach that shapes it's transfer rate & quality based on what speed you have so if there is a glitch in your set-up you may not notice it as easily with NetFlix.

     

    Anyway with the help of this forum and others I eventually arrived at a solution that has fixed my streaming problems with the ATV 2's (and I suspect this will work with ATV 3's). It may not work for everybody but it may point people in the direction of a solution. It's a shame that the ATV isn't plug and play in the way that I feel a consumer product should be but here we are!

     

    My set-up

     

    VirginMedia cable 50Mbs using their SuperHub router.

    Time Capsule (TC)

    Airport Extreme (AE)

    2 x ATV 2

    2 x ATV 1

     

    So, after a lot of experimentation, this is what eventually worked and is now flawless:

     

    I disabled the Flood Protection and IPsec pass-through features of the routers Firewall protection and put it into modem mode.

     

    The TC was then connected to the Virgin Media cable router (that was now in modem mode) and became the router.

     

    The AE was used to wirelessly extend the network to other parts of the house (it's a large/tall Virctorian terrace house!)

     

    I downloaded version 5.6 of the Airport Utility and then downgraded the firmware of the TC and AE to version 7.5.2

     

    I have one ATV 2 connected via Ethernet to the TC in my living room and the other ATV 2 and two ATV 1's are distributed around the house and connected wirelessly to the network.

     

    They all work fine and often simulataneously given we have kids etc.

     

    The 1st "break-thru" moment in this journey was the disabling of firewall features in the cable router which solved most problems until Apple upgraded their AE/TC firmware to 7.6.1

     

    The 2nd break-thru was discovering that Apple's AE/TC firmware was messing with the set-up. A quick downgrade and then, like magic, everything worked.

     

    I don't expect this to work for everyone but it worked for me and I did set things back (especially the AE/TC firmware) to double check that it was really this that was causing problems.

     

    My guess is that something in the Firewall protection in the original router was preventing the ATV 2's to stream in the way they want to and that there's a similar problem in the latest AE/TC firmware or a combination thereof - either way this still seems like alchemy and not something you'd expect from a consumer product from Apple.

     

    Good luck everybody!

  • 729. Re: Apple TV HD Rental Streaming Problem
    markmyles Level 1 Level 1 (0 points)

    I have the same problem.

     

    My internet speed is not the issue (21 - 25 Mbps), pretty sure that Apple servers are the issue.

     

    Here's my solution, since its happens to me again and again:

    1. Open iTunes and go to your account history.
    2. Click on "Report a Problem" on the movie that was slow to download or didn't download.
    3. Tell Apple exactly what happened (that it was not streaming at the speed it ought to have and didn't download properly).
    4. Wait for a reply.

     

    Usually, the reply I get is, "Sorry. Here's your money back."

     

    They don't seem to be doing anything about it except that they seem to be aware of the issue and are appeasing frustrated customers with refunds.

     

    If everyone starts getting their money back, eventually Apple will have to fix the problem. Either that, or I start renting DVD's & Bluerays again.

  • 730. Re: Apple TV HD Rental Streaming Problem
    synaptech Level 1 Level 1 (0 points)

    Thanks I wil give this a try.

  • 731. Re: Apple TV HD Rental Streaming Problem
    Lunchbox48 Level 1 Level 1 (0 points)

    My problem resulted from using google DNS. I fixed it by manually configuring the DNS on the AppleTV to pull DNS from comcast instead of my router/airport.

  • 732. Re: Apple TV HD Rental Streaming Problem
    Mile High Joe Level 1 Level 1 (0 points)

    Mine was a Apple TV software problem.

     

    All I had to do was go back to the last program I watched and let it finish.  (I had stopped it before the end.)

     

    Somehow that unclogged the pipes.  Now I'm back to near-instant streaming.

     

    Problem solved.

  • 733. Re: Apple TV HD Rental Streaming Problem
    Bfattuck Level 1 Level 1 (0 points)

    I just figured out how to fix my streaming problem!....thought I would share. I'm using an AppleTV 2nd Gen.

     

    My issue was that streaming content from iTunes on my Mac Book Pro was incredibly slow: just trying to play a song via AppleTV from my laptop was taking 2 minutes or so before the music would start. You could forget about streaming videos. I knew that my network and internet was working fine and I had reset both iTunes and AppleTV several times. I kept hoping a software update would take care of the problem but it didn't. The one thing that was working was that I was able to AirPlay music from my iPhone without delay.

     

    Solution: It turns out the problem was I'm using a dual band router (Netgear WNDR3400) which offers two channels, one at 2.4GHrz and at 5GHz. The AppleTV and my MB Pro were both on the 5GHz channel while my iPhone was on the 2.4GHz channel. As soon as I switch the AppleTV over to the 2.4GHz channel, the problem went away (even though my MB Pro remained on 5GHz). Movies and Music load up quick as can be, just like before! My assuption is that the AppleTV does not like operating on the 5GHz channel. I haven't tested it, but alternatively, it could possibly be a security setting issue: my 2.4 channel is using WEP while the 5GHz is using WPA2.

     

    I hope this helps others!

  • 734. Re: Apple TV HD Rental Streaming Problem
    jtclary89 Level 1 Level 1 (0 points)

    YOU SIR ARE AMAZING!!! That's exactly what my problem was. I was operating my Apple TV on the 5 GHz bandwidth, instead of the 2.4 GHz. Switched over and it completely solved my problem. Thank you kind sir!