1 3 4 5 6 7 Previous Next 129 Replies Latest reply: Dec 13, 2010 2:09 PM by Steve Hoge Go to original post
  • 60. Re: aperture library not showing in mail, iweb or iphoto
    jlinaschke Level 1 Level 1 (20 points)
    That's a fantastic find! I had a similar issue back in Aperture 2; it didn't manifest itself in that way but I had these exact null file problems. Not a clue how they got there, but if I recall correctly it also was tif files, meaning (in my case) they were all files that had been externally edited with a plugin.

    Anyway, thanks for posting that find. Awesome.

    -Joseph @ApertureExpert
    ApertureExpert.com
  • 61. Re: aperture library not showing in mail, iweb or iphoto
    Ernie Stamper Level 8 Level 8 (37,475 points)
    I am having trouble buying that explanation and solution. I have one Library that while having a few TIFFs, seems to have the date metadata in order, but still refuses to load. With those dates on those TIFFs, Aperture itself sorts them in the correct order.

    The issue would seem to be in the media browser, which prior to the upgrade of the Library by 3.1 could read them just fine.

    As time allows, I will create a new library with no TIFFs at all, and only images from a digital camera to test this further. My own opinion is that the media browser needs a fix.

    Ernie
  • 62. Re: aperture library not showing in mail, iweb or iphoto
    adrianbruce Level 1 Level 1 (0 points)
    Following the advice Adrian Wackernah received, I also did a search of my library and found just ONE Photoshop (PSD) image without a date stamp. Have duly adjusted the date and now the iLife media browser is again working without having to put a "Read Only" flag on the iLifeShared folder in the Aperture library.

    Great that the problem is at last properly solved!
  • 63. Re: aperture library not showing in mail, iweb or iphoto
    Andy Hewitt Level 1 Level 1 (70 points)
    This seems to have also been my problem too. I found 6 PSD files that had no dates. I have added the dates, and likewise I can now access photos in the media browser.

    However, I do agree that there are some issues here. For one, the PSD files are all ones that have been edited externally in PSE from an Aperture master image, so the missing dates were in fact in the control of software (I don't know at this point if it's Aperture or PSE at fault though). Secondly, I got a message on mine that it couldn't update the master files, as they were in a format that cannot be written to. However, the fix still worked.

    Andy
  • 64. Re: aperture library not showing in mail, iweb or iphoto
    Steve Hoge Level 2 Level 2 (160 points)
    I found 2 .tiff files that showed no dates in the Aperture Browser; these had both been round-tripped through an external editor but didn't show up in the Browser when sorting by Date because they were part of a stack (and not the stack pick.)

    Strangely, when I used the Metadata HUD to examine exactly which date fields were missing - none were! That is, all the EXIF and IPTC and Aperture-specific date fields (and there are several) were populated correctly, but the the generic "Date" field in the Aperture Browser column was blank. This makes it look like a database corruption problem.

    When I used Metadata->Adjust Date and Time - even if I didn't actually change the default date that was already there - then their dates reappeared in the Aperture Browser, but only if I also checked "Also change master file".

    After making a new version of another image (which is enough to trigger re-writing the ApertureDatabaseTimestamp file) and renabling write priveleges for iLifeShared/, I quit Aperture. The timestamp file was rewritten, but I was still able to perform iLife media browsing, for instance in System Preferences -> Desktop Image.

    So master image date corruption in round-tripped images seems to be the problem here. The fact that the problem is common to all of us - who are using different external editors - points to Aperture as the culprit, not to an outside editing program.

    OK Apple, where's our KB Note regarding this?
  • 65. Re: aperture library not showing in mail, iweb or iphoto
    Andy Hewitt Level 1 Level 1 (70 points)
    A backtrack on that, it worked once in Mail, but crashed iWeb next time I tried.

    I'll try a full rebuild next.

    Cheers
  • 66. Re: aperture library not showing in mail, iweb or iphoto
    bobbyco57 Level 4 Level 4 (1,745 points)
    I had this problem, not seeing Aperture library in Media Browser for the other apps, after having migrated to a new MB Pro. I have all the latest updates and my Library was fine. This worked for me:
    1. I launched Aperture while holding Option, created a new library in the same directory (default Pictures).
    2. I imported a few dozen pictures.
    3. I Quit Aperture, then launched a couple iLife 11 apps to verify and yes the new Library was there.
    4. I launched Aperture holding Option again, switched back to my main Library.
    5. Relaunched iLife apps and my entire Aperture Library was back and accessible through Media Browser, and through iTunes to select pictures to display to Apple TV 2.
  • 67. Re: aperture library not showing in mail, iweb or iphoto
    currymac Level 1 Level 1 (10 points)
    Well, I have this problem too. Every image has a date assigned so the "date fix" doesn't apply to me. Opened and updated an older library and that shared successfully. Went back to my working library and zilch. Have completely rebuilt the library. For me, this also occurred after updating iLife. Waiting on Apple I guess.
  • 68. Re: aperture library not showing in mail, iweb or iphoto
    zebio Level 1 Level 1 (0 points)
    and how do I find these images? I have this issue in several applications!
  • 69. Re: aperture library not showing in mail, iweb or iphoto
    jlinaschke Level 1 Level 1 (20 points)
    Zebio,

    I posted an entry on ApertureExpert.com about this following up on info from this post, including instructions on how to find the date-less images. It doesn't seem to be fixing it for everyone, but it definitely IS working for some people! The entry is: Aperture Library Not Showing Up in iLife/Media Browser? Possible Solution Found…

    -Joseph @ApertureExpert
    ApertureExpert.com
  • 70. Re: aperture library not showing in mail, iweb or iphoto
    Steve Hoge Level 2 Level 2 (160 points)
    currymac wrote:
    Well, I have this problem too. Every image has a date assigned so the "date fix" doesn't apply to me.


    Look also for weird dates - where the database manager may have substituted a min or max date for an invalid date field. For instance, once or twice I've seen dates from 1984 that were clearly bogus. Try sorting your entire library by date and see if any outliers appear.

    -Steve
  • 71. Re: aperture library not showing in mail, iweb or iphoto
    Rajaratnam Level 1 Level 1 (0 points)
    1) Tried the changing dates technique - fail

    I would change all the dates, and then close Aperture and it would update libraries and previews. But still doesn't do anything. The next time I check the dates, other Pictures would have their dates missing. #$%^!

    2) ApertureData.xml date is stuck

    When I use my photo browser in Mail, or the iWeb, it keeps showing the smart album Last Week Photos as photos I uploaded on 22nd Oct 2010. It doesn't show any new photos after this date. Of course in Aperture, the Last Week Photos shows correctly. #$%^!

    3) Can't locate iLifeshared folder

    Under the package contents of both Aperture & Aperture Library, I checked every single file and folder and can't find the iLifeshared folder to try to delete it. #$%^!

    Any ideas on how to force Aperture to rebuild the ApertureData.xml? I've tried rebuilding/repairing the Library - still #$%^!

    p.s. I just upgraded to 10.6.5 today since it says got some performance fixes for Aperture....but #$%^!

    UPDATE

    p.s. I just synced my iPhone with the my MBP and guess what? It doesn't sync the new photos....#$%^!

    Message was edited by: Rajaratnam
  • 72. Re: aperture library not showing in mail, iweb or iphoto
    mrkgoo Level 1 Level 1 (10 points)
    I'm with Ernie. No doubt the dates thing is ONE issue.

    I have a similar issue in that my iPad will periodically sync to 'nothing', hence losing all my photos on my iPad (and other iDevices).

    When this happens, the Aperture library shows up as having no photos, and hence "Sync with Selected Albums" option is no longer available.

    Meanwhile, the library appears to share with iLife apps and Mail ok.

    I've tried everything from rebuilding, trashing and so on, and it normally fixes it such that it allows me to sync my selected albums to my iPad, but if I toy around in Aperture too much (add photos, move photos around etc), it will inevitably cause the issue to sync through it iTunes appear again. One time, I think I noticed that the iPod Cache within the Aperture Library actually empty itself, possibly on an Aperture close, so maybe this is a consequence of the bug also.

    As another aside, my Aperture library is no longer viewable in my Desktop Preference Pane. This started happening a while ago for iPhoto too, and I have yet to see a fix. They DO show up in Screensavers for me, so my workaround tends to be thus:

    Open System Preferences -> Desktop/Screensaver. Open the Screensavers tab, then close System Preferences. When I open System Preferences and go back to Desktop/Screensavers, it is now default in Screensavers. After my Libraries load, THEN I switch to Desktops, and my libraries then load there.



    But yeah, this really *****, and my major iTunes sync issues only started with Aperture 3.1. As far as I can tell, I have no erroneous date stamps on my files, but if there are I'm not even sure how I can find them in a 35,000 large library (I can order by date in list, but nothing jumps out as being weird).

    The only thing I haven't really tried is to delete and regenerate all previews, but that is a last resort method, as it takes overnight and then some for me library. And I'm not convinced it will fix the issue permanently.
  • 73. Re: aperture library not showing in mail, iweb or iphoto
    Rajaratnam Level 1 Level 1 (0 points)
    Ok. I re-builded the Database, and now the iLifeshared folder appears in the Aperture Library package....but lo and behold, the ApertureData.xml file remains unmodified.

    I have renamed it prior to the rebuilding, hoping that a new ApertureData.xml file would be created...but its still stuck to 22nd Oct 2010. Any advise on how to force Aperture to rebuild this particular file.

    This file is the one controlling the the Mail & iLife photo browser because without it, it doesnt show Aperture as a choice of library.
  • 74. Re: aperture library not showing in mail, iweb or iphoto
    jlinaschke Level 1 Level 1 (20 points)
    Rajaratnam,

    Did you try deleting the ApertureData.xml file? I'd turn OFF sharing in prefs, open the Library package and remove the file entirely (you can always put it on the desktop and zip it to ensure that it's safely stored away if all goes funny), open Aperture, quit it again (I like being redundant and really ensuring that things are in the right state when mucking around with the package), open Aperture again, enable sharing, quit Aperture, and it should build a new XML file at that point.

    worth a try, and as always when doing anything in the package, you should be working from a new backup of your Library.

    -Joseph @ApertureExpert
    ApertureExpert.com
1 3 4 5 6 7 Previous Next