Previous 1 2 3 4 Next 55 Replies Latest reply: Dec 11, 2014 7:51 PM by LarryHN Go to original post Branched to a new discussion.
  • Terence Devlin Level 10 Level 10 (132,025 points)
    A lot of folks have fixed these glitches with a simple restart of the phone. Others with a Reset of the phone.

    Regards

    TD
  • mrbofus Level 1 Level 1 (5 points)
    So, this isn't really a solution, but the videos I couldn't import into iPhoto '11 import into Aperture 3 just fine. =/ Guess I'm switching to Aperture 3.
  • keeeet Level 1 Level 1 (0 points)
    How are folks fixing this glitch with regular digital cameras such as a Panasonic Lumix like mine. All the photos get imported but not the videos, which iPhoto doesn't see. Even if I switch the camera on and off or remove the battery. I've never had this problem before. Its a problem with the latest iPhoto.

    Apple's continual release of products with issues is getting boring. A lot of people moved from Windows to OSX in the first place because of the shoddy quality of MS products. Now Apple is doing the same - getting its customers to test its products like MS .... perhaps we have to move to Google now.
  • Terence Devlin Level 10 Level 10 (132,025 points)
    What format are the movies?

    Regards

    TD
  • jonarnoldimages Level 1 Level 1 (0 points)

    Yes all very frustrating. I can import movies made on my Canon 5d2 or Lumix camera into iphoto and it plays fine on my Mac but none of them import onto my iphone or ipad (via itunes syncing). You have to convert them to an m4v file first if you want them to play on the iphone/ipad. You can do this using Quicktime Pro or other conversion software but it all takes time (lots). I have found a workaround. With the ipad2 (not sure about the iphone or ipad1) if you have the camera connector and plug in the SD card from your camera you can then import the movie files straight into the photo program on ipad2. They work, even though they are .mov not .m4v files. Odd that it works this way but not via iphoto/itunes syncing!? So what you can do is chuck some .mov files onto an SD card and import that way. Worth a try. By the way there are some ipad apps that import .avi, .mov files etc into the ipad but in my experience they can't handle 720 HD movies let alone full 1080 HD movies.

  • ablkmnd Level 1 Level 1 (0 points)

    Most iPhones are password protected.  If you disconnect your iPhone and then unlock it, then hook it up, you should be able to sync your videos.  I had the same problem, but remembered this issue when working on my PC. I never had a problem on the Mac, but after upgrading to iPhoto 11 I ran into this issue.  Unlocking it fixed the issue.  Hope this helps.

     

    Fletch.

  • Deteroblix Level 1 Level 1 (0 points)

    I get the same "unrecognized format" error when I try to import .MOV videos from a thumb drive plugged into my Macbookpro into iPhoto 11 v9.2.  Here's how I got to the error:

     

    1. Took video using my old iPhone 3G using Qik video app downloade off of app store (app turns 3G into a video camera).

    2. Transfered my .MOV files from 3G iphone onto Dell PC laptop.

    3. Bought new Macbook Pro and transferred .MOV videos onto thumb drive from PC laptop to new Macbook.

    4. Opened up iPhoto 11 v9.2 and tried drag drop .MOV files from thumb drive over to iPhoto app, that's when I get the error.

     

    It's odd, when I have the thumb drive with the .MOV videos in the USB drive of the Macbook, I click on the video clips and they play fine, again from the thumb drive.  But when I try drag drop onto iPhoto, iPhoton won't import them 80% of them.  Some of the .MOV video clips imported ok, but most didn't.  Lastly, the few that imported fine were the ones I could see an image on the video clip icons on the thumb drive.

     

    Any ideas of how to get iPhoto to accept the .MOV files?

     

    Deteroblix

  • MarcosCastellano Level 1 Level 1 (0 points)

    Unbelievable. I just did it that way and it works well. Strange issue. Apple should check it.

     

    Thanx for your help.

  • paulfromwinnipeg Level 1 Level 1 (0 points)

    It seems I've lost all of my .MPG and RAW videos that were already in my Library (thanks loads Apple). iPhoto won't recognize them, and it defaults to .JPEG file type when I try to export. Of course, the export fails every time.

     

    I guess I need to go back to a pre-upgrade backup and try to restore them.

     

    I agree with many other posts I've seen - this product release was not ready for prime time....

  • Terence Devlin Level 10 Level 10 (132,025 points)
    It seems I've lost all of my .MPG and RAW videos that were already in my Library (thanks loads Apple). iPhoto won't recognize them, and it defaults to .JPEG file type when I try to export. Of course, the export fails every time.

     

    How do you reckon that? Have you tried exporting as Original - which is what you need to do to get your Raws.

     

    Regards

     

     

    TD

  • paulfromwinnipeg Level 1 Level 1 (0 points)

    exporting as Original is greyed out, but I can access them if I use that option on a JPEG to get the finder to open. So, they are there without restoring from backup, but it's still a major bummer to not be able to view them in iPhoto.

     

    It also seems that none of the movies I created in iMovie before upgrading are playable / recognizable either......including in iMovie. But they will play in Quicktime.....

  • Terence Devlin Level 10 Level 10 (132,025 points)

    You do seem to have a corrupted Library, if that original option is not available.

     

    Select one of the affected photos in the iPhoto Window and go File -> Reveal in Finder -> Original. A Finder Window should open with the file selected. Does it?

     

    Regards

     

     

    TD

  • paulfromwinnipeg Level 1 Level 1 (0 points)

    Reveal in finder only works for JPGs.

     

    The option is greyed out for .MPG, .MOV and .M4V (however I can reveal a .JPG using that method, and then access the other files).

     

    I don't think it's a simple as a corrupted library, as the .m4v file won't open in iMovie either.

  • Terence Devlin Level 10 Level 10 (132,025 points)

    The point isn't the file type, the point is the Original

     

    If you select one of the files at issue and do the Show File / Original command, what happens?

  • paulfromwinnipeg Level 1 Level 1 (0 points)

    I'm not sure why you think the original is an issue.

     

    Like I said. The command is greyed out. The originals are fine, and can play with a number of commercial codecs, and also with Quicktime. The issue has nothing to do with the presence or absence of the original file, it's to do with iPhotos ability to recognize or process the file type, more specifcally with the Library entry that was converted at the time of upgrade.

     

    Associations at the OS level are fine. So it's either a library corruption for that type of file (ie; the conversion failed or the file type was not properly interpreted at the time of conversion.)

     

    After some additional experimentation, I can successfully copy the files from the iPhoto library Masters to an external device, and re-import them with no issue. So it appears that something failed when the upgrade performed the Library conversion.

     

    So there is a manual work around for this - but it's not what I would call a seamless upgrade. Very buggy release - iPhoto seems to have interpreted these file types as JPG during the upgrade.

     

    And yes, I have done a few Library rebuilds, including thumbnail generation. I'll probably just nuke the whole Library and re-import the Masters.

     

    But it's still a pain in the ***, and iPhoto still won't import from the camera directly without first copying the files to the local disk. So poor marks to Apple on this one sadly.

     

    Thanks for your comments.