Previous 1 2 3 Next 38 Replies Latest reply: Mar 23, 2011 9:38 AM by RandyMassey
rwwh Level 1 (0 points)
I've played around editing some pictures in iPhoto'11 for about an hour, and had already two cases of a completely unresponsive screen on my iMac. Both times the screen locked up when exiting edit mode and going back to the "event" view. The only thing still moving was the mouse pointer; clock and everything else is frozen. The power button will put the machine to sleep, but bringing it back up only shows a blue screen, nothing else. Using an ssh login from my MacBook I have been able to do a clean "sudo shutdown -r now", but that was the only way to free up the screen: killing iPhoto or even killing Finder from the remote login did nothing. Killing iPhoto (-1, -2 or -15) didn't even work, only kill -9 which produced a zombie process.

I have ±540 events and 33k pictures in my iPhoto library.

Did anyone else experience this? Any hints on how to work around it or solve it?

iMac aluminium 24", Mac OS X (10.6.4), 4GB/1TB
  • Old Toad Level 10 (135,423 points)
    Are there any messages in the Console that might shed some light on the freeze up?


    OT
  • rwwh Level 1 (0 points)
    I never looked at the Console before but there is nothing I can trace in the "Console Messages". There is a reasonable break before the crash until I start shutting things down. Are there any specific "tricks" I should try? Do I need to look at "All Messages"?
  • Old Toad Level 10 (135,423 points)
    I look at the All Messages for iPhoto and times around the time of the problem. Sometimes there will be a message which can help.
  • rwwh Level 1 (0 points)
    There is "Writing DB Version File to: ....." once, and "Incompatible applications: app=com.apple.iPhoto, targetApp=com.apple.Safari" twice. Around (but not at) the time of the first hang, there is the kernel that reports "PM notification timeout (pid ....., iPhoto)" three times in the same second.
  • Iemke Kuijper Level 1 (15 points)
    I have here more or less the same problem. When in an event and after selecting one photo. The whole system freezes. In the library are 600 events and 15000 photos.
    Only a hard restart with the power button brings everything back to life. Machine mac pro. On my imacs I have no problems but libraries are half smaller in seize.
  • Old Toad Level 10 (135,423 points)
    Boot into Safe Mode and try running iPhoto. If it runs OK reboot and try again.
  • Michael C M Level 2 (205 points)
    I've found a process that can reproduce this 100% of the time.

    1. Create a new book (or edit an existing).
    2. Enter full screen mode.
    3. Add one of the map pages.
    4. Start adding places to it.

    One my computer during adding the first or second place the processor jumps to 100% and iPhoto stops responding.

    I didn't need to login remotely to reboot it, hitting command tab will show the dock and menu bar (even though you can't make any windows appear above the iPhoto window) and you can force quite iPhoto. I have no idea what it freezes doing. The system processor usage is at about 30% and the iPhoto consumes the rest.
  • rwwh Level 1 (0 points)
    This also sounds nasty but does not appear to be the same problem. Command-Tab definitely did not work for me any more, even the clock stops....
  • Old Toad Level 10 (135,423 points)
    In your iPhoto/Advanced preference pane what is the "Look up Places" set to? Also are you able to go to the Places mode and move the map around and zoom in OK?
  • netnothing Level 1 (60 points)
    Do you know if you have a Mac with an NVIDIA based card? There is a large thread, +not directly related to iPhoto+, about NVIDIA drivers freezing systems:
    http://discussions.apple.com/thread.jspa?threadID=1916253

    Myself and at least one other person have seen this happen even more frequently with iPhoto '11.

    You won't see the error message in the Console All Message log. To see it, you open Console, expand FILES, expand /private/var/logs/, and look at kernel.log.

    If around the time of the system freeze and you see errors like:

    *NVDA(OpenGL): Channel timeout!*
    *NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error*

    Then you are likely having a driver issue that has gone on for a while with NVIDIA based Macs.

    Not much you can do. Hopefully it just freezes the system for a short time and doesn't require a restart.

    -Kevin
  • rwwh Level 1 (0 points)
    Hm.. I do not see this exact error message; it also looks like the problem is different because the way you describe it, your system can actually recover. In my case, I have not seen it recover and so far a reboot is the only way to gain access to the screen again.

    But you did bring me on a path to some sort of error message. Right around the time of the crash I see, in that same system.log:

    Oct 22 19:50:44 imac kernel[0]: ** Device in slot: SLOT--1 **
    Oct 22 19:50:44 imac kernel[0]: ** GPU Debug Info Start **
    Oct 22 19:50:44 imac kernel[0]: 0x00009583
    Oct 22 19:50:44 imac kernel[0]: 0x000000d6
    ...around 800 lines skipped...
    Oct 22 19:51:01 imac kernel[0]: 0x00000000
    Oct 22 19:51:02: --- last message repeated 47 times ---
    Oct 22 19:51:02 imac kernel[0]: ** GPU Debug Info End **
    Oct 22 19:51:13 imac kernel[0]: ** Device in slot: SLOT--1 **
    Oct 22 19:51:13 imac kernel[0]: ** GPU Debug Info Start **
    ... etc until the shutdown.

    It looks like this could have something to do with the issue. Unfortunately this is not something I can do anything with myself.
  • netnothing Level 1 (60 points)
    Yeah, you're right....not the same error....but I think it's similar. Stumbled across this thread:
    http://discussions.info.apple.com/thread.jspa?messageID=11483646

    People with that type of error.

    It's definitely Graphics card related....wondering if iPhoto is taxing the card more now.

    -Kevin
  • Michael C M Level 2 (205 points)
    Advanced settings look up places was set to Automatic. It seems to work without freezing when set to Manual. Any ideas why it does this? I will continue to load for a good 4 hours at 100% CPU and not make any headway when set to Automatic.
  • asavartsov Level 1 (0 points)
    I have similar issues:

    1) Using Definition and Remove Noise filters make iPhoto freezy and unresponsible. When iPhoto unfreezes, photo blanks with black and shows again only if I exit edit mode and enter it again.

    2) When I use zoom in edit mode, I see multiple artifacts, color or black, on Navigator window, iPhoto freezes while I tries to move around clicking Navigator or moving display area on it by mouse pointer. After using Navigator for a long time (say, I edit dozen of photos using zooming on each), my screen, whole or part, fills up with randomly-colored noise and OS freezes completely.
Previous 1 2 3 Next