Previous 1 2 3 4 5 Next 166 Replies Latest reply: Nov 20, 2014 8:04 PM by Jasonsito Go to original post
  • Colin N Shaw Level 1 (0 points)
    Hey There dukedinger!

    If possible could you send me this fix as well?

    Would greatly appreciate it!

  • Colin N Shaw Level 1 (0 points)
    Right - here is my email address, cns12(at)

    Forgot to include it with my last post - again, dukedinger, if you were able to send me the fix I would greatly appreciate it!

  • Fred driver Level 1 (0 points)
    Dukedinger - please add me to the list of those pleading for the fix. rchrist2(at)

    Much appreciated.
  • frabu Level 1 (0 points)
    Dukedinger, pleas add me too to this list.


    At least I'm glad to see, that I'm not the only one with this problem
  • Fred driver Level 1 (0 points)

    First – download the 18.0.3 patch from the SPSS website and update your software if you haven’t already. You’ll have to set up an account with SPSS to get access to their technical help. The patch is 160MB or so it's not possible to e-mail it.

    Second – on the same download page from SPSS you can then download the patch to fix the JAVA problem. This one is a little harder to install as it requires you go into Terminal mode and enter a bunch of commands. Much smaller file and comes with a README for instructions. Just follow the README exactly and it should work. I did have one hiccup though.

    In step 6 where you have to copy the new file to the appropriate SPSS directory, my computer couldn’t find it. In the example at the bottom of the README file it says to find the directory where you stored the new file and enter a command like:

    FOR EXAMPLE, if the file is at /Macintosh HD/Users/foo/libspssjvm.dylib, the cp command must be this:

    $ sudo cp -p "/Macintosh HD/Users/foo/libspssjvm.dylib" .

    That didn’t work for me until I removed the "/Macintosh HD" part in the address and just used "/Users" as the first part of the directory address. Then it found the file and copied the file over to the SPSS directory.

    Started up SPSS and it worked like a champ.
  • asuray Level 1 (0 points)
    Hey dukedinger! If you're still sending out fixes for PASW 18 I would appreciate it if you would add me to the list. I can't get the 18.0.3 update patch or the fix file as I use the program on my university's license and can't create an SPSS support login to get files/create support tickets. Thanks!

    rayreichenberg (a)
  • supreemo89 Level 1 (0 points)

    Can I get a copy of that fix as well?

    thank u
  • Gambisto Level 1 (0 points)
    Hi Dukedinger,

    I got almost crazy while trying to fix that issue. Could you please send me the patch by email? My address is:

    Many thanks!
  • winter118 Level 1 (0 points)
    Hi, could you also email me the file? thanks a lot...
    I really need my SPSS 18 to work in order to continue my research... at
  • winter118 Level 1 (0 points)

    Could you also email me the file?
    Many thanks!!!!!
    I really need it for my PhD research...
  • Aristarchus Level 1 (5 points)
    SPSS released a patch. It requires using terminal to update a file in the SPSS library, but the readme file is well written (with one exception, clarification below). Roughly, this is what you need to do:

    1. Go to If you are an SPSS user, you should register if you haven't done so already. For some reason, you can't download patches and upgrades unless you are registered. If you already did, just log in.

    2. On the Main Menu navigation menu (left-hand side), click on Statistics, then on Patches.

    3. *If you haven't installed the 18.0.3 patch, download it and _install it first_.*

    4. Get the Hotfix.

    5. This "Hotfix" is simply a new file libspssjvm.dylib that must replace the old one. Follow the instructions in the readme file, but pay attention to step (6), where it says to enter:

    $ sudo cp -p (path where you saved the new libspssjvm.dylib)/libspssjvm.dylib .

    *Ignore their example*, it has an unnecessary "Macintosh HD" in the path. If you downloaded the patch, your browser probably saved it on the Desktop or in the Downloads folder. If you have done nothing to the downloaded folder, this is probably what you need to enter:

    $ sudo cp -p "/Users/yourusername/Desktop/IBM SPSS Statistics 18/libspssjvm.dylib" .

    Just change "yourusername" to your actual user name and "Desktop" to "Downloads" (if necessary). It is very important that you do not change anything else to the line above, it should include the quotation marks and the dot at the end of the line.

    It worked for me, it should work for you.
  • gethryn Level 1 (0 points)
    [deleted] -- missed the answer already provided.

    Message was edited by: gethryn
  • winter118 Level 1 (0 points)

    I have downloaded the 18.0.3 patch but when I was about to install it my mac couldn't recognize the presence of the original SPSS 18. It's weird as I'm pretty sure I've got it on my laptop. I even tried to install and reinstall SPSS 18 before trying to installing the 18.0.3 patch. Still my mac can't detect SPSS 18. Do you have any idea about how this could happen? You have no such problems do you?

    Thank your for all the help and I really look forward to your reply soon. My e-mail (if you don't mind):
  • ratboyy Level 1 (0 points)
    Hello dukedinger --

    Don't know if you're still looking at these posts, but I'd greatly appreciate the file ...

  • jeremyjaytaylor Level 1 (5 points)
    Hey everyone,

    I applied the “hot fix”, as is suggested on the SPSS website, but now I'm unable to run any analysis whatsoever. Since applying the hot fix, SPSS seems to open appropriately (and seems to have fixed the problem with importing Excel files into SPSS), but freezes every time I try to run any kind of analysis. Has anyone else experienced this and/or have a suggestion about how to fix this problem? I am running Mac OS 10.6.5 and I applied the 18.0.3 update before installing hot fix (as was recommended on the SPSS website). Thanks in advance to anyone who is able to help. Best. Jeremy
Previous 1 2 3 4 5 Next