Previous 1 2 3 Next 36 Replies Latest reply: Apr 11, 2015 8:01 AM by good GPS
Suzanne Thompstone Level 1 Level 1 (5 points)
Does ANYONE know why the driver I downloaded from Canon (CAPT_V320_MacOSX_ukEN) will not run my Canon LBP6000/6018? Seeing as the Canon HK website (my local) told me to go there to download it and it SPECIFICALLY SAYS it's for Mac (10.4 - 10.6)?

I'm absolutely raging. D**m thing cost me HK$1,000 (US$127.00) and I get home to plug it in and find that nothing remotely like my model name is in the drop-down list in the printers pane. After downloading, installing and even - GASP - restarting my iMac, there is still no mention of it or any way to choose anything vaguely similar to my printer.

I'm not a computer bod and I don't know what I'm doing, but I'm on the verge of calling Canon and tearing them a new one (as it says ON THE BOX that the printer is compatible with Mac). 2 hours arsing about with hundreds of obscure websites to find a driver to replace the one that doesn't seem to work from the manufacturer? Unacceptable.

Any hints or help at all would be appreciated. I actually bought the thing to print with tonight, not expecting any installation problems. I have never had such trouble with any other peripheral/extra I've bought for my Macs since 2002.

Thanks anyone!

iMac, Mac OS X (10.5.8), 2.66 GHz Intel Core 2 Duo
  • alternativeman Level 1 Level 1 (15 points)
    Hi Suzanne,

    I'm also based in Hong Kong with the exact same printer I bought from Broadway the other day. I had the same problem as you describe when I tried to install it earlier tonight, but now I've got it working.

    Once you have the driver installed and the printer connected and turned on, open any printable document, then:

    File > Print
    Choose "Add Printer..." in the Printer dropdown menu
    You will see LBP6000/LBP6018 in the box that appears. Ignore it. Instead, click on "More printers..." in the bottom left corner of the same box.
    Another box will appear with a dropdown menu at the top, giving you two choices. Choose "CANON USB (CUPS CAPT)," which will give you the model number again. Click on it, then "Add," and voila!

    Hopefully, this will save you the angst you will likely suffer from calling customer support (funny how that has become an oxymoron...)
  • Suzanne Thompstone Level 1 Level 1 (5 points)
    THANK YOU! You, sir, are a bl**dy star!

    Followed your instructions and it works a treat. I cannot thank you enough! Not only have you made my printer work, you've prevented me from having to call 'support'.

    Thanks again!

  • trixipixie Level 1 Level 1 (0 points)
    Bless you again from me!! Although it did seem that your hint was not going to work as it wouldn't let me 'add' (was greyed out), but then I tried other things & I think I fixed it by going back to the document & when I pressed 'print', then it came up with the right model to click on and as you said - et voila! - now it works a treat!! thank you thank you thank you, cheers Trixi
    mind you - how ridiculous that Canon couldn't add the correct driver in the start up disc in this day & age.....
  • DoctorFresh Level 1 Level 1 (20 points)
    *A salutary lesson in printers*

    I have had horrendous difficulty with my Canon printer.

    Followed the instructions - the Mac would (intermittently) recognise the Canon but when I asked it to print, either nothing happened and the job stayed in the print queue or it would disappear.

    Mhmm - now officially a computer dork - changed the USB cable this morning and everything works fine using the CAPT driver. Just a hint to anyone else assuming that the driver might be defective - CHECK THE LEAD!
  • alternativeman Level 1 Level 1 (15 points)
    You're all welcome, folks.

    So I tried printing this morning after a long period of non-printing, and this Canon responds with something like my software needs to be updated. So I went to Software Update expecting the new Canon driver to show up (just like the other printers do), and nada. Then I went to the Canon UK website and found that they did indeed update the driver last month. I downloaded and installed the update, delete the old setup from Printers & Faxes, and added this new one using the same steps I described above.

    Took only a few minutes, but Canon should get its act together and update automatically. Le sigh.
  • vimyridge Level 1 Level 1 (0 points)
    Alternativeman, you are a star! I also am in Hong Kong, and had the same problem. Thank you!
    If only CANON could put information on its driver download page!
  • PAHU Level 6 Level 6 (15,810 points)
    It's pretty easy to blame Canon for your troubles but if anyone here cared to read the manual included with the CAPT driver download then they would have seen the procedure in Chapter 2 for adding the printer via USB or Ethernet.
  • Droidex Level 1 Level 1 (0 points)
    So no Wireless?

    I have this printer shared on a Windows 7. The PC is connected to a Wireless DSL router.

    The Mac laptop connects via WiFi to the Wireless DSL router but printing is not working with that manual. It shows a ethernet problem.
  • Aikiman001 Level 1 Level 1 (0 points)
    Hi everyone,

    Can somebody supply a link to the driver? I downloaded this one CANON_CAPT v310 EN.dmg but when I go to 'Add new Printer' > 'More Printers' and select Canon IP (CUPS CAPT) I have to supply an IP address which I have no idea how to get. And since this is connect via USB, the Canon USB (CUPS CAPT) has no list of any printers to choose from.

    My printer is a Canon LPB 6000.

    Thanks for the help.
  • zer05um Level 1 Level 1 (0 points)
    More on this issue....

    Since upgrading to OS10.6.7 I had to do the whole palaver about finding the update. Now I can't print anything. Only lines come out from tables, and then only the top 2cm of the page.

    To be honest I've never had so much trouble from a computer as with my mac - crashing, freezing, the worst customer support on the planet outside of telco companies and as for getting peripherals to work... HA! Even my Logitech mouse caused issues. The only point in common with all my issues is the mac. Never had anything like this much trouble on a PC or a Linux box. Even Microsoft write better help files.

    For example, where the **** ARE printer diagnostics on a mac?
  • vimyridge Level 1 Level 1 (0 points)
    My printer was working fine until today. Now either it does nothing, or it prints only a small line. Any ideas???
  • vimyridge Level 1 Level 1 (0 points)
    I can't find the guide in the CAPT download. There is a documents folder, but it only sends you to the Canon Web site where you have to start from scratch selecting countries, products, etc. Totally frustrating.
  • Thomas PL Level 1 Level 1 (0 points)
    I'm having the exact same issues: MacBook Pro, LBP6000 laserjet. It occurred updating Mac OS X from 10.6.5 to 10.6.7 for me.

    It's frustrating how a Mac OS X update can make Canon laserjet drivers dysfunctional.
Previous 1 2 3 Next