Previous 1 2 3 4 Next 52 Replies Latest reply: Oct 23, 2012 7:51 PM by weekstyler Go to original post
  • SteveDemy Level 1 (0 points)
    Nice work Janvier and John. I removed the hp_ kext files to a folder on the desktop, restarted, and as advertised the USB-connected Color Laserjet 2500 was found on the list, without having to be added. Printing works, printer sharing works.

    This is a pretty coarse solution, so I too hope that HP and Apple provide us an update.

    I had posted on that other thread before finding the work-around here
  • RedActor Level 1 (0 points)
    Hooraaaaay! I also deleted all of the HP files in the extension folder and can now print!


    Thanks everyone. It's amazing to come and find advice from such smart people!
  • FN Level 1 (5 points)
    John's and Janvier's workaround did it for me! Let's stay away from this HP Printer Software Update 2.5.2!
    Thanks a lot
  • jion35 Level 1 (0 points)
    I had the same problem "Waiting for printer to become available... " - HP LaserJet 2500 L with iMAC 11.1 running Mac OS X Version 10.6.5. since the "HP Printer Software Update 2.5.2".

    This also helped for me:

    1) delete all of the items whose name starts with "hp_" in System/Library/Extensions
    2) Disconnect the printer and turn off the printer
    3) delete the printer if it's still there
    4) reset the printing system
    5) restart the Mac
    6) empty the trash
    7) turn on the printer and reconnect the printer to the MAC
    8) reinstall the printer

    Thanks to all contributors!
  • MervynG Level 1 (5 points)
    I have a thread running relating to the HP C309a printer [here|].

    To be clear, amongst other assets, I have two iMacs on my home network. One is on 10.6.5 and 2.5.2 and the printer is not fully functioning - it has lost the ability to scan normally although it does print and fax. The other is still on 10.6.4 but again with 2.5.2 and is functioning. So in my case it appears as if it is an OS update issue (although an original and longstanding issue between the HP printer and Photoshop remains unresolved).


  • PacBch Level 1 (0 points)
    I do not seem to have a directory "Extensions" Has everyone else gotten their printer to work again?
  • John Blanchard1 Level 5 (5,230 points)
    Are you looking in the right folder? What happens when you enter "cd /System/Library/Extensions" in Terminal?
  • MervynG Level 1 (5 points)
    Hi PacBch,

    As an alternative to JB's advice, double click your Hard Drive icon on the desktop (or if you haven't got a hard drive icon on the desktop, select 'Computer' from the 'Go' drop down menu in the Finder and then click the triangle to open your hard drive), then click the triangle to open 'System', then click the triangle to open 'Library', then click the triangle to open 'Extensions', then you should see hp extensions. I had 17!

    I note you say you are at OS 10.6.2. If so, this is interesting as my printer issue that started the thread only occurred after the update to 10.6.5. It was NOT caused by 2.5.2 printer update alone (or at all?). Indeed the same two hp printers I use on our home network continue to work fine with my wife's iMac on 10.6.4 and 2.5.2.

    I may try the Extensions deletion suggested but can say that at this point in time my HP C309a (CC335) still has lost its System Preferences >> Print & Fax computer initiated Scan capability.

    I think there continues to be a problem between Apple and hp as remains in evidence from the inconsistent advice on the two company's websites; especially hp's.

    If I were a betting man I would wager we will see another update that will finally address a host of hp incompatibility issues. Let's hope it is prioritised enough to arrive before Christmas. It has, after all said and done, been around in one form or another for nearly a year. Are you engineer's listening??

    Anyway must dash, I have to post another incompatibility issue as my two WDC back up Time Machine (highly recommeded everywhere and replaced three times) drives won't reliably come out of sleep by themselves!!

    Finally, before I go I must set this in context and say that I have spent orders of magnitude more time trying to sort out a tiny but exasperating pc problem for my son and have now given up and thrown it in the bin!


  • Aldert Level 1 (0 points)
    WOW! Finally, after days of disconnection with my HP, I finally can print again. Thx a million you experts.
  • Ginny K Level 1 (0 points)
    In step 4, you say to reset the printer after deleting it. I must be missing something. Can you be more specific?

    I have a hp Color Laserjet 2600n which doesn't appear on the list when I try to reinstall. I even use my old original hp installation disk. It still doesn't appear.

    When I try to print using a generic printer, it stays in idle mode. Won't "resume printing".

  • RedActor Level 1 (0 points)

    Basically turn it off and then on.
  • jion35 Level 1 (0 points)
    Dear Ginny K,

    In the German MAC-OS there is a button where one can reset the socalled "printing system" I can only translate the german name into english. MAybe you can find a button which deletes all installed printers from your system in order to have a "clean" system.
    If you do not find it do not worry and simply try to skipp this point.

    With kind reagrds
  • Ariel Lev Level 1 (25 points)
    Same problem here. I'm not able to print since OS X 10.6.5 and/or HP Driver Update 2.5.2 (I was away from my printer for a while and installed both updates during that time so I'm not sure which update actually messed up printing).

    My setup as follows: MacBook Pro with 10.6.5 and HP Drivers 2.5.2 installed. I'm trying to print to a networked (as in plugged in via ethernet and has it's own static IP) HP Color LaserJet 3800.

    Worked perfectly for as long as I can remember. Now, no matter where I click print I get a message that says "Error while printing". The job never even makes it into the print queue. Keep having this error message appear in my logs:

    Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/10_0_05) from localhost

    I tried all the troubleshooting steps outlined in this thread but nothing seems to have worked. The one workaround I was able to come up with is to change the driver from HP Color LaserJet 3800 to Generic PCL Laser Printer. That works but is obviously not ideal.

    Hopefully Apple & HP get this sorted out officially, quickly.
  • actionmarker Level 4 (1,555 points)
    Hi All,

    Thanks for all the suggestions so far, but unfortunately for me, it hasn't appeared to resolve the issue.

    I have HP Color Laserjet 2550L, Macbook 5,1, 10.6.5.

    I cannot confirm if this issue has only just appeared since the 10.6.5 update or the HP Printer Drivers 2.5.2. This printer has normally been shared through an XP machine, which has recently been upgraded to W7. (Not sure if that was a good idea or not yet, as it has caused a host of unrelated issues, but that's off this topic)

    So I have connected the HP2550L directly to the Mac via USB and are having these issues.
    I doesn't seem to matter if I follow the suggestions posted here, but I seem to always get one print job complete and then the next print job fails with the printer going 'off line'. If I restart the printer, then the job in the queue will print and then again fail on the next job.

    I have;
    Trashed all hp_ files in Extensions
    Deleted printer
    Reset the printers
    Emptied Trash
    Reconnected Printer
    Printer is found and works again for the first job but goes off line again for the next.

    The same also occurs try if I follow the above process, but also reapply the 2.5.2 update.

    My question is, when deleting the hp_* files in /System/Library/Extensions, is this actually removing the whole 2.5.2 update and its associated drivers, or just some of the associated files that come with the update?

  • Gordon33 Level 1 (0 points)
    Printed first page in days thanks to helpful advice! Thank you!