Previous 1 2 3 4 Next 56 Replies Latest reply: Jun 3, 2012 11:50 AM by bugracakir
ikhaled_ Level 1 Level 1 (0 points)
I have upgraded to snow leopard 10.6.5 today and I can not see any users in the log in screen. All the user account disappeared and the only use I see is "other" with a blue logo!

No options for me to restore, have not done a pickup long time ago and I do not really want to lose the access of my Mac because of this upgrade!.

Any ideas anyone? I saw other posts that were not answered, were you guys able to fix it?!

Thanks!!

iMac, Mac OS X (10.6.5), User log in lost
  • Francesco.Romano Level 1 Level 1 (0 points)
    Hi! =) Same problem, I've upgraded the OS and then (after shutting down it some times, so not at the first time), I fixed permissions and I read that they changed permissions about Users ... something like 95 to 0 ... but I don't remember exactly. I think that was my problem. Maybe.

    But yes, I can only see the blu icon with others, and if i use my old User and Pword it says no, can't login.
  • ikhaled_ Level 1 Level 1 (0 points)
    The bad thing for me is I did the update and shutdown my iMac.

    I hope there is a fix for this unexpected disaster!!!
  • Francesco.Romano Level 1 Level 1 (0 points)
    Just re-install mac os x.

    I've just finished. Just install mac os x without transferring files from time machine.

    Install -> don't import files, insert the same username used before, and you'll found your old data, and settings on your desktop =)
  • ikhaled_ Level 1 Level 1 (0 points)
    Thanks for the help Francesco,

    I was with AppleCare support but in the UK. They have found that we are from the minority that to have this issue and they are going to investigate that with the office in the U.S.A.

    It seems that the only solution at the moment is to reinstall the system and create the same user accounts and therefore you will find all the settings at the desktop as you said!
    The only disadvantage of this solution is you have another system installation and you will lose another 8-10GB of you hard disk space.

    At least it was a good experience for me at the end and I'm going to backup my system now

    Cheers
  • RichTh Level 1 Level 1 (0 points)
    hey hey

    Having the same issue here after updating to the latest OS (only user is "other" with a blue logo after rejecting my password twice, but no luck with the OS reinstall any other suggestions going around? Also i did the update when it was pushed out and have restarted a couple of times since, has anyone noticed anything else causing this problem?

    thx
  • :.Interloper.: Level 1 Level 1 (0 points)
    Same issue over here. Unfortunately I don't have a solution.

    But I've booted from the install Cd and using the 'reset password' option from the Utilities list I've managed to set up a Guest User account. In there I can view my old users on the HDD and access some files which I have permissions for. However I can't make any changes in the system preferences as it asks for my Admin user name and password which it wont recognise ...

    Also tried using Time Machine from the utilities list to revert to a back up however it wont even run, I click it and it does nothing, which is infuriating.

    Thanks for the info on the re-install work around, I'll give it a go.
  • :.Interloper.: Level 1 Level 1 (0 points)
    Update.

    So what I've done is set up a new admin account on the computer. To do this follow these instructions

    http://www.hackmac.org/hacks/how-to-create-a-new-administrator-account/

    And then you'll find all your files from your other users on your Hardrive and should be able to access them without issue, copy them in to the new account, delete old ones etc. This way all your programs should still be installed and you can copy your preferences across so it should all run just as it used to.

    I don't know what triggered this issue but really hope it doesn't happen again ...
  • alessandrobl Level 1 Level 1 (0 points)
    Me too... same problem!! Searchin' around for a solution!
  • defmetal Level 1 Level 1 (0 points)
    This just happened to me today as well, updated to 10.6.5 on Snow Leopard server, now I'm stuck at the login screen and can't log in with my accounts.

    Fortunately the websites still up, and email, but I lost the ability to login.
  • defmetal Level 1 Level 1 (0 points)
    I found the solution, at least for me.
    After installing OS 10.6.5, for me, it reset the permissions of all users to Deny access to the login menu.

    Being that this was a server, I had Server Admin Tools on my mac.
    I found I was able to SSH into the server so I new my accounts still worked.
    If you use "Server Admin" to connect to the computer and go to Access you can reenable Login Screen for all accounts.


    I hope this fixes it for you, if not, gl!
  • Level 6 Level 6 (11,035 points)
    I had the same thing happen to me. Updated to 10.6.5, then upon shut down and reboot, all account users deleted. Password rejected. Tried to reset the admin. Not possible.
    Had to restart with installation disk and then use time machine to install previous 10.6.4 ! WHAT THE HECK HAPPENED APPLE AND WHY NO RESPONSE??!!??!!

    Now not sure I want to update to 10.6.5!!!!! So much for the perfect Mac! Will Apple address this problem or not??????????????????
  • Rockdoctor Level 1 Level 1 (40 points)
    Same problem. I've had 10.6.5 on my machine for some time, but when I logged out last night, and disconnected an ipod and an external HD, it seems to have caused a glitch; when I tried to log back in all the (five) user accounts were gone, replaced with user "Other". None of the accounts names + passwords will log into this.

    I have tried Disk Repair from the CD, and although it fixed some things, I still have no user accounts.

    I'm reluctant to reload Snow Leopard if there is a simpler cure - my next plan is to boot up from my old Leopard CD and see if I can fix anything that way.

    What is the best cure for this problem, with the least chance of losing data (needless to say my last TM backup is rather out of date).

    Cheers.
  • Rockdoctor Level 1 Level 1 (40 points)
    As so often happens, here I am posting the solution to my own problem;

    I put in my Snow Leopard DVD, forced it to boot from the disk by holding down "C".
    Used the option to change password from the utility menu - only option was to change password of "User Administrator (root)" so I changed it for that.

    Re-booted from internal HD and got the same "Other" option for user accounts. Tried "User Administrator (root)" without success, but "root" worked with my newly changed password.

    Once I was logged in as "root" I was able to create all my old users - as I created each one the system told me there was already a user by that name and would I like to attach all the existing files (yes!).

    After trying all the users they seem to have picked up all data correctly and (fingers crossed) everything is back to normal.

    So what was that all about?
  • Litachao Level 1 Level 1 (0 points)
    I had the exact same problem twice now. In my case, all users except for root seem to disappear after shutting down Windows on my BootCamp partition and rebooting into OSX.

    The user data is still there, so the accounts can be restored with the method described above.
    - log in as root
    - add users with the same short names as the missing ones in system preferences
    - confirm when it asks you if you would like to keep old data.

    The most annoying thing about this is that after restoring a user, time machine needs to do a complete backup of the user's data as it seems to think that all the user's data is new.
Previous 1 2 3 4 Next