Previous 1 2 3 Next 496 Replies Latest reply: Aug 5, 2012 9:12 AM by RCully
matteocaldari Level 1 Level 1
Since I upgraded to 10.6.5, my MacBook Pro (Early 2006) cannot connect to my USR9110 (802.11 g) access point. 
From 10.6 on, there's been always troubles when resuming after sleep, but now even at startup the connection goes timeout.

All other devices (an iPhone,an iPad and a MacBook Pro (Late 2006) with 10.5) work perfectly.

I tried rebooting, changing  the wifi channel, updating the access point firmware, turning on and off airport, resetting the SMC, switching to WEP, switching to WPA, switching to unencrypted. Nothing changes, connection timeout. 

MacBook Pro 1,1, Mac OS X (10.6.5), early 2006
Solved by tenortim on Jan 13, 2011 12:03 PM Solved
OK, my wife just went through this ordeal (2007 MBP, Atheros 5424 chipset).Thanks to the work of others diagnosing this, I found a solution that doesn't require a full downgrade, although a little bravery might be needed.As has already been stated, the version of the firmware for the Atheros cards changed in 10.6.5. This seems to be the culprit. Did anybody bother testing this fully? The new firmware is unable to maintain a connection under conditions that the older firmware handles with aplomb. Anyway, we clearly need the older driver/firmware, but downgrading to 10.6.4 seems rather draconian, so I set about finding a solution that just fixed that problem.To cut to the chase, you can run the 10.6.4 drivers on 10.6.6. To do so,1) Download the 10.6.4 Combo update and the Pacifist program that allows one to extract files from, amongst others, ".pkg" files.2) Mount the update .dmg, open the package in pacifist, extract the subtree "/System/Library/Extensions/IO80211Family.kext" to a convenient location.3) As root, cd to /System/Library/Extensions, rename IO80211Family.kext to IO8021Family.1066 (or anything else to back it up), and copy in the replacement IO80211Family.kext that we extracted from Download, install and run "Kext Utility" (Google it, it's at Insanely Mac). It should ask for your password, run, and fix up the kext permissions and caches.5) Reboot. You should now be on the new (old) driver/firmware. Verify by running "About this Mac" -> "More Info" -> "Network" -> "Airport". As stated, the newer firmware is, the working firmware is doing this, my wife's MBP is back to full functionality and domestic harmony is restored. Apple, please revert this driver and inform Atheros that it does not work correctly.Message was edited by: tenortim (fix typos)
  • satcomer Level 4 Level 4
    Try the steps in the blog How I fixed my dropping wireless Airport connection problem in Snow Leopard to see if any of these steps work.
  • RicZS Level 1 Level 1
    Same problem here, with mac mini set 2006. Please, we need a no geek solution.
  • davpoind Level 1 Level 1
    I'm having the same issues. Trying to connect to the WPA network at my university, and I keep getting "connection timout"

    Message was edited by: davpoind

    Message was edited by: davpoind
  • davpoind Level 1 Level 1
    That's a helpful resource, but some items don't apply.

    I'm trying to connect to my university secure wireless network, so I can't exactly change channels on the router.

    This is definitely a 10.6.5 update problem. I was using the wireless network, even as I was downloading the 10.6.5 update. After restart from the update, that's when the wifi problems appeared.
  • satcomer Level 4 Level 4
    The non-geek way to try to reset your Airport card.

    1. Quit All Programs!
    2. Open System Preferences->Network and Highlight the Airport card. Then TURN OFF the Airport card!
    3. In the lefthand pane (while the Airport card is still highlighted) and click on the - button.
    4. Don't Panic!
    5. Reboot immediately (Don't skip this step)!
    6. Upon the restart open again System Preferences->Network and click the + button and re-add the Airport card.
    7. Then in the right hand of the Network pane click on the 'Apply' button.
    8. Now put in you wireless settings (from the Network pane) and try to rejoin the network. If this is successful hit the 'Apply' button (in the Network pane still).

    This is the non-geek way to reset the airport drivers in OS X. See if this helps, Good Luck.
  • matteocaldari Level 1 Level 1
    Thank you for your tips. I tried the "geeky" ones and the "non-geeky" as well, yet the problem persists.
    It is certainly an issue with 10.6.5: yesterday, with 10.6.4, things ran fine, except for the resume after sleep issue.
    After the upgrade I can't connect at all.

    Now I booted from a USB HD with a backedup 10.6.2, so same network configuration, and wifi works properly.
  • fourcorners65 Level 1 Level 1
    Thanks for info. It worked great. I did find however after I uninstalled airport and reinstalled it, the system tray was not reflecting the status the System Preferences reflected. I had to give an addition reboot after reinstalling Airport. After the second reboot the system tray correctly reflected the status and I was able to rejoin my network.
  • Matt4mac Level 1 Level 1
    Having the same problems here. Airport drops connection randomly. Tried reconfiguring connection settings, re-adding airport to network settings, resetting SMC, rebooting cable modem and wifi router, changing airport connection channel, security settings, network name, rebooting mac several times. Have tried two different routers. Router A: 1st gen Time Capsule 500gb (20ft away), started with a spotty connection almost immediately after updating to 10.6.5, and now when attempting to connect with TC network name will not even show under airport. Like it's gotten worse. Router B: super old Dlink (5 ft away), freshly reset, was spotty earlier today, and now seems to have held a connection for a record 22 minutes.
    So, I am really confused. Anyone having these problems try something I haven't? Please post. Iv'e run out of ideas aside from tethering my iphone or saying goodbye to my TC and security encryptions.
  • Russa Level 4 Level 4
    ..delete the AIrport service in the Network preference and recreate it.
  • ctmurray Level 1 Level 1
    I just helped another person with the tip of repairing permissions. Specially after an OS upgrade.

    Repair Permissions:
    * Open Disk Utility, located at /Applications/Utilities/Disk Utility
    * Select your startup disk on the left of the Disk Utility window
    * Select First Aid from the tabs
    * Click the "Repair Disk Permissions" button

    Post back if this or any tip works for you so we can help others.
  • Matt4mac Level 1 Level 1
    Thanks for that tip. That's something that I hadn't thought about. But it definitly helps after OS updates. Started repair. Says it'll take 9 minutes.

    Time capsule connection is a bit more stable after renaming it. Though not a smooth as before update. I'll post back after the permissions are fixed.
  • matteocaldari Level 1 Level 1
    I tried deleting the airport service and recreating it, and repairing disk permissions, but had no luck.

    Now I found that when I join a new network, for the first time, only for the first time, it works, and it does also if I change the name (SSID) of my network to a new one.
  • lost.carrier Level 1 Level 1
    Same here... I got a Mac Mini from late 2007. Since install of the 10.6.5 update yesterday, I have very high ping times (1-10s!) or even loss via WLAN...

    I've tried the repair permissions and reinstall AirPort tricks, but no luck. :-/

    Any further Hints?

    Is Apple aware of this 10.6.5 bug, yet? Are they already working on it? Is there some kind of status page?
  • Matt4mac Level 1 Level 1
    I have had a solid connection to the Time Capsule router all morning with expected speed, up and down. I don't wanna call this solved for me because I still had disconnects and airport wonkiness after repairing permissions last night. But, today is a different day, I guess. So far, so good. I have no idea what to suggest, as I have tried so many things. Will report back if things go south again. Thanks everyone for your help/suggestions!
Previous 1 2 3 Next