Previous 1 3 4 5 6 7 Next 91 Replies Latest reply: Nov 23, 2012 11:13 AM by Heckles Go to original post
  • kreisman Level 1 Level 1
    Had same problem with iPhone 3GS. Did the upgrade using a different computer, which did not have my media on it. I'm out of town, so could not do sync. Instead, I performed a backup of the phone again, which I had done just prior to upgrading. Doing this backup (NOT A RESTORE) caused all the media to re-appear.
  • Adoos Level 1 Level 1
    Had the same problem and the steps below worked out well.

    Cheers
  • persis roumbis Level 1 Level 1
    Thanks for the solution. this solved it for me too!
  • madein1985 Level 1 Level 1
    soooo..... this was my first iPhone update.... and I suppose I fooled around with iTunes and my phone until the disappearance of my music seems irreversible. it even seems that under the 'about' tab I've lost all my songs for good. can anyone tell me if there is a fix? if there is, any sort of fix, please explain it very simply. ha. oh it really hurts to think about all my songs being gone. guess I'll do some research next time.
  • kimberly2720 Level 1 Level 1
    This totally worked/___sbsstatic___/migration-images/migration-img-not-avail.png/___sbsstati c___/migration-images/migration-img-not-avail.png/___sbsstatic___/migration-imag es/migration-img-not-avail.png I did NOT have to sync or connect to iTunes. I just changed the language to French and then changed it back to English. Then all my music magically reappeared/___sbsstatic___/migration-images/migration-img-not-avail.png
  • josh20bass Level 1 Level 1
    I tried to update and everything was deleted. A lot of my songs had been purchased in the iTunes app on the phone and had not been synced to my computer yet. I can't figure out a way to retrieve them and now I am missing well over 100 songs. Any advice on how to get them back?
  • ywo Level 1 Level 1
    @Applezilla:
    Thx for posting. Had the same issue after installing iOS 4.2. Your trick worked fine. I only discovered the issue after downloading some songs from itunes for iphone and nevertheless my ipod on my iphone was empty.

    Applied your trick and all my music is back on there including the downloaded music. Thank god!

    Cheers and again thx for posting.
  • ywo Level 1 Level 1
    @Justin D'Onofrio:
    Might indeed be the case, as I also keep manual manage my music (want to keep my iPhone clean and not put all my music on there).

    However, never had the issue before. Only since upgrading to iOS 4.2...

    @everyone:
    Does anyone of you, who manually keeps track of their music, have already upgraded to iOS 4.3 and experienced the same?

    Yves
  • S1ggy Level 1 Level 1

    Mine is not working at all.

    It says when its syncing the music, that there is no music being synced on the iPhone.. Please help!

  • shoodyOsome Level 1 Level 1

    thanxx it worked !!

  • hermannfromhaskell Level 1 Level 1

    But what if it's set so that I manually manage my music and videos?? I can't sync it though. Itunes shows that i have music on my iphone but my iphone itself shows otherwise, how can I fix it?

  • DJP931 Level 1 Level 1

    I am having a similiar problem. I updated my Ipid touch to iOs 5.0.1 and I put my music on there but for some reason my songs are not updating like they should. I put the artist names and the song and when I go to music it says unknown not the name of the artist I put

  • LymeC Level 1 Level 1

    how do I play a song from itunes store on my iphone? I tried looking for music but all I can find are podcasts... please help, I've tried so many online suggestions but I just can't get my music and photos back... am frustrated and disappointed with apple. I tried to access the itunes store via the ipod app but i keep getting 'Cannot connect to itunes store'....

  • danyfrazao Level 1 Level 1

    This is happening to my iPhone 4!!!!!!!! The strangest thing is that songs didn't disappeared immediately after I updated.... Now I have done all those tricks below and it's not working at all!!!! Someone please help me!!!!! I want my songs back!!

  • idontcarejustletmein Level 1 Level 1

    Try a restore. It worked for me - this would be my second restore, did a restore after update because I felt like it; made me wonder if that was what triggered the problem.

     

    Jesus, this is 2012 and this is still happening.

Previous 1 3 4 5 6 7 Next