Previous 1 2 Next 22 Replies Latest reply: Jul 15, 2012 12:15 PM by mistermuziq
long_haired_david Level 1 Level 1 (0 points)
I have just bought a new Mac Mini and have loaded up the iPhoto supplied with all my photos. I have just intsalled iPhoto '11 and now I get a message as follows:

"In order to open iPhoto, you need to update to the latest version. Please run Software Update to imstall it now."

As I have just installed the latest version I am a bit concerned about my photos and using the software. I have checked and all the other iLife updates - iMovie, etc. are all working fine.

Can anyone help here?
Thanks
David

Mac Mini 2010, Mac OS X (10.6.5)
  • Ric Donato Level 4 Level 4 (1,095 points)
    Hi longharieddavid,
    Welcome to the iPhoto forum.

    Allow me to suggest you peruse this forum. In the iPhoto '11 forums are a gazillon posts regarding the same issues, or quite similar, as yours. In there you will find many suggestions to fix your issue. Also, in the upper right is "Search Discussions, more Options". There you can search for answers for Apple products.

    Being as this is your fourth post be aware this is a user helping user forum; Apple does not answer posts in these forums. It is my hope you can find a solution to your issue.

    Fixing permissions is one thing that is mentioned that may or may not work.

    Terence Devlin suggests: Try remove the DivX components from HD/Library/QuickTime. Restart your Mac and try again. The user he responded to replied, "This Worked ".

    Cordially,

    RicD
  • Old Toad Level 10 Level 10 (127,665 points)
    Welcome to the Apple Discussions. If Ric's suggestion doesn't work try this: backup the library and try the two fixes below in order as needed:



    Fix #1


    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your User/Library/Preferences folder.

    2 - delete iPhoto's cache files that are located in the User/Library/Application Support/Caches/com.apple.iPhoto folder.

    3 - reboot, launch iPhoto and try again.




    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding the the Option key. You'll also have to reset the iPhoto's various preferences.


    Fix #2

    Launch iPhoto with the Command+Option keys depressed and follow the instructions to rebuild the library. Select options #1, #2 and #6.



    Click to view full size



    OT
  • LarryHN Level 9 Level 9 (67,200 points)
    and give iPhoto Library Manager - http://www.fatcatsoftware.com/iplm/ - a try

    Update 10/24: I released a quick 3.5.8 update yesterday, which doesn’t yet provide full iPhoto ‘11 compatibility, but does provide a couple improvements for iPhoto ‘11 users, including a fix for those experiencing the issue of being unable to reopen a library after upgrading it to the new iPhoto version. If you have such a library, simply open the library up via iPLM, and you should be prompted by iPhoto to upgrade the library again. Once it’s complete, you should then be able to close and reopen the library normally.


    LN
  • long_haired_david Level 1 Level 1 (0 points)
    Thanks for the comment. I should have searched of course.

    However, I solved the problem. It was in the error message, viz. "Please run Software Update to imstall it now."

    Believe it or not I ran Software Update - it downloaded a patch and everything worked.

    After 20 years of Macs I should be better than this!
  • F. Farmer Level 2 Level 2 (200 points)
    I'm having the same problem, and also get that "please run Software Update ...." message. But when I do, it tells me everything is up-to-date. However, if I try to start iPhoto, I get the same error message, that it needs to be updated. Very strange.

    All the other apps in iLife11 seem to be working fine.
  • Terence Devlin Level 10 Level 10 (133,930 points)
    Have you moved iPhoto from the default Install location? Into a Sub-Folder perhaps?

    Regards

    TD
  • F. Farmer Level 2 Level 2 (200 points)
    I did create an "iLife11" folder within the Applications folder and moved all the new iLife applications into it because I wanted to retain the old iLife apps until I was happy with the new ones. I thought this may be causing the problem, but when I moved iPhoto out of it and back into the root Applications folder, it still didn't work. The other apps work fine.
    Thanks for the suggestion. Any others?!!__
  • F. Farmer Level 2 Level 2 (200 points)
    I removed the DivX thing as suggested in Ric's message above, and restarted, but iPhoto'11 still would not run, giving the same error message that it needs updating, yet Software Update tells me everything is up to date. Get Info tells me that the version number of this iPhoto app I have is 9.0. Seems there's a 9.1 available but I can't get to it.
    My old iPhoto 8.1.2 works fine.
    So now, I will try the other advice provided in this thread.....
  • F. Farmer Level 2 Level 2 (200 points)
    I've just tried Old Toad's suggestion for Fix #1, but sadly it didn't help. And I couldn't get anywhere with Fix #2 (holding Option + Command) but iPhoto simply wouldn't even start, even after restarting the computer.
    For now, I'll stick with iPhoto 8.1.2.
  • F. Farmer Level 2 Level 2 (200 points)
    Problem solved?
    Since I couldn't get Apple>Software Update to find the iPhoto 9.1 update for me, I went to the Apple site and under Support found the available update, which I downloaded. At first, it refused to install on my Macintosh HD but that was because I had placed iPhoto9.0 (all the iLife'11 apps, actually, to keep them apart from the iLife'09 apps) into a separate folder which I named iLife11. After moving iPhoto9.0 out of that folder and into the root Applications folder, I was able to proceed with the update installation successfully. I was then able to start iPhoto9.1, even after moving back it into my iLife11 folder. But that's as far as I went with it, because iPhoto immediately said it needed to update my photo library which would become unreadable by older versions of iPhoto. I wasn't ready to commit to that just yet. It's not a huge library, so I will back it up first, before "converting" it to iPhoto9.1 standard -- just in case I need to revert to iPhoto8.x.

    There was also an update for iLife (9.0.4) on the Apple support site, so I downloaded and installed that too. All the iLife11 apps seem to work (at least, they start up).

    I see that the advice to seek the iPhoto9.1 update on the Apple support site is also given in other threads about this same problem. This is probably the best solution.

    Message was edited by: F. Farmer

    Message was edited by: F. Farmer
  • Steve Vansak Level 1 Level 1 (20 points)
    I used this thread for my iPhoto 11 troubleshooting and I can report that removing the DivX components from HD/Library/QuickTime and then restarting my Mac solved my problem of iPhoto 11 not launching.

    I had downloaded the 9.1 Update from Apple and had it sitting on my desktop ready to go, then I installed iPhoto 2011, then applied this update immediately. I did not corrupt my library this way. It just would not launch. I'm happy to report that after the above fix was applied, iPhoto started up and everything was intact.
  • luckyref Level 1 Level 1 (0 points)
    I was not able to install the lastest patch, and the Software Update was saying that everything was up-to-date. I moved back the iPhoto into the original Application folder and then, I was able to update iPhoto with the Software update.
  • Forsethi Level 1 Level 1 (0 points)
    Hello after which I had installed iLife 11 starts iPhoto with a mistake report. start from iPhoto over the terminal the following error message proves. "iPhoto [378] <Error>: CGBitmapContextCreate: unsupported parametre combination: 8 uprightly bits/component; 32 bits/pixels; 3-component colour space; kCGImageAlphaPremultipliedFirst; 523 bytes / row.
    objc [378]: FREED (id): message autorelease sent to freed object=0x1c100b50
    Illegally instruction"
    Could somebody explain to me?
    many thanks beforehand
  • Old Toad Level 10 Level 10 (127,665 points)
    Welcome to the Apple Discussions. Don't know what that means. Have you tired any of the fixes that have been posted? Which ones and what were the results exactly?
Previous 1 2 Next