Previous 1 4 5 6 7 8 Next 140 Replies Latest reply: Mar 4, 2015 10:05 PM by Mort Al Go to original post
  • ckahn Level 1 Level 1 (0 points)

    Same here -- zapping PRAM and bypassing rEFIt brought back the brightness controls.   Weird.

  • kevung Level 1 Level 1 (0 points)

    Hey all,

     

    I'm using a 2009 iMac intel dual core with snow leopard. I'm in Hong Kong so I left my Snow Lopard disk at home, so I ran into similar problems as you guys, except with Bootcamp 2.0 which came with the iMac computer. Anyways, my colution was to update my nvidia driver. After that, my keys worked perfectly. Try it out!

  • Djnetics Level 1 Level 1 (0 points)

    Ok guys. I'm back again.

     

    Found a new way WITHOUT zapping PRAM. Don't know if it works for you guys. Worth a try on this serious Screen Dim issue.

     

    I've just installed the new OS Lion. Don't know if it's the Lion that helps it out or not. I also have rEFIT installed into my Mac.

     

    After turning on your MacBook Pro, once you heard the boot up sound, hold on to the EJECT button till rEFIT screen comes up. (You can let go of the button now.)

     

    Choose your Windows OS and boot it in.

     

    Press F1 or F2 and the screen dim comes back to life.

     

    Boot Camp control panel in windows will still be missing the Brightness adjustment.

     

    So try it out guys and let me know if this method works for you on Snow Leopard or Lion. Really hope it helps you guys rather than zapping the PRAM everytime and worrying if it will cause the Mac OS to malfunction in some ways or another.

  • izevaka Level 1 Level 1 (0 points)

    Same problem and solution here - rEFIt was the culprit causing brightness not to work in Windows. Thanks for pointing this out.

  • William.Dettmann Level 1 Level 1 (0 points)

    Same thing here, I noticed my brightness controls worked when I switched to Lion and reFiT stopped working.  After reinstalling Lion to the final release I tried it again and got reFiT working by manual install but the brightness did not work again, uninstalled reFiT and the brightness started working again.

     

    Edit:  I hope someone is able to get reFiT working again properly it was one of hte best addon for people who used bootcamp.

  • William.Dettmann Level 1 Level 1 (0 points)

    Has anyone reported this problem to the refit sourceforge bug tracker?

  • tdma800 Level 1 Level 1 (0 points)

    My friend bought a macbook pro in May of this year. I installed bootcamp and Windows 7 on it.  Automatic updates were not turned on.   This week she said the Windows portion was too slow. So I installed  Service pack 1, Windows Updates, etc etc. 

     

    The computer works properly except that one of the updates probably disabled the brightness adjustments, similar to what is happening to other people here.  I didn't install any special bootladers or anything. Just boot camp.

  • stuartloh Level 1 Level 1 (0 points)

    MBA, with annoying brightness problem after windows 7 32 bits update at 4 days ago. F1 and F2 failed to operate as everbody here encountered, with the ! sign in the Device Manager at the Display Adapter and Bluetooth Peripheral device, after uninstalled it and restart succeed to gain the proper driver for Display Adapter(shown as Nvidia Driver), but still having the problem with ! sign at Bluetooth Peripheral device. but still can't get the proper brightness adjustment from the Nvidia control or from the F1 and F2. and have tried to update the display driver through the update tab in the driver properties through online update but came up as my driver was in the latest version at mean time.

     

    After trying for so many days, and make up my mind to download a new Bootcamp 3.2 (which i had too in my computer that i had updated months ago) and installed again still without any progress. Then tried again with the driver update in the Driver properties and found that it had a new version of driver to be download and install, in the installation process, the brightness suddenly came back to its proper level, and after installation finish, the F1 and F2 resume the proper operation and i got back to the normal control.

     

    Went back to the Device Manager and found that the Display Adapter name have changed to Nvidia Geforce 320M.

     

    Advice to let your brightness level to atleast at minimal 1 or 2 level before the update process, don't close all the level as you may get a black screen in the driver update progress and scare **** up to you .

     

    Hope this may help people with the same MBA with the same problem.

  • Malte Noerskov Thy Level 1 Level 1 (0 points)

    I also have the brightness problem with my iMac (early 2011) running Lion and my MBP 2011 (new model) running Windows 7 x64.

     

     

    when I'm using the iMac as an external monitor for the MBP running windows 7, the brightness can no longer be adjusted...

     

     

    After searching for a solution for a LOONG time, I ended up installing this little tool - DIMMER:

    http://www.mylittlehost.com/dimmer.aspx

     

    I think it works by putting some sort of transparent layer on top of the screen - but it works fine. You can even select the transparency

     

    Hope this helps in some way!

  • griffinfromchicago Level 1 Level 1 (0 points)

    I found the solution! FINALLY.

    Specs: MBP 15" with radeon 6750 (the problem, really) (early 2011 or late 2010).

     

    disable windows User Account Control, restart, repair the Apple Bootcamp service, restart, make sure your radeon 6750 driver is enabled, and BOOM. It works.

     

    Here it is:

     

    I had the exact same problem, only on a 17" MBP. In my case, Win7 event manager reported that BootCamp 3.2 Services failed to install, in particular the KeyAgent service (and without that you get no Apple keyboard and functions and apparently the BootCamp icon doesn't show up in the system tray).

     

    Event Manager said the BootCamp installer did not have sufficient permissions, so I went to dial down the User Account Control (UAC) settings (in fact, I turned it off). What I should have seen when BootCamp 3.2 update was running was a window to ask my permission to continue (allow the software to install). Instead, there was a silent failure.

     

    OK, so by turning off UAC that gives it permission in advance (you have to reboot after changing the UAC settings in order to ensure that it is truly OFF). After rebooting, I went to Programs and Features and found BootCamp Services as a software item. I selected "Repair" and after another reboot, I was back in business! Keyboard is now fine (including the disk eject button, which I wanted working). Then I went back to turn on UAC to its default level (one notch below highest setting). It is useful (normally) to have this on.

     

    Ask the Windows Help system if you don't know how to find the UAC settings to give this a try. Hope it helps you.

     

    From:

    dawalters

    https://discussions.apple.com/message/12613397#12613397

  • Polytonic Level 1 Level 1 (0 points)

    You sir, are a genius.  I commend you on your brilliance. 

    /bow

  • ckahn Level 1 Level 1 (0 points)

    Disabling UAC helps complete the installation of BootCamp_3.2.2792.exe (is that the latest?) but the brightness control still only works if I bypass rEFIt when booting up.

  • USMarshall Level 1 Level 1 (0 points)

    please note, not all terms may be accurate, but the concept does work...

     

    Problem: unable to control screen brightness in Windows OS after boot drive option automatically boots to Mac           OS and than switching to Windows OS.

     

    Solution(at least as I have found to work consistently): Don't boot into Mac initially, hold 'option' or 'alt' and           press the power button and choose the Windows OS drive and boot straight to Windows.

                                       -OR-

    Set the default drive to Windows OS and hold 'option' or 'alt' when you desire to boot into Mac OS.

              To set Windows as the default, Go to Start -> Control Panel -> Boot Camp -> Yes -> And than just           select the appropiate start-up drive.

     

    As far as I can tell, this does work consistently, and is escpecially good if you have to use Windows OS often, or even half the time, as it allows the screen brightness to be changed.

    Basically, or so it does seem, the reason that the screen brightness does not work on the Windows OS is because of something the Mac OS does when it is booted (not sure how/what/why, but thats the evidence).

  • LostLegend Level 1 Level 1 (0 points)

    I want to thank all of you so VERY much for working this out. This problem has been plaguing me for months. I had trouble searching for the correct term before I found this thread and it hadn't really been bothering me until I really stated using it at night.

     

    I'm using a Macbook Pro 17" w/ Radeon HD 6750M video card. I have tried updating software, drivers, using video drivers that aren't made for this card specifically, everything else I could thing of including trying 32bit and 64bit Windows 7.

     

    I just want to say that the solution to this was not my idea, I just followed what everyone else has done.

     

    My problem, simply, was rEFIt.

     

    However, I did find that by bypassing rEFIt by either holding the Option key or setting the Startup Disk in the Boot Camp application as the default boot disk (and restarting), I could get the dim function back.

     

    I ended up removing rEFIt since it wasn't working for what I needed anyways. To the poster that was running OSX, Win 7 and Linux, try booting holding Option and bypassing rEFIt and see if that works for you.

     

    Thank you thank you thank you again to everyone!

     

    Now time to reinstall everything again since I was hoping that a Windows reInstall would fix it. I'm just happy this is resolved!!!

  • ZHPlatform Level 1 Level 1 (0 points)

    Beautiful!  Thankyou!

    This solved my "key agent/bootcamp/volume and brightness control" problems.

    griffinfromchicago wrote:

     

    I found the solution! FINALLY.


     

    From:

    dawalters

    https://discussions.apple.com/message/12613397#12613397

Previous 1 4 5 6 7 8 Next