Previous 1 2 Next 17 Replies Latest reply: Mar 27, 2011 11:25 PM by turtle42069
Wags28 Level 1 (0 points)
I bought a computer for my self for christmas. I got a iPod touch 4th gen for christmas from my mom and i set it up on my new computer. I have ALOT of space on this computer. I noticed my iPod has an update for 4.2 and decided to wait because i wanted to transfer my apps from my 2nd gen to 4th. I go to update it and all of a sudden it goes to the end of the download and then it give me an error saying its the network. I have stong internet connectivity. I dont know why it wont download. Can you please help me?!?!

Asus Windows 7, Windows 7
  • roaminggnome Level 10 (95,027 points)
    Have you tried disabling your firewall?
  • Wags28 Level 1 (0 points)
    no but ill try that now
  • Wags28 Level 1 (0 points)
    ok i took off the firewall and i redid the download of the update and it didnt work again.. I got err = -3259
  • Chrissy M. Level 1 (0 points)
    I'm having the same problem! I have a 2nd generation and just downloaded the latest version of iTunes on my new laptop, but when I went to put the new update on my iPod it got to the end of the download and said it was something about my network too. I can't figure out why the download won't work.
  • lonewolf070571 Level 1 (0 points)
    I just got the ipod touch 4.1 32gig and already had a ipod touch 2.0. The recent update will only download to the old ipod touch 2.0. If I try to download to the ipod touch 4.1, it will get to the end of the download and it give me an error message saying it timed out and it's having network problems. The download was complete when the error message came up. And how can it update the 2.0 the first time I tried while I tried to upload on the 4.1 6 times now. The 4.1 was highlighted new and shouldn't have a conflict with the 2.0.
  • tjoph Level 1 (0 points)
    I want to know the answer, too. I've repeated the download/update process at least ten times with the same frustrating result '... problem downloading... network timed out ... etc. when I know there's no network problem (I've tried three different networks). I'm almost at the stage of doing a complete iTunes uninstallation/reinstallation to try and resolve the problem but hope that someone here can come up with an answer.
  • Wags28 Level 1 (0 points)
    I am having the exact same problem as you lonewolf. I have everything including both the ipods same size same gen. and having same problem
  • Wags28 Level 1 (0 points)
    Im on the phone with apple i will tell everyone what they tell me here!

    Apple Says:
    Its the firewall. After you disable the firewall you have to exit out of itunes and try the update again?
  • bronco1991 Level 1 (0 points)
    I tired disabling my firewall and it didn't work.
  • samsmiles Level 1 (0 points)
    Yeah I have the same problem as well! and I tried disabling my firewall, but it still doesn't work.
  • jacintomx Level 1 (0 points)
    I have the same problem for weeks, i have no firewall. I went to the store to update one of my devices but i cannot do it again.
  • kevin buick Level 2 (410 points)
    there's a bug in the itunes or some thing i got the software to download i just keept reloading the page every time it timed out.
  • Edindie Level 1 (0 points)
    Same thing happened to me, but now I'm stuck with no software needing to restore all the time.
  • Earthsea Level 1 (0 points)
    In case it may help... I have just posted a couple of replies on the thread 'iTunes won't let me update version 4.2 for iPod touch' which discusses problems remarkably similar to yours.

    HTH
Previous 1 2 Next