Previous 1 5 6 7 8 9 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • Austin Bellagirl Level 1 Level 1 (0 points)

    My printer was working beautifully since I followed Oz's instructions several months ago, and now, lo and behold, I'm suddenly having this issue again.  I have changed nothing in my setup.  Have there been any recent software updates that could be throwing a wrench into things again?  i was fixin' to install Mountain Lion, but now I'm apprehensive in case that will pose yet another complication.  Help, please!  One very frustrated Mac user.

  • Austin Bellagirl Level 1 Level 1 (0 points)

    I'm in need of help From Oz again!  My printer decided to stop printing suddenly a few days ago when I last posted.  This evening, it printed one page and then proceeded to go back and forth between the Communication Error message and printing.  It makes no sense to this computer novice, help, please, as your advice is the only guidance I've found thus far that solved my problem for the last several months until this cropped up again. Thanks!

  • Ron R Level 2 Level 2 (320 points)

    Thanks for the tip!  I had also been dealing with this problem with my MX350 for the past 5 months. It now works with no more "communication error."

  • hermionesmom Level 1 Level 1 (0 points)

    This worked!!!! Thank you.

  • Ron R Level 2 Level 2 (320 points)

    Well, It worked for about a week. went to print a job today -  "communication error" again. had to go back to the printer and reset the router connection then delete the printer and reinstall it. oh well.

  • NichoTL Level 1 Level 1 (5 points)

    Of all of you who are experiencing the problems AFTER the solution from 'fromOz', how many have mixed environments (PC/Mac)? How many print from multiple computers (Macs, PCs)? The reason I am asking is because I have been experiencing some bizarre behaviour and I am trying to see if it is relevant to the discussion.

  • uskrums Level 1 Level 1 (10 points)

    I have a mixed environment, but most of the printing (90%) comes from the Mac mini or my MBP.Hard to quantify how much it fails, but it still has a problem even after all the solutions from Oz. His solutions did help, as before that it was a 100% failure. I don't have to delete and add or anything, I just have to power down the printer. delete the jobs from the que and then restart printer. Takes maybe 2 min. I gave up trying to get the foolproof fix.

  • joe3945 Level 1 Level 1 (0 points)

    This is BS. I see this issue started in 2011? It is now October 2012 and the canon techs seem mystified. Still? They assigned me a new manual IP address and that worked about a week. Then the same problems. OZ's instructions look good, until the part where I select the new printer. THEY ARE NOT THERE. The printer does not show up on the 'add printer' box. Plug it in with USB, nothing. It is infuriating. The stupid canon techs tell me to reload software. I've done that three or four times and then the smarter ones got me to change IP address. Now it does not work again.

    I'm sure this all started with Lion, and Canon upgrades to Lion.

  • amylevin Level 1 Level 1 (0 points)

    Completely agree - this has gone on way too long. I still cannot reliably print to my Canon - and if my computer can actually "find" the printer the latest trick is that it pauses the print queue after each job.

    This is absurd. I bought an Epsom for my home office and took the Canon to work and the Epson is better but still occasionally can't be found.

  • Ron R Level 2 Level 2 (320 points)

    Although, it may not be the ultimate fix, over the past month or so, I changed the channel on my router settings to one that no one  else in my local area was using.  This has resulted in a more steady MX350 printer connection.  I have not had to reset it or reboot the router once.

  • FromOZ Level 2 Level 2 (415 points)

    Hi all again. I have been seeing from emails from the forum that the info I posted worked for people fine then the problems mysteriously come back. Frustrating.


    The instructions I posted were what I would advise as 'best practices' in the sense that that is the best way to attach a printer to network. I don't have the MP560 printer myself, I have the Canon iP4600. I posted the instructions to help my brother who does have an MP560 and it got him sorted out.


    In my setup I have the iP4600 directly connected to one iMac in our home office and it is shared via that iMac. I have never had any problems with that setup and/or that model Canon.


    To see a situation where my instructions work and then stop starts to sound to me like driver issues. I believe Canon (like other printer manufacturers) write the drivers and supply them to Apple. I would keep on pressuring Canon. It seems unlikely that it is down to Apple's printing platform (used for all printer brands) otherwise there would be the same issues for other brands.


    Harass Canon - good luck.

  • mik194254 Level 1 Level 1 (0 points)

    As a point of interest I get this problem consistantly from the iMac (pause & restart printer a few times for it to burst into life) however I never get the problem from my macbook pro, iPad 2 of iPhone. I will follow up on your suggestions and hope that cures the iMac issue. Incidentally my printer is an MG6200.

  • cjw17 Level 1 Level 1 (0 points)

    I cannot believe how complex this issue seems to be given that Apple is supposed to be so simple. Why dont they do something about this ?


    It brings me back to the older Apple commercials with the IBM and Apple guys.....  Only now its Apple in the buttondown shirt with the glasses, and irritating and lame answer to questions posed by simple consumers.


    Unbelievable the hype behind Apple.    I go by one of their massive stores that is jampacked with consumers and wonder,...  what are they selling ?


    - a Desktop computer

    - a Laptop computer


    - iPhone

    - big iPhone that doesnt have a phone  (ie iPad)

    - small iPhone that doesnt have a phone (iPod touch)

    - iPhone without a screen or a phone  (iPod nano)


    - exorbitantly expensive accessories......




  • Harden Long Level 1 Level 1 (0 points)

    As stated other places in the thread, this is most likely a Canon problem and not an Apple problem. It seems specific to Canon's Bonjour/mDNS implementation.


    That said, here is my work-around. (Note that I am on Mountain Lion 10.8.2.)


    • Assign your printer a static IP, or configure your DHCP server to give your printer the same IP, always. (I run dd-wrt firmware on my router and that comes with DNSMasq. I configured a static lease by adding this to the free-form text field in dd-wrt's DNSMasq configuration page: dhcp-host=00:1E:8F:62:A6:E5,MP560,,infinite where 00:1E:blah:blah is the MAC address of the printer as reported in in the LAN settings.)
    • Enable LPR on your printer. It's buried under the settings > lan settings > other settings > LPR protocol setting
    • Now, on your Mac, remove the non-working printer via system settings. Manually re-add using LPD as the printing protocol instead of Bonjour. To do that you click the + in the printer panel, click the IP toolbar button, set protocol to LPD, enter the static IP of your printer, leave queue blank, and pick the Canon MP560 under the Use drop-down.


    That's it. Your printer will work, now. You can do more detailed configuration by accessing http://localhost:631 if you're tech savvy.


    Message was edited by: Harden Long - fixed typo

  • loganfromMO Level 1 Level 1 (0 points)

    I am running Lion on iMac with NetGear router and Canon MP560.

    I am having the same problem as all others

    All the workarounds are over my head, can someone please put in laymen terms?

Previous 1 5 6 7 8 9 Next