Previous 1 2 Next 29 Replies Latest reply: Jan 4, 2013 12:04 PM by MarianoMoran
Rikayla Level 1 Level 1 (0 points)
My iTunes won't detect my iPod touch (2nd Generation). Every time I connect it with my computer, a pop-up comes up and say that Mobile Device Service isn't on, and that it has suddenly stopped and has to close down.

Here's what I've tried so far:

- Uninstalling (following the Apple support document on how to ~properly~ uninstall iTunes) http://support.apple.com/kb/HT1923
- Reinstalling to the latest version
- Temporarily disabling AVG http://support.apple.com/kb/TS3125

Here are my stats:

Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2
System Manufacturer: Dell Inc.
System Model: Studio 540
Processor: Intel(R) Core(TM)2 Quad CPU - Q9400 @ 2.66GHz (4 CPUs), ~2.7GHz
Memory: 8190MB RAM

And here's what the exact error that I've been given from Windows:

Problem Event Name: APPCRASH
Application Name: AppleMobileDeviceService.exe
Application Version: 17.64.0.5
Application Timestamp: 4cb91bf4
Fault Module Name: kernel32.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e038c0
Exception Code: c06d007e
Exception Offset: 0001e124
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 4105
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

There was another thread here that talks about kernal32.dll but the thread suggests that I need to install the original AMDS (Mobile Device Service) of iTunes 10 instead of iTunes 10.1 version. I have no idea where to find that.

http://discussions.apple.com/thread.jspa?threadID=2678258

Any help would be amazing. Thanks!

Dell Studio 540, Windows Vista
  • Rikayla Level 1 Level 1 (0 points)
    Any solution?
    I'm finding other people with the same problem...

    http://discussions.apple.com/thread.jspa?threadID=2737392&tstart=0
  • cahern7 Level 1 Level 1 (0 points)

    I am getting the old version of JUST AMDS (version found in iTunes 10.0).... will post download link in a few mins...

  • cahern7 Level 1 Level 1 (0 points)

    OK I'm having problems uploading the files but HERE's HOW TO GET THE iTunes 10.0 VERSION OF AMDS!!!!

    First, go to http://oldapps.com and search "iTunes" in the search box (DO NOT PUT THE VERSION YOU WANT).

    Then, click the FIRST link reading JUST CLICK HERE: "Old Version of iTunes Download - OldApps.com." Then, if you scroll down, you will see many different versions of iTunes. Scroll down and click the version you want (in this case 10.) While that's downloading, you need to install UniExtract. http://legroom.net/software/uniextract (i dont know if this will work on macs....) When the itunes 10 downloader finishes, DO NOT RUN IT. it will just say that you already have a newer version installed. Instead, go to the location you SAVED it to (if you clicked "run" when that box pops up in some browsers, then you need to redownload the installer but click "SAVE") and RIGHT click the installer. (on mac you hold down control and click it) and find the button saying "UniExtract Files..." and click it. Change the BOTTOM location selector to a place you'll remember, and click OK. Then on the next screen after some loading, a box *might* pop-up with 3 bullet-buttons. CLICK THE LAST one and then "OK." (if thatr doesn't work, go back to it and try the first, and then the 2nd one...) When this is done, go to Start>Control Panel>Add or Remove Programs (i have NO idea how to uninstall on mac...) When in add/remove programs, uninstall "Apple Mobile Device Helper" (i think that's what it is, if not it has Apple, Mobile, and Device in the name.) when thats done, go to the folder you saved the itunes 10 UniExtract files to, and run "AppleMobileDeviceSupport" (may have .msi at end of the name). When thats done, you now have AMDS from iT 10 instead of iT 10.1!!! hope that helped

  • robydid Level 1 Level 1 (30 points)

    Thank You so much, I have been trying to fix this for such a long time now. I have heard so many false suggestions, such as getting a registry cleaner for the "kernel 32.dll"  and I have updated from 10.1 all the way up to 10.2.2 hoping that apple would fix this problem. Apple suggested removing itunes and all other apple products including the library files but that didnt work as well. I just cant believe they dont have a better resolution than that. So many people are having this problem and some have even changed to andriod phones because of this. The above suggestion fixes it all. The only thing I want to add is that AMDS for 10.0 might not work so I used the one for 10.0.1 so you might want to try out a few before you get your fix. Thank Again

  • ra1larsen Level 1 Level 1 (0 points)

    I downloaded iTunes 10.1.2 and ran after uninstalling iTunes 10.2 used older library and iTunes while still slow 2-5 minutes with nothing happening. It did run. Apple Mobile Device refurses to run. Error is Started but stopped due to some issue. It says started in Services but, it is not running. iTunes freezes when iPhone plugged in maybe waiting to AMD service? It cannont see device plugged in and Apple has no answer. Where do o go from here?

  • robydid Level 1 Level 1 (30 points)

    You dont have to uninstall itunes at all. I'm currenly only itunes 10.2.2 and you should just update to the same one. Once you have 10.2.2, the problem is going to come from the apple mobile device service (AMDS). What you need to do is to install the AMDS of itunes 10.0.1 using the instructions stated above by cahern7. Once you do that, it will prompt you to restart your computer and Voila, problem solved. Atleast thats what worked for me. The AMDS of 10.0 did not work for me, it made my it so that my computer didnt recognize the iphone at all. So try 10.0.1 using the instuctions by cahern7 and let us know if you run into any problems. Good Luck

  • ra1larsen Level 1 Level 1 (0 points)

    I am cunfused on versions here. iTunes 10.1 was fine for me and that is why I tried going back to it. I downloaded version 10.1.2 from httpsw://oldapps. It is still in my download folder. Research now shows issue with AMDS and not sure when it was changed except that I had no problems until upgrade to 10.2. Is iTunes itself hanging on startup only due to AMDS issue? Is there a site where I can just get AMD only (Ver ??) and install after uninstall of current AMD. I have seen here people are having issues uninstalling AMD. Any Help is appreciated. I can deal with slow if needed but,  would like to see what is going on.  Right now iTunes does nothing for 2-5 minutes after starting from shortcut. Apple did this two years ago and now seems to repeats itself with a slower App that will not see my iPhone. Is there a sweet spot in iTunes Versions for Vista 32 bit users with iPhone 3G??

  • robydid Level 1 Level 1 (30 points)

    The problem seems to arise after upgrading to versions after the initial 10.0 release. I personally started to have problem after I upgraded from 10.1.2 to 10.2.0. I will incooperate what Cohern7 did to fix the problem along with what I myself have done.

     

    1. Completely uninstall the current version of Itunes including Apple Mobile Device Support, You will find it after going to Computer, Make sure you delete both of them.

     

    2. Next install the latest version of itunes from the apple website. Make sure to download the correct one as there is both the 32 bit and 64 available.

     

    3. Now the problem with AMDS might still persisit as it did for me. So you want to uninstall Apple Mobile Device Support (again), you will find that after going to computer and uninstall programs.

     

    4. Next install itunes 10.0.1  http://www.oldapps.com/itunes.php , Just scroll down until you see 10.0.1

     

    5. Save it to your desktop or somewhere visible.

     

    6. Next install UniExtract

     

        http://www.legroom.net/software/uniextract

     

    7. After the installation is complete go to where you save your itunes file, right click and click on uniextract

      

        files.

    8. Press Ok and make sure its set to your desktop.

        On the next screen when prompted to choose an extract method, choose "Not an Installshield

        installer".

    9. Next open the folder you extracted and go to Apple Mobile Device Support and install it. Once complete

        Restart your computer and it should work.

     

       (If it doesn't work try different versions of the old itunes programs such as 10.0) Good Luck

     


     


  • ra1larsen Level 1 Level 1 (0 points)

    Thanks for all the help and clarification. AMD is now running but with itunes 10.2.2.17 which I just down loaded it appears Apple may have changed something. BAD News is iTunes 10.2.2.17 does not see iPhone attached! I had left Ver 10.1.2.17 which I thought would work after using your instructions AMD did run but still no iPhone seen by iTunes. We got AMD to run which is Good. iTunes still cannot see Device which is Bad! iTunes crawls when opening and when a device is attached it actually is Non Responding, I can live with. I just need it to see my iPhone????

  • ra1larsen Level 1 Level 1 (0 points)

    OOPS! My bad latest version is 10.2.2.12 which still cannot see my iPhone! Any Help out there???

  • robydid Level 1 Level 1 (30 points)

    So what you are saying is that it didnt work on 10.2.2 after installing the AMDS of 10.0 or 10.0.1. Be very specific on what you tried and didnt work for you so we can suggest other ideas.

  • ra1larsen Level 1 Level 1 (0 points)

    Sorry. I did not install AMDS from 10.0 or 10.0.1 as the latest install of iTunes 10.2.2.12 included an AMDS that worked properly, I stopped at YOUR step 2 above. The driver is now installed when phone plugged in and working properly (running) which did not happen earlier. Now running 10.2.2.12 with packaged AMD Support and that works properly as seen from MicroSoft device driver/services and iTunes Diagnostics. It (iTunes 10.2.2.12) just does not see any device connected, and it takes a long time to respond.  I had checked before I went to your next step getting from 10.0. The old from 10.1 I had downloaded and extracted per your instructions corrected the AMDS issue also but failed to see device, I thank you for the specific directions, I had not removed before installing older version of iTuunes.  I did per your suggestion removed all and reinstalled from Apple site then tried as I saw device driver being set up when iTunes opened and later when iPhone pluggged in. Yes, Microsoft sees my iPhone in Computer.

  • ra1larsen Level 1 Level 1 (0 points)

    Voila!! and My Bad!! I re-read and followed instructions loading and installing AMDS from iTunes Ver 10.0.1 and You and Cahern7 suggested. I simply uninstalled AMDS from iTunes 10.2.2.12 and installed Version from 10.0.1. It Worked just as the both of you said. iTunes pops up in a Flash and it Sees my iPhone all works well and I checked numerous times as I only get ERROR! "iTunes  was unable to load data class information from Synch Services. Reconnect or try later. I Can Live with That all I do is close box. I tried Apple easy remedies and guess what? they did not work. I do not care and I am just HAPPY to have iTunes appear in a flash and connect to My iPhone. I cannot thank You both enough especially ROBYDID, like you took time to say Be Specific. I did and follwed Specific instructions and it works.

  • ra1larsen Level 1 Level 1 (0 points)

    Did you ever find solution? If you read down this discussion you started. Cahern7 and robydid provided information and help that worked for me.

Previous 1 2 Next