Skip navigation

Bluetooth + Wifi Interference issues

38631 Views 38 Replies Latest reply: Feb 7, 2014 3:32 AM by ChemicalElectric RSS
  • bizresearcher Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2011 12:44 PM (in response to CarlosRG)

    the mba was fine till 2 days ago when it suddenly had very slow connection and i couldnt figure out why. the ipad was working fine. then i checked the forum and sure enough, when i turned off the bluetooth, the connection was fast again (i am using bt mouse and keyboard).

     

    logged on to my router and wap has no 802.11n. only 802.11g or 802.11b (i'm on sky) but it did have a 'mix 802.11g and 802.11b' option which i chose. that solved it.

  • rrichard Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 8:52 AM (in response to ~BobS~)

    Thanks BobS;

     

    Changing my AP to 802.11g on Ch5 cured the issue.

  • aarellano Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2012 7:23 PM (in response to CarlosRG)

    Same problem here. In my case, the Wifi doesn't auto connect when I'm NOT in my office, where I have my bluetooth accesories (keyboard and magic trackpad).

     

     

    My guess is that the interference is produced when the bluetooth keeps looking for known devices to pair with. I have reassured this since if I turn off the bluetooth, all the Wifi problems disappear. Actually, this is my current solution to the problem.

     

     

    This could also explain why there aren't too many users complaining about this, since it only happens to people who use bluetooth devices regularly.

  • jminhudson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2012 10:34 AM (in response to CarlosRG)

    Had the same issue here, here is how I resolved it:

    You have to define a new "Network Location" and set proper network service order in Preferences. 

     

    First you need to be logged as an administrator on your system (if you're the only user, that should be the default)

     

    Open System Preferences

    Goto Network Pane

    On top of that pane is "Location" that by default is set to "Automatic"

    Click on the right of that selection and then "Edit Locations"

    Click the "+" to add a new location

    Use any name that makes sense for you then "Done"

     

    Select the right WiFi network (in Network Name) just below Location on the preferences pane

     

    Then at the bottom left of the pane, click on the action cog (gear icon just above the lock icon)

    Select "Set Service Order"

    Then make sure your WiFi network is above Bluetooth.

     

    Cheers!

  • cwebber1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Feb 22, 2012 7:57 AM (in response to jminhudson)

    TEMPORARY...

    I tried changing the WiFi Channel, and it seemed to fix the problem.  Then it came back.

     

    Why did the problem come back.  I don't know for sure, but here's what I suspect:

    After I abandoned the interfering WiFi Channel, so other device with automatic channel selection (maybe in my home, maybe in a neighbor's home) saw the empty channel space, and jumped on that channel.

    This might explain why the FIX is only temporary.

     

    I wonder why the mouse/keyboard can't just use the wireless network.  Latency?

  • WoodyFlower Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 12:27 PM (in response to CarlosRG)

    Bought the Macbook Pro Retina and discoverd that when using bluetooth (streaming music) and Wifi together creates problems. pages are not loading, or the music stops...

     

    Aperently it's and old problem, strange it still excist!

    Is there a solution (note: dont know anything about routers and all that ****)

  • GregLec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2012 3:12 PM (in response to jminhudson)

    Nice one! Fixed my problem on new MBP Retina.

     

    Alson tried to change the channels but with little luck.

     

    Thanks!

  • graphic_mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2013 7:17 AM (in response to CarlosRG)

    My roomate and I were having the same problem. I have the new Retinal Display macbook and recently purchased the bluetooh enable magic mouse and with it on our internet was practically not working.

     

    After some quick googling, it seems changing the your wireless router settings seems to work. Cisco suggest channels 1,6,11 or three steps in either direction from your current settings. And VOILA we have the internets.

     

    Some other solutions suggested moving the router away from the conflicting devices. That didn't work in our case, but we have a pretty small apartment space.

     

    Good luck.

     

    A

  • Dartiesdad Level 4 Level 4 (1,095 points)
    Currently Being Moderated
    Jan 11, 2013 11:58 AM (in response to jminhudson)

    Jim

     

    Thanks very much, I implemented your suggestion.. I don't think I've ever had problems but I liked your explanation and directions.

     

    Cheers

  • logib Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 4:00 AM (in response to jminhudson)

    Seems to do the trick, will test for a few days, cheers!

  • logib Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2013 1:56 AM (in response to logib)

    Didint work, problem came back Managed to get an Official Apple USB Ethernet Adapter for £10, resolves my problem for now, but would prefer Apple to sort issue soon!

  • sbaker@osd Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2013 3:28 PM (in response to CarlosRG)

    I work in the IT department of a school district, and this year we have purchased about 300 macbook airs.  We sent a few COWs of them (Cart on Wheels, ~30 machines per cart) out earlier this school year with no issues.

     

    We've begun replacing aging staff laptops at our two largest highschools; one school is split between Mac and PC, the other is almost entirely Mac.  We did the first school, the Mac/PC split, with about 35 airs.  No problems.

     

    This last week we went to the almost all Mac school, with ~80 airs, and network connectivity steadily tanked the more airs we installed.  We were able to determine there was a large amount of intermittent packet loss at the 2.4 ghz band, but no issues at all on the 5 ghz band.  This was effecting PCs and Macs, including older Macbooks (not airs, circa 2007-2008).  The problems died down once students and teachers left the school for the day.

     

    We could think of nothing at all different from the rest of the school year, save the installation of a bunch of airs.  After reading this thread, I've used Workgroup Manager to disable Bluetooth on all of the staff airs we installed.  I'll know if this worked come Monday, and I'll respond in this thread with the results. 

  • haida12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 8:38 AM (in response to CarlosRG)

    I've had the same connections issues on my macbook air, I found the solution on another post and thought I would share on this post. 

     

    The problem apparently is when a system is upgraded ie. Lion to Mountain Lion, something from the old system preferences messes up the new system preferences, specifically network settings.

     

    So the solution what worked for me is to naviagate to:

     

    Library/Preferences/System Configuration

     

    Once you find the system configuration folder delete it, wala your bluetooth and wifi will work again!

  • albertboa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2013 8:23 AM (in response to CarlosRG)

    Same problem here with the new MBA 13' (i5/8/256).

     

    Has anybody exchanged the unit for a new one to see if these bluetooth + wifi conflicts are still there? I am seriously considering the option...

  • sbaker@osd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2013 8:34 AM (in response to albertboa)

    Disabling Bluetooth did nothing for us.  We are going to try out the suggestion from Haida12, but currently teachers are on summer break so they check their laptops out during the summer.  Additionally, two things have come up.  A recent Apple patch specifically deals with wifi issues, which might resolve this.  Also, our wireless manufacturuer, Aruba, came out with an update to their controller that includes better support for Macbook Airs.

     

    I will come back to this post later this fall when things have settled down and we've had a chance to evaluate things, and let you all know if we had any luck.  We've got another 300-400 macbook airs to order and ship out to staff before December so hopefully we are able to get this resolved!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.