Previous 1 6 7 8 9 10 Next 141 Replies Latest reply: Dec 24, 2015 5:37 PM by Bitdust Go to original post
  • Bleary84 Level 1 Level 1

    Hi everyone,


    I had the same problem - no green light, nothing working, new batteries don't work - and tried the suggestions above, including the CTRL+COMMAND+OPTION+POWER, cleaning inside the battery cartridge, and trying different batteries.


    Now the "Bluetooth Setup Assistant" has appeared on my screen and the computer is trying to pair with my mouse (which is now finally flashing the little green light!) but the computer is saying "The computer failed to pair with that mouse."  Unless I missed it, I don't think anyone above has experienced this. Anyone out there know why this is happening??? Driving me insane...


    Thanks in advance for the help!

  • Bleary84 Level 1 Level 1

    *I meant SHIFT+CTRL+OPTION+POWER BUTTON. Sorry. Long morning...

  • daleuark Level 1 Level 1

    Just passing this one along -- none of the hoo-haw in all the previous pages worked - but this did it.  - dm


    "Recently I was affected by a pretty annoying phenomena of my Apple bluetooth mouse. The mouse could only be used to click but the cursor did not move. Various times I disabled the mouse and/or the bluetooth module but that had no effect. Finally I got the solution from this blog. The battery connectors did oxidyze and one simply needs to wipe the clear finish (slight build up) from the metal pads. Et voilá the mouse will come back to live again..."

  • somaskanda Level 1 Level 1

    Yes! cleaining the terminal of battery chamber and control + Option+ Command then power on your mouse

  • yukii_she Level 1 Level 1

    I discovered a tips for apple mous without indicator light.


    After installed 2 x AA batteries, use your thumbnail and push the " - " side / bottom of the battery onto top for a few times, make sure it is turned on. It would bring it back to life.

  • msigler Level 1 Level 1

    It worked to me. Thank you very much

  • Sergio B Netto Level 1 Level 1
    Mac OS X

    Apple should take care to solve the problems with this mouse. How canwe deal with a peripheral that need cheats to work? I gave up. I went back to using the wired mouse. I can not believe!

  • msigler Level 1 Level 1

    Just to let you know, actually what worked to me was this:




    Re: Is my Magic Mouse Dead?

    24-mar-2011 15:47 (in response to Sportwart)

    Try cleaning the battery contacts.
    This just happened to me.
    When I took the batteries out there was a very thin film of oxidation covering the battery contacts. I scraped it off gently with a scalpel blade, and now everything works just fine.
    Pretty simple but I never would have realized...


  • Applelove14 Level 1 Level 1

    This is true. Same sequence of events just happened. Battaries leaked, cleaned and replaced with Duracell, did not work, was about to head to the apple store for a new one when I thought to check this forum.  I tried Energizer as a last ditch try, works perfectly. Thank you for the advice.

  • Mossyo Level 1 Level 1

    This solved my problem. Legend. There was an oxidised buildup on the mettalic bits that connect to batteries. Thanks.

  • Sergio B Netto Level 1 Level 1
    Mac OS X

    ...and the worst problem is that with Mavericks the battery lasts half the time it lasted with earlier systems. So I went back to my wired mouse.

  • seemebefree Level 1 Level 1

    Thanks Dave Lord -- back to working! Phew!

  • Mofowax Level 1 Level 1

    You'll never believe this!


    I've tried new batteries, old batteries, rechargeables, a folded paper wedge shoved between the batteries, cleaning the contact points... everything.


    I noticed some batteries worked and some didn't. It all comes down to the depth of the positive contact 'nipple' (for want of a better word) on the battery. Energizer, Panasonic and Ikea all work fine but Duracell won't and it's down to 0.5mm difference in depth.


    Take a look at the positive contact in the mouse itself and you'll notice the metal contact is recessed behind plastic — if the positive 'nipple' on the battery isn't long enough it won't make contact with the mouse. Hence the Energizer's work Applelove14.

  • captian_potato Level 1 Level 1

    Tried everything that people have posted here , had no luck ..... sooo  got a hair dyer and warmed up the mouse for 30 seconds and presto, instant working mouse.  just flipped the mouse on its metal belly, bit of heat where the batteries sit and within seconds, i got the green light back on.  ( just don't hold the hair dyer too close, you don't want to fry anything!! )
    haha household fixes are the best!

  • Mr Pixel Level 2 Level 2

    Your post really saved me. Thank you so very much for sharing it with me.

Previous 1 6 7 8 9 10 Next