Previous 1 2 3 Next 36 Replies Latest reply: Apr 27, 2013 8:12 PM by LoveVigilante
Level 6 (11,040 points)
Anyone having issues with Lexmark printers that stops working after the recent driver update. I have multi function X6570 that stopped accepting wireless printing from my macbook.

Thank you,

Macbook Aluuminum, Mac OS X (10.6.6)
  • Beergander Level 1 (0 points)

    I've got the same issue, the printer just stopped working, (Lexmark X7675). Tried to install latest Mac drivers from Lexmark UK but just keep getting error message *+usr/libexec/cups/backend/usfailed error+* message in the print queue.

    I've tried uninstalling and reinstalling drivers to no effect.

    Someone please help as I need my printer back!!

  • Trifster Level 1 (50 points)

    I have the same issue here after 2.4 update. my X4850 stopping printing on both my and my wife's macbook. my windows computers can print fine to it still. I've tried to install the 2.3.1 update i found on the net, reinstalling via Lexmark web installer all to no avail. i haven't had any installer errors but all i get is communication's failed after it tries to print. Lexmark 2.4 broke something and reinstalling the old or newest drivers from lexmark's website have not helped! I did do a permissions repair and rebooted, that did not help either...

    Help, anyone??
  • Trifster Level 1 (50 points)
    Good Afternoon,

    I was just able to fix my Lexmark All-in-one X4850 after the Apple/OSX 10.6.6 Software update Lexmark Driver Update 2.4 broke my previously installed and working driver. Here are the steps that i followed that did work.

    1. Downloaded and installed Lexmark Printer update 2.4 from Apple here:

    2. Open Print & Fax.

    3. On the left side inside white box with printer(s) listed, right click and choose Reset printing system. All printers will disappear.

    4. In finder, navigate to /Library/Printers and move the Lexmark folder/items to trash.

    5. In finder, navigate to /Library/Printers/PPDs/Contents/Resources and move all Lexmark labeled files and folders to trash.

    6. Visit and download the latest driver installer for your printer. In my case I was the image 4800 Series Web Install.

    7. After reinstall of drivers, Lexmark assistant found wireless printer and complete install with no errors. Printing of test page successful.

    8. Separate test printing a PDF doc also successful again! YAY!!

    Good luck!
  • Beergander Level 1 (0 points)
    I tried this and although it appears to look promising as soon as I submit a print the print queue quickly goes to 'Printer Paused', if I try and resume it I quickly get the 'usr/libexec/cups/backend/usbfailed message'.

    Any other ideas? Can I restore my system back to the stage before the update that screwed things up?

    Thanks for any advice
  • Trifster Level 1 (50 points)
    I'm printing wireless on both my computers. Are you connected via USB? The only other thing I did before my steps above was a full permissions repair via disk utility. That may help?
  • Level 6 (11,040 points)
    Hello Trifster,

    My fix was simply going back and deleting my X6570 printer from my system, then reinstalled the software. I then went in and deleted my network setting on the printer and then setting them up again. This was not necessarily the optimal fix as deleting the printer from my settings also meant I deleted the recent printer driver update sent out which is now back and now listed under software update. I don't think I will be using this update anytime soon. My printer was working like a charm prior. In a nutshell this problem seems to be a networking wireless issue.
  • Beergander Level 1 (0 points)
    Ended up contacting Lexmark support in the Phillipines who were very good. We eventually got the printer working via ethernet connection rather than USB, maybe the USB port's U/S? Anyway back printing so I'm happy.
  • chikosneff Level 1 (0 points)
    I've done this on my x4550 and now I can print using USB but can't do it over wifi: at first I get a fake print job called "supplies levels", after I erase it I get the error message "unable to read cups raster data"
    I really need wifi printing....any help is much appreciated.
  • sgoldswo Level 1 (0 points)
    This is similar to the fix another poster mentions above, but will leave you with the latest working Lexmark driver rather than the version on the Lexmark website (which will likely be older than the version you receive through software update).

    My only solution to this problem on my Lexmark x9575 (connected to my network by ethernet) was to revert to the 2.3.1 Lexmark Drivers and ignore the 2.4 update which breaks printing on all of my Macs. This involves:

    1) uninstalling the drivers from the link in the folder within Applications or on your desktop (mine is called Lexmark 9500 Series and it lives on my desktop);

    2) Go into the Library folder on your main hard drive (NOT within your user folder, the hard drive is usually listed in the finder as Macintosh HD unless you have renamed it) and delete InstalledPrinters.plist and the Lexmark folder (restart after uninstalling the driver in step 1 if it won't let you do this);

    3) Download the latest drivers for your model on the Lexmark website and install them;

    4) Search on the internet for 2.3.1 Lexmark Printer Driver. At the time of posting you can find it here:

    5) Check you have version 2.3.1 - it should be called LexmarkPrinterDrivers2.3.1.dmg and install it.

    6) go to software update, which will prompt you to install the 2.4 drivers and set software update to ignore the update (this can be done by clicking on the name of the update to highlight it, then going to the Update menu and selecting Ignore Update).
  • Level 6 (11,040 points)
    Thanks sgoldswo!

    I will give this a try. Basically, it appears that I reinstall the old or current printer drivers after deleting the new driver update and then setting the system to ignore the update.
  • CTK sydney Level 1 (0 points)
    Thanks sgoldswo. This worked for me, but in addition to this i had to reset all network settings on the printer itself.
  • sgoldswo Level 1 (0 points)
    That's correct. The steps outlined in my original post eliminate the broken version 2.4 drivers, reinstall the basic Lexmark drivers, then update them to version 2.3.1 (the latest working version), then block the broken version 2.4 drivers.

    Despite the fact I actually quite like my x9575 from a mechanical/end product point of view I have never known a company break their drivers quite so much as Lexmark.
  • sgoldswo Level 1 (0 points)
    Fair enough - I think I am lucky in that this seems to happen automatically when I reinstall the drivers for my x9575. I am glad the solution worked in general for you.

    It's probably worth noting generally that more often than not problems with network printing on lexmark printers can often be solved by reseting all network settings and then reinstalling the software.

    It isn't really Lexmark's fault (on the basis of my fault source checking), but when I used my printer wirelessly it would suffer a connection problem to my router (then a BT HomeHub 2.0) on a regular basis. From a networking perspective, it has worked flawlessly since being connected by Ethernet cable.
  • FXTrader Level 1 (0 points)

    Thanks sgoldswo,


    I have a X7675 and your fix worked well and was easy to follow. However, I loaded the original driver from the disk that came with the printer. I have only had the IMAC for two weeks (previous MS slugger) can't believe I waited so long to see the light.

Previous 1 2 3 Next