12 Replies Latest reply: Jul 8, 2014 8:15 PM by VoilaMagic
brandon handford Level 1 (0 points)
Macbook not booting properly, install disk nothing, press option on start up goes directly to grey screen with lock and login bar, tried all passwords and ...Nothing
cannot safe boot. cannot reset PRAM. regular boot startup displays apple icon and spinning wheel.. Have no idea what may have caused issue (not the last one to use it) In other words HELP!

MACBOOK, Mac OS X (10.6.6)
  • Kappy Level 10 (265,914 points)
    Sounds like someone set a Firmware Password or there is a hardware issue.

    Booting From An OS X Installer Disc

    1. Insert OS X Installer Disc into the optical drive.
    2. Restart the computer.
    3. Immediately after the chime press and hold down the "C" key.
    4. Release the key when the spinning gear below the dark gray Apple logo appears.
    5. Wait for installer to finish loading.

    What happens, precisely?
  • brandon handford Level 1 (0 points)
    Chime muted, restarted using I stall DVD, wheel continues to spin.
  • Kappy Level 10 (265,914 points)
    OK. Try resetting the PRAM and resetting the SMC. Try again with install DVD. Be sure to wait several minutes as the installer is slow to load from optical media.
  • brandon handford Level 1 (0 points)
    would not reset, goes directly to apple icon and spinning wheel.... is there an internal reset?
  • Kappy Level 10 (265,914 points)
    The previous methods do all the resetting you can do. Since they occur before anything else there should be nothing but gray screen during the PRAM reset. Be sure you've followed the instructions properly.

    Otherwise I can only suggest you take it in for repair.
  • brandon handford Level 1 (0 points)
    Thank you Kappy, i apologize for sounding short... i appreciate your time and insight. I will try these again and keep my fingers crossed.... ill keep you up to date...
  • kgresssm Level 1 (0 points)

    Brandon.....   Please tell me you found an easy fix for this?????


    I have the exact same issue.


    Grey screen with big lock.  Only there when i try to reinstall Lion...


    Keith Morgan


  • aduffbrew Level 1 (70 points)


    If it looks like this, Kappy is right and your firmware is locked.  You need to use the password used when configuring this feature in Open Firmware.


    To force remove password protection, change the amount of RAM by adding or removing DIMMs then reset the PRAM three times.

  • tsoneal26 Level 1 (0 points)

    I have tried to reset my pram by pressing and holding command+option+p+r and by removing one of my memory sticks and same combo and this is the only screen I get.

  • Kathryne_B [nom de plume] Level 1 (125 points)

    This is for those of you who've tried to find out how to do away with the gray padlock of death.  You have to install the original OS disc that came with your computer. Insert it and go to Mac installer, under Disk Utilities to the drop down menu. Then go to about the fourth one down marked Firmware Password. When you do, it just turn off the password portion of it and you won't need to enter any password the next time you install or reboot from your DVD/CD disc. But just be aware that in doing this, anyone can login into your OS. Hope it helps.  ~Kathryne

  • VoilaMagic Level 1 (0 points)



    This is the same screen that I keep seeing. I've owned this white iMac since 2008 (late 2006 model) and I updated it last year, to Lion, then moved to my new house and couldn't log in. I placed it aside and now I really need data off of it. I turn it on, regardless of what I do I'll see the login screen with my picture, no menus and the password won't take. I've been able to get it to the grey lock screen and tried the password (plus some) and nothing. I know the computer works fine, maybe I've tried the password too many times. I tried the Firmware pw removal from apple documents without success, memory as well. Any suggestions without lugging it to the apple store, please do assist. I swear I thought I would have been able to reset the pw with my apple id but no, it won't seem to have the option. scratching my head often. I tried target disk mode, lock screen.


    Also, I have all of the manuals, books, cds, etcetera from when I purchased, I've tried all of the original install disks and tried Lion Combo, I ordered the Lion CD (AGAIN PURCHASE grr) and am waiting for it to arrive however I'm quite certain it won't let me by the lock screen- there is no documentation about this screen online except for here, I've searched all day and found this thread- Thanks !

  • VoilaMagic Level 1 (0 points)

    I was able to do this ! YAY ! I believe I did something incorrectly on the first go with the PRAM reset. I was able to enter Single User Mode with original disk. Yay ! It was indeed the firmware password! Thank you Kappy !


    Following Kappy's steps, I did the following;


    If you're running OS 9, you may need another mac (though i suspect a PC with firewire and a HFS driver would do) and a firewire cable. You will need to delete preferences pertaining to keychain access and any keychains in the preferences folder in the system holder The first imacs ran this so its plausible

    If you're running OS X on the imac

    Single user mode would do the trick unless there's open firmware password protection in place

    To go into single user mode

    1. Press the power button to start the computer.
    2. Immediately press and hold the Command (Apple) key and one of the following: the "s" key for single-user mode. (Command-S) This should boot into a white screen, and iirc throw you into a command prompt

    These instructions should work for older versions such as 10.4. Khafshoh S' version works for newer systems 10.5 and better - 10.7 also has yet another option for resetting the password involving the 'resetpassword' command in lion recovery.

    Instructions for changing the password are based off of Apple's documentation though the documentation goes very in-depth.

    You would then mount the file system as writable with

    mount -uw /

    then find out what the accounts on the system are with

    ls /Users/

    then change their passwords with

    passwd username

    reboot and get back into graphical mode with


    Then check the accounts to work out which one is the admin account.