Previous 1 2 Next 18 Replies Latest reply: Aug 26, 2014 12:54 PM by RPTB1
Daniel_Italia Level 1 (0 points)
I have this problem.
My SD Card Slots it's in READ ONLY MODE.
I already use the SD cards in this computer without a problem, they we're always read/write. Not anymore since a month. (I think from the last software update, but I'm not sure of this).

Someday, without notice, all these cards are read only on my macbook pro.

I don't have this problem with my G5. I can read/write on these SD cards. Of course, all of them are unblocked.

I tried in several formats (formatting the cards with my G5). Same results.
My Macbook Pro 13 (last edition so far, I brought it on November 2010).

I read is probably A Snow Leopard 10.6.6 problem.
So I reinstalled the system without updating the computer, but the problem is the same.


Message was edited by: Daniel_Italia

MacBook Pro 13, Mac OS X (10.6.6)
  • Michael Bradshaw Level 5 (4,135 points)
    It's likely a hardware issue and not a software issue.

    First steps are reboot, reset SMC, reset NVRAM.
    Then perhaps try re-applying the 10.6.6 combo update.

    If you have a Apple Store close by - the genius bar would be a great place to get it tested / possbly repaired if it's the slot that has failed.

    Have you tried any/all of these?
  • Daniel_Italia Level 1 (0 points)
    MAC Combo 10.6.6 updated.
    PRAM & NVRAM reset.

    Same issue.

    I didn't try with SMC resetting.
    Is it safe?, I didn't do it because I'm working and I need the computer by the moment.

    I forgot to mention. This computer has a new logic board. I don't think in a HW problem. The Apple Service confirm this (according to them ).
  • Daniel_Italia Level 1 (0 points)
    "If it is a HW problem you could not read from it" the phrase from Apple Center.
  • skygremlin Level 1 (10 points)
    I have the same problem. I was able to format my SD card a couple times the other night. Now, no matter what I do it's set at read only when it's inserted. I have 2 different cards I'm using with the same issue with both.

    One (the card I was using in the description above) is a Kingston 16Gig SDHC. The other one is a 8Gig SanDisk SDHC. Both have the toggle for lock on them. Regardless of how that's set it's read only.

    I have an appointment at the Genius bar tomorrow. So they can look at it..
  • Daniel_Italia Level 1 (0 points)
    Can you please ask about the reseting SMC?.
    BTW. I can read and write on my power PC without a problem. Obviously I use a card reader. No problems with that.
    I already format an SD with the G5 as Mac Os and nothing. The Macbook Pro still read only on SD cards and I tried with normal ones and SDHC. Sandisk, Kingston, ecc.
  • skygremlin Level 1 (10 points)
    Yeah I have a usb card reader too and both cards are read / write when plugged into that.. And work fine.
  • skygremlin Level 1 (10 points)
    Went to the Apple store today. I opened up my MBP the SD card worked perfect, no issues.. I couldn't believe it. But after we (me and the tech) removed the card a few times / formated it. It stopped working and started setting it for read only, and we couldn't get it back to read / write. IE same issue as we were posting.

    The tech spoke to his lead technician, which both said they have never heard of this, but decided that the motherboard is defective and needs to be replaced. So I left it there for them to replace it. Price, if out of warrenty, was 650.00. Can't remember if that included labor. I have AppleCare (which they didn't have on record) so free for me. Glad I paid the 350 when I bought the laptop.

    Overall I waited an extra 15 minutes before being seen. A little annoyed about that. But the tech was very nice, professional, and helpful. I did ask about the SMC, but we were talking about a couple of things and that kind of got lost in the shuffle and I completely forgot.... Sorry I had "I am Number 4" on my mind as we were planning on seeing that next.

    Will update as soon as I get it back

    Message was edited by: skygremlin
  • Daniel_Italia Level 1 (0 points)
    It seems very very strange and a loot "windows pc style"... I'm still thinking is a firmware/software problem. But if you say that Apple Center changes the motherboard this will tell us (a lot of people) that there is a problem on a lot of Logic Boards.
    I will return to my apple center to change (for the second time) the logic board because a SD card reader.
  • skygremlin Level 1 (10 points)
    Picked up my MBP last weekend - tested it before I left with 2 different cards (My cards that were not working before) had no issues. I just coped a roughly 4.5 Gig VM to the SD card and am using it as a VM with no issues..

    Hope that helps.
  • Daniel_Italia Level 1 (0 points)
    Well. It seems a Logic Board problem. I went to the Apple Service and they will change the Logic Board (FOR THE SECOND TIME) because this problem. I repeat, Apple now is more like PC's. GRRRR... Anyway. The technician an me thinks that this is a firmware problem, anyway, my MBP is on guarantee, so let's change this logic board for free.
  • Daniel_Italia Level 1 (0 points)
    Well. I spoke with Apple Service and they will change the Logic Board (for the second time). I'm still thinking is a firmware problem. Someone on Apple made a mistake IMHO. But I'm not a technician, so... let's change this logic for free, my MBP is still on warranty. Let's make spend money to them.

    For everyone that read this thread... don't try anything like resetting NVRAM, PRAM, SMC or tricks like "insert the card in this way"... go an Apple Services, and change the logic board (obviously if you are on warranty time).
  • Ravichri Level 1 (0 points)
    Today I had this same issue with two different SD sandisk SD cards.

    This worked for me: Blow air into the slot. I used an air blower for camera lenses.

    Maybe its just some dust blocking the lock detection? I'm glad I don't need to have my mobo replaced ...
  • Daniel_Italia Level 1 (0 points)

    Today, an Apple Service change the Logic Board because this SD card slot problem.

    It seems to be the only way, according them. Of course, if was anly the dust... well, it is not my problem They change it for free because the warranty.

  • VaughnSC Level 1 (0 points)

    Blow in the slot FTW. Worked for me.

Previous 1 2 Next