Skip navigation

MacBook trackpad won't 'click'

25506 Views 18 Replies Latest reply: Apr 9, 2014 9:36 PM by superrrabbit RSS
1 2 Previous Next
OceanTing Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 8, 2011 8:56 PM
Hey everyone,

I have a early white MacBook whose battery's status is "Replace Now" and i can move my cursor around, but it wont perform a 'click' at all. However, I connected my magic mouse and it was able to also move the cursor, but it still did not click. I reset my PRAM to see if that would do it any good. So upon restarting I didn't touch my trackpad and only used my mouse and I had my 'click' action back...problem solved right? NOPE!...the minute I touched the trackpad I lost the 'click' action. Can anyone tell me what is going on and is there anyway I can solve this problem without taking it to a store?

I also have the same model MacBook in black, whose battery won't charge at all, yet I still can click with my trackpad. Does this rule out the possibility of it being a battery problem?

Cheers.
MacBook, Mac OS X (10.6.6)
  • Alan Bishop2 Level 2 Level 2 (380 points)
    Currently Being Moderated
    Mar 8, 2011 10:43 PM (in response to OceanTing)
    Hi OceanTing,

    Welcome to Apple discussions.

    Take the battery out and run it on power. If the track pad works then your battery has probably become distorted in shape and is pushing up on the bottom of the track pad.

    Good luck,

    Alan
    Mid 2007 Macbook 2.16 ghz. Intel core 2 duo. 2 gig. RAM. 2 G4 ibooks, Mac OS X (10.4.11), Running Panther and Tiger on the three. Going to get Snow Leopard soon.
  • JoeyR Level 6 Level 6 (8,275 points)
    Currently Being Moderated
    Mar 9, 2011 5:16 AM (in response to OceanTing)
    As Alan indicated, try removing your battery and see if your button works then. While not common... batteries expanding as Alan had mentioned are not unheard of... especially with older batteries. As you have indicated your system says "replace now" for the battery, that would be an indication that your battery had failed. When running the machine with the battery removed, the system automatically throttles back performance significantly (nearly a third). So you'll want to replace that battery if it turns out to be the problem. Of course the battery gives you protection against losing your data during brief power interruptions as well.
    Core Duo BlackBook - SR MBP - 13.3" MB Pro - 2.2GHz 15" SB MB Pro, Mac OS X (10.6.6)
  • wired4use Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 2:43 PM (in response to OceanTing)
    Yesterday, I started experiencing this same problem. Both my MacBook's trackpad and a usb mouse can move around but they can't click. I replaced my laptop's battery several month's ago, so I doubt I would be having the "bulging battery" problem. I have tried rebooting in safe mode, resetting the SMC and resetting the PRAM. Nothing has helped. Needless to say this is extremely frustrating. Is there something else I can do that I haven't tried yet?
    MacBook Intel Core Duo 1.83 GHz, Mac OS X (10.6.6)
  • mkritzer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2011 5:35 AM (in response to wired4use)
    Same thing is now happening to me, wired4use. Were you able to find a solution?
    Macbook
  • mkritzer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2011 3:31 AM (in response to mkritzer)
    I ran the Disk Utility from the OS DVD. There was a missing file that was repaired. All is fine now.
    Macbook
  • mkritzer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2011 4:44 AM (in response to mkritzer)
    Hmm. So it was only a temporary fix. Whenever the laptop hibernates or shuts down, the issue arises again.
    Macbook
  • mkritzer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2011 5:35 PM (in response to mkritzer)
    And we have a solution. After a tech call, I deleted all files in the Preferences folder that had to do with the touchpad and mouse (systempreferences.plist and anything with touchpad.plist and mouse.plist). One of the files got corrupted. Hope this helps.
    Macbook
  • Haribol Level 4 Level 4 (2,455 points)
    Currently Being Moderated
    Mar 25, 2011 3:04 AM (in response to mkritzer)
    Same here. Touchpad dead. And can't start from disc. Have no idea what to do ???
    MacBook 13'' 2.0GHz Intel C2D 2 GB RAM 80GB HD, Mac OS X (10.6.7), iPhone 4,16 Gb
  • Arnie C Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2011 5:36 PM (in response to OceanTing)
    I have a similar problem.
    Macbook white about 1 year old. Up to 3 days ago was working fine. Since then the trackpad or external optical mouse are behaving strangely - the cursors wont respond properly and when it does it seems to have a mind of its own. At times click doesnt work.
    Tried most of the things in the forums (havent tried taking battery out - sounds complicated!).
    But interestingly I have discovered that if I disconnect the charger lead and run on the battery alone it works fine. As soon as I reconnect the charger it misbehaves. The lead is the original Apple one (not a third party one as some discussions have suggested might be the problem).
    Anyone any ideas.
    Thanks
    MacBook, Mac OS X (10.6.7)
  • rollingjonicle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 2, 2011 7:19 AM (in response to Arnie C)

    Hey Arnie

    I stumbled upon your post because i'm experiencing the exact same stuff right now!

    Started two days ago, and my cursor really seems to "have a live of it's own"

    Have you found any solution yet?

    On my computer, the issue sometimes disappears when i tilt my laptop 45 degrees to the right.. strangely..

     

    Any idea?

    Thanks

  • hadjeas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2012 11:42 PM (in response to OceanTing)

    Same me having the same problem, at first I also thought it happen because of battery, but got a new battery and dying to figure out the problem, but nothing positive, can't clck anything, any idea or help..... I'm having MacBook black.

  • PalAstroDaddy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2012 5:08 AM (in response to OceanTing)

    Exact Same Issues for me and FINALLY this week I got it solved.  But you won't believe what it turned out to be.  Embarassingly simple, but in the end the simplest solution is the best solution.

     

    I had a wireless bluetooth magic mouse in the bottom of my computer bag (i carry as a spare) that was turned on and broadcasting a signal that was overriding the touchpad and other mouse that I had at my desk.

     

    I had read these posts and found a bunch of things to try.  At the advice of some of these discussion forum posts I went to the apple store to have them replace the trackpad, then problem was fixed. 

     

    At the apple store, we

    a - updated the PRAM

    b - inspected the battery to see if it was touching the trackpad from underneath.  ruled out as ok

    c - adjusted the tension screw that controls the sensitivity of the trackpad.  did not fix the problem

    d - booted the computer from various known good software configurations using the network boot options and diagnostic tools at the apple store.  Because the mouse click would not work immediately on boot from any configuration, we determined it was likely a hardware problem and decided to replace the touchpad

    e - actually replaced the touchpad, which on my MBP 17" mid 2010 was approx 90 minute service, so i had to leave it overnight for service

     

    When I went to pick up my computer with the new trackpad, the mouse click did not work even though it had been working just fine for the technician moments earlier.  The tech told me to please wait a minute and took my computer back to the workbench.  As he was walking away the message flashed on the screen "Connection Lost" to my magic mouse.  At that point, clicking worked.  He came back out and asked if I had a wireless mouse in my computer bag.  Once I located it and removed it from the bag which was pressing against the touch surface of the mouse, both the trackpad and mouse started to work.

     

    It was a frustrating few days, and embarassingly simple to fix.  In the end, mine was neither a hardware nor a software problem.  I hope that this post now saves someone else the same pain.

  • mathew78 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2012 10:25 AM (in response to PalAstroDaddy)

    Thanks buddy!! This issue was irritating for me for some time, I use old mouse, the magic mouse was on and in my bag all this time..

  • Death21andall Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 24, 2012 9:09 AM (in response to OceanTing)

    Right guys, i really need help because this is bugging me now... I was playing a well known game World Of Warcraft in which my track pad and USB external mouse were working fine... to eventually the right click on the track pad (Double-fingerd touch on track pad) stopped working and the right click on the mouse stopped working... the USB mouse is fine and i have tried the system preferences a couple of times but all is normal.... Now more unusual is that the commands in the game World Of Warcraft and surprisingly other game's which need the right click,... no can be active by using only the left click... the Ctrl+left click still works, but it is an inconvenience to use when doing different things. If anyone would like to help it would be great, the macbook is the standard white and also is a couple of years old, but i got second hand from my brother...

     

     

    Thanks,
    Conor.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.