Previous 1 2 3 4 Next 56 Replies Latest reply: Oct 7, 2011 9:33 AM by gschlact
Dave Z Level 1 Level 1
I just updated to iOS 4.3 (from 4.2.1) on my first generation iPad. I have a Time Capsule running a 2.4 GHz network and a Linksys E2000 setup as a network bridge (DHCP and NAT disabled) running a 5.0 GHz network. I live near a college and need the 5.0 GHz network because there are at least ten 2.4-based networks in the area.

Before the update to iOS 4.3 my iPad was able to connect and use the 5.0 GHz network without issue. Immediately after the update it reports it cannot connect to the network. My wife's iPad, still running 4.2.1, can connect to the 5.0 GHz network without issue. I have removed the WPA2 key and ran the network unsecure for a couple of minutes but that didn't resolve the issue. When I re-enabled WPA2 I also changed the Linksys to use 2.4 GHz instead of 5.0 GHz; the iPad connected immediately. When I changed it back to 5.0 GHz the iPad immediately would no longer connect.

I am quite familiar with networks and, despite having two routers on the same network, they are configured properly and this setup has worked for months. Indeed, it still does work with my iMac and wife's iPad (running 4.2.1).

Is anyone else having difficulty using the 5.0 GHz spectrum after this OS update?

Thanks!

iMac (Late 2009), Core i5 2.66 GHz, 4 GB RAM, Mac OS X (10.6.6), 16 GB iPhone 4, 16 GB iPad (1st Gen.), Apple TV (1st Gen.)
Solved by TallBearNC on Mar 12, 2011 2:14 PM Solved
Issue solved. Apparently iOS 4.3 REQUIRES WMM support to be ENABLED or it will refuse connect to a dedicated N router or it will fall back to G on a mixed mode router. I read the final IEEE 802.11n requirements and it hinted WMM is now mandatory.

WHY apple would force this w/o telling ppl is a mystery. But once I enabled it, all my idevices can now do 2.4 and 5gz N again on iOS 4.3
Reply by TallBearNC on Mar 11, 2011 8:55 AM Helpful
I just talked to apple phone support. They are only just becoming aware of this, and apple will start watching these threads now.

Some ppl don't notice this 4.3 "oops" because their routers run in mixed A/N modes @ 5ghz, and after iOS 4.3 the iPad and atv2 cant do 5ghz N, but will fall back to 5ghz A if the router is in mixed mode. The rep said most ppl with apple routers are probably in mixed mode and they should verify if they truly can or can't to N at 5ghz but putting the apple router into dedicated N only mode. Apple wants to know if this problem is isolated to just non airport routers

If ur stuck with 4.3 on an iPad or ATV or ATV2, and cant do 802.11n @ 5ghz, call apple. The more ppl who call, the faster 4.3.1 gets pushed out with fixes

Message was edited by: TallBearNC
Reply by gschlact on Oct 7, 2011 9:33 AM Helpful

Of course I found this thread AFTER I found the solution after 3 hours of thread reading and hunting/googling.

I am simply responding to enter some keywords for google to find if others like me have the problem.

 

Problem: 

Wireless 802.11n or specifically N Only mode (key here is N only, otherwise device can connect in alternative mode either 2.4ghz or 5ghz - ipad / ipod / appletv / apple tv 2 -  Unable to Connect to Network"  ssid

 

APPLE Solution Link: http://support.apple.com/kb/TS3727

In a nutshell, on router, must turn ON or ENABLE WMM to allow the apple devices to use the  wireless N protocol and connect to the router.

 

Devices / firmware  -

DD-WRT, Tomato, Cisco, Linksys e3000,  610 , Belkin

 

I hope some of this help others find the solution to this in this thread (i realize it is posted already, but I couldn't find it via google and the key words i was using).

 

Other items -

I had tried all the other solutions of WEP / WPA / WPA2 / AES / TKIP etc (TKIP doesn't work with N mode, only with Mixed at which point it won't choose N mode).  Enableing WMM fixed it for me once I did the next step.

 

TIP -

always remember to FORGET the network AND then Settings -> General -> Reset -> Reset Network settings in the Apple devices after you make the change to your router / network wireless device.

 

Good luck,

Guy

gschlact

All replies

Previous 1 2 3 4 Next