Previous 1 5 6 7 8 9 Next 123 Replies Latest reply: Aug 4, 2012 10:02 AM by sguilliard Go to original post
  • Conradical07 Level 1 Level 1 (0 points)

    Just received my iPad2 this morning, you saved me some hours tonight.  PPTP wouldn't working connecting to OpenSUSE 10.? box at the office (I control it).  I can confirm that "Adding either 'nopcomp', 'noaccomp' or both to /etc/ppp/options.pptpd results in the connections working every time." does work.

     

    This is not just limited to DD-WRT.

     

    OpenSUSE 10.?

    pptpd - v1.3.4

    pppd - v2.4.5

     

    Ugh, what has become of me - a Linux geek on an Apple forum?!  Now I have to actually go and pay for some apps.  The pain....

     

    Thanks,

     

    Conrad

  • alainexpat Level 1 Level 1 (0 points)

    This is really lame.  My iPhone has worked with my dd-wrt VPN for at least a year with absolutely no problems.  Then, Apple releases iOS 4.3x.  Now, it does not work.  And, since I have had the device for over a year, they want me to pay for support.  Wow!  What a great business plan.  All they have to do is simply disable some feature in iOS with every release and then they can charge everyone to to tell them, individually, how to fix it.  Thus, their revenues grow with every new release and their tech staff also grows.  Unfortunately, it only works until some other company can provide a similar product with honest support.  Then, the whole thing comes down like a Bernie Madoff scheme.  Quick, someone check the visitor list at Bernie's prison to see if Steve has been by for a visit.

  • Kevin Kondo Level 1 Level 1 (0 points)

    Can we please return to some clarity of thought and civility.  Apparently there is a disconnect in with constitutes "cause and effect."  Just because an iOS patch resulted in some tunneling issues with a handful of routers, doesn't automatically mean that the problem is with the patch.  Isn't it possible that some of the routers are not engineered to spec?  Is it really Apple's burden to test each patch with each manufacturer's router (or mouse or monitor or hard drive or driver)?  The computer world runs on open standards and open systems - everyone must trust everyone else to follow the rules.  USB, Linux, HTML, WiFi are all prime examples.  Apple may still be culpable, but it does appear to be a foregone conclusion.

     

    The 'nopcomp' and 'noaccomp' are commands to turn off compression, BTW.  Thanks Conradical.

  • alainexpat Level 1 Level 1 (0 points)

    Perhaps I should elaborate.  I use a total of 4 devices with my VPN.  Windows XP, Windows 7, Mac OS and an iPhone.  All four of these devices have connected successfully to the same dd-wrt router via VPN for over a year.  I have changed absolutely nothing at either end.  With the advent of iOS 4.3, the iPhone quit.  All of the others continue to work normally.  I agree, Apple has no responsibility to test "new" features with all available combinations.  I do think they have a responsiblity to continue to support the features that were available prior to an "upgrade".

     

    I would be happy if Apple would simply provide a way for me to return to 4.2 iOS.  That would solve the problem for everyone.

     

    And, finally, my comments regarding Madoff were intended to add a little levity to this discussion.  Nothing else.

  • Asatoran Level 4 Level 4 (2,535 points)

    FYI: iOS4.3.3 on iPad1 working for me.

    • PPTP to Linksys RV042 (firmware 1.3.12.19-tm)
    • L2TP to Windows 2003 server
    • IPSec to Cisco ASA5510 (COS 8.3)

    Basically same equipment that I had previously working on iOS3 & 4.2.x & 4.3.1 & 4.3.2.

     

    Conradical07 wrote:

     

    ...PPTP wouldn't working connecting to OpenSUSE 10.? box at the office (I control it)...

    This is not just limited to DD-WRT.

    ...

     

    @Conradical: isn't DD-WRT based on Linux?  And DD-WRT's webpage says the name DD-WRT is the code for Dresden, Germany.  Suse Linux came from Germany so perhaps the same code or programmer(s) or programmer based one on the other?  I'm just thinking out loud, but the coincidence caught my eye.

     

    @Kevin Kondo: Thank you for being another calm voice in the storm.   I've been following the thread but have to bite my tongue for all the "me too" posts without details.  And sadly for the issue, all I can report is that for all iOS versions so far, the non-Linux based VPN endpoints I'm using have worked.

  • alainexpat Level 1 Level 1 (0 points)

    Does anyone know of a website that has older versions of iOS?  For example, the 4.3 release of iOS for the iPhone has almost rendered my phone unusable due to problems with VPN.  If I had known, I would have never installed the update.  I would be very happy to simply retreat to any version of 4.2 iOS, but I have no idea where to get it.  Help!

  • sid2 Level 1 Level 1 (0 points)

    Hello Conradical07..need your help

    Im a newbie for DDWRT and IPAD 2 Firmware 4.3.2..can u please correct my original script of WRT54GL DDWRT so that I can add echo 'nopcomp' and 'noaccomp'  or echo'default-asyncmap'>> as per your details and Syrex and Cosworth ..

    I hv tried to add those words here and there but still not luck my Ipad 2 does not able to connet using PPTP to my DDWRT router.( Ihv got this original script from DDWRT forums)

     

    Original script :

    sed -i -e 's/mppe.*/mppe required,stateless/' /tmp/pptpd/options.pptpd

    Appreciate any help given to solve this PPTP problems...thanks so much Conradical07

     

    Sorry If I made any mistake,  because this is my first time writing in the apple forums... my email address xpand168@yahoo.com

     

    brgds Sid2

  • tgfromgz Level 1 Level 1 (0 points)

    same prolem here. IPAD2 4.3.3, vpn dosn't work.  same settings work well  in my laptop and smartphone.

  • sid2 Level 1 Level 1 (0 points)

    Hello Everyone,Im a newbie on this forums, I would like to share my experince in solving my Ipad2 Ver 4.3.2 VPN PPTP connection problems to my dd-wrt router.

    Many thank for the following people and dd-wrt forums/ dd-wrt wiki: Syrex, Cosworth, and Conradical07 ( Conradical07 thanks so much for the link ) and dd-WRT Forums discussion / dd-wrt wiki.

     

    Problems that I encountered is a PPTP connection to my dd-wrt Router. ( My dd-wrt PPTP is connecting perfectly everytime with my iphone3gs Ver 4.2.1) ,but problems occuring when I try to connect my Ipad2 ver 4.3.2 to my dd-wrt router.

     

    Solution : Actual step by step fix is shown in detail through the following link below  :

             

    I have these script from  the dd-wrt forums
      http://www.dd-wrt.com/wiki/index.php/PPTP_Server_Configuration#iOS_4.3

     

     

    #!/bin/sh

     

    echo "nopcomp" >> /tmp/pptpd/options.pptpd

     

    echo "noaccomp" >> /tmp/pptpd/options.pptpd

     

    kill `ps | grep pptp | cut -d ' ' -f 1`

     

    pptpd -c /tmp/pptpd/pptpd.conf -o /tmp/pptpd/options.pptpd

     

     

    sed -i -e 's/mppe .*/mppe required,stateless/' /tmp/pptpd/options.pptpd

    Steps on putting these script to the dd-wrt router :

    1.login to dd-wrt

    2.Administration

    3.Commands

    4.Paste the Script above to the Command Shell

    5.Run command

    6.Save Startup

     

    The above script is include with a force encription for PPTP connection .

                

    I hope my experience will help others with the same Ipad2 problems.

     

    cheers

  • nycphone Level 1 Level 1 (0 points)

    I hope this was fixed in iOS 5!

  • jeremy207 Level 1 Level 1 (0 points)

    I tried pretty much all suggestions in this thread with no luck. But then I noticed my Windows XP PPTP client connected to DD-WRT was using MTU 1400, and my IPad2 was using 1450. I changed the following in my options.pptpd:

     

    mtu 1400

    mru 1400

     

    and the IPad2 can now successful connect and pass traffic through DD-WRT.

  • marshalfrombeverly hills Level 1 Level 1 (0 points)

    It is seriously frustrating - the updates are surposed to provide solutions... though thanks for the solutions!

  • alainexpat Level 1 Level 1 (0 points)

    Lucky you.  The iPad 2 obviously has a complete set of options.  Too bad the iPhone does not.  We will have to wait for Apple to adjust the settings that they changed for 4.3.  I can just imagine a couple of guys somewhere in the bowels of Apple saying "I wonder what these parameters do?"

  • jeremy207 Level 1 Level 1 (0 points)

    alainexpat wrote:

     

    Lucky you.  The iPad 2 obviously has a complete set of options.  Too bad the iPhone does not.  We will have to wait for Apple to adjust the settings that they changed for 4.3.  I can just imagine a couple of guys somewhere in the bowels of Apple saying "I wonder what these parameters do?"

    Sorry for not being more specific. The following changes were in the options.pptpd on my DD-WRT router.

     

    mtu 1400

    mru 1400

     

    I made no changes to the IPad2 config.

  • andrewfromwesterville Level 1 Level 1 (0 points)

    I was having trouble with this recently and just now got it working.

     

    My iPhone was running 4.3.3 (whatever it was just prior to the latest release which is, I think, 4.3.4).  I set up a vpn on my synology disk station (pptp) and set up the pptp vpn setting on the iphone.  I could not connect.  Today, I noticed that my wife's phone was running the latest (4.3.4?) ios and when I set up her pptp connection it worked.  So I updated my phone to the latest and tried to connect again with no luck.  I finally deleted the vpn on the phone and added a new one with the same settings and now it is connecting.

     

    Was it the os?  Maybe.  Or perhaps it was deleting it and adding the settings again that did the trick.  Anyway, I hope that this helps someone.

     

    Good luck!

Previous 1 5 6 7 8 9 Next