Previous 1 2 3 4 Next 54 Replies Latest reply: May 15, 2014 3:06 PM by Supernovae
yeahyeahright Level 1 (0 points)
Hi Guys,

I recent upgraded my MBP from the 2006 15inch model to the latest 2011 15inch higher end series unibody, and I'm experiencing weird problems with the SD Card reader.

I use a Sandisk SDHC Extreme Class 10 SD Card and have problems getting it to read through the inbuild SD card reader.

I tried the following:

Reformatting on Disk Utility
Reformatting on my Canon 450D
Restarting Laptop
Resetting PRAM
Resetting SMC
Repairing Disk Permissions
Repairing Disk

All of these did not solve my problem. I have a card reader which when plugged into the MBP, works fine and detects the card.

The Weird Part

I plugged the card into a friend's iMac and it detects it every time. And then right after I do that, I plug it into my MBP, and it detects the card, but the problem is once I eject it, and slot it back in, it fails to detect again! However if I try this method again (Slot to iMac, remove, slot back to MBP), it will fail the second time.

Now when I take the card and put it into the camera, and take a photo, then slot it back into the SD slot, it detects the card once more, repeat the steps again, and without fail, the card is undetectable again, unless I do something like erase an image off the sd card using the camera, the MBP will then detect the card again upon putting it back in.


Does anyone here have this same odd experience or do I own a possessed MBP/SD Card?

Macbook Pro 2011, Mac OS X (10.6.6)
  • yeahyeahright Level 1 (0 points)
    Anyone else having this problem? I tried plugging it into my friend's new 2011 MBP 13 inch. Then I tried it on my cousin's new 2011 MBP 13 inch...same issue.

    I hear the SDXC card slot has switched from being wired to the usb port of the motherboard, to being wired to the PCIE port instead.

    Can anyone else confirm this?

    I'm using a Sandisk SDHC Extreme Class 10 16gb Card.
  • Porac Level 1 (10 points)
    I recently purchased (2 days ago) the newest 13 inch Macbook Pro (2.7GHz/500GB) and experienced the same 8GB 45MB/S Sandisk SDHC card (US) would not be recognized in the SD slot. In that machine, I did find a workaround.....leaving the card in and then restarting the machine. I made a Genius appointment and took it in to be looked at. They couldn't figure out what was wrong. I had them try the card in the most recent previous generation and it worked fine. I tried it in the store display models of the 13 and 15 inch macbook pros and it did not work. I was told to wait for a "fix", and went home. The next day, I had a problem with the display not being as bright as the previous model, and soi called Apple Tech Support to discuss that. In talking with Tech Support I also mentioned the Sandisk SD card issue, and was told by them that this was a know issue (as apposed to what they said at the store) and asked if I would please turn in the machine for a new one, so that their engineers could actually examine MY machine (mine would be the first to be turned in for such an evaluation). I agreed, and today went in for the swap. I went in to a different store, and tried my card on the new machine before the swap - and it worked fine. I had them swap the machines and move all may stuff to the new machine. Got it home and it did NOT work.

    I am wondering if there is something being transferred from the old settings that is either not compatible, or is somehow not allowing that card from being read.

    The card works fine in the camera, and in any previous generation macbook pro, and in the current IMACs as well.........

    Very weird......
  • yeahyeahright Level 1 (0 points)
    I doubt switching a to another new MBP would help. I've tried my SD card on both my cousin's and friend's new 2011 13 inch MBP as well and nothing popped up either.

    I really hope it's a firmware issue and that Apple's releasing a fix for it asap, cause it ***** to carry around an external SD card reader when there's already one in the laptop.
  • Porac Level 1 (10 points)
    The new MBP actually worked this afternoon, right out of the box (I popped in the Sandisk SDHC 8GB card, and it came right up onto the desktop, and showed in the finder), until they ported all my stuff over from the "bad" one, so I am thinking some setting or something got moved onto the new one, that created this issue. That alone seems to point to a software/firmware issue versus a hardware issue. I have emailed the tech who wanted to other one sent back, with this new finding, and hopefully a fix will show up sooner than later. Whatever the issue, it was able to be transported over to the new one, when they swapped everything from the old one to the new one.
  • Porac Level 1 (10 points)

    This is now a known issue, and I have sent my mackbook pro 13" i7 back into engineering for evaluation (EFFA). Hopefully they will come up with a fx sooner than later. Appears to be a compatibilty issue with Sandisk Extreme Pro 45MB/S SDHC cards (Class 10 as I recall). I purchased a new macbook pro 13" i7 a few days ago, and found that the card reader did not recognize the above referenced card. The reader did recognize the 30MB/S Sandisk card (both 8GB), and the most recently "retired" macbook pros recognized both cards, as do the current iMacs.

    They had me EFFA back the machine, and provided me with a new one. I tested the new one right out of the box and it worked fine, but after Migration, it no longer worked. Restoring using the included disk back to factory specs DID NOT restore the ability to read the card.

    In checking random machines at the apple store, only 1 on the entire floor recognized that a card was inserted, when I tried the Sandisk SDHC Extreme Pro 8GB 45MB/S card.

    Whatever the issue, it is rather odd that it seemed to have been ported over during Migration, but was not "fixed" after wiping and reformatting the HD using the supplied disk.

    As it appeared that my machine will be the first to have been EFFA'd, as they now have it, we can hope they come up with a fix soon.

    It does not appear to be hardware related, according to Apple Techs I am communicating with, so pushing on the card and other such things are probably not a good idea, and should be avoided.

    Interestingly enough, with the first machine I had, a workaround was possible by restarting the machine with the card already inserted, however, unfortunately, that workaround does nopt work with my current "defective" machine.

    I have also advised Sandisk.

    Hope this helps......
  • yeahyeahright Level 1 (0 points)
    That's great, thanks!

    Mine isn't the Extreme Pro though, it's just the Extreme edition 30mb/s Class 10 card.

    I'm not sure if I've fixed mine...but I tried a couple of things, and the recent one which seem to work was to uninstall Growl from my mac, which got installed with CS without permission.

    After restarting the computer, it recognizes it all the time since. It doesn't seem to pop up on Windows I'm guessing it's still an issue.

    Keep us updated! I hope unlike what I've tested, Apple has a better solution soon, I don't want to think I wasted money on a decent SD card! =)
  • yeahyeahright Level 1 (0 points)
    Ok uninstalling Growl didn't work. The problem came back after I'd put my MBP to sleep, brought it to work, and tried it again - No Luck.
  • yeahyeahright Level 1 (0 points)
    Managed to get a video up and running, I hope someone can shed some light to this!

    Problem is when reading a Sandisk Extreme SDHC Class 10 16gb Card, which works fine on all my equipment except the Mac!
  • yeahyeahright Level 1 (0 points)
    Looking at the new threads popping up, I assume there's no answer yet?

    Can those who are having problem particularly with the 2011 models post their SD Card Models that don't work?


    Sandisk Extreme 16gb SDHC Class 10
  • Lane Roathe Level 1 (0 points)

    I am also having this issue with my 15" 2011 MBP - inserting any SD or SDHC (I don't have an SDXC card) fails to result in the card showing up, either as a volume or in the Card Reader information in System Profiler.


    If I turn the MBP off, insert one of the cards, and then turn the machine on then the card will show up. If I eject the volume, remove the card and then re-insert the card the volume shows up again.

  • Lane Roathe Level 1 (0 points)

    Update: wanted to specify that ONLY the card I have inserted in the the SDXC slot will be recognized using the power-on with card inserted method. Ejecting and removing that card and then inserting any other card will NOT result in the new card being seen.

  • Pseuds Level 1 (0 points)

    Yup, same problem, but I also can't read DVD-R's, but that might be a seperate additional issue!


    Got married abroad, friend taking photos on my camera, went on honeymoon, all photos RAW = full SanDisk Extreme Pro SDHC 1, 45MB/s. I had my new maxxed out Feb 2011 MBP 15" with me so could back up to my hard drive and an external hard drive before reformatting but MBP wouldn't recognise the disk so couldn't back up and reformat. Proper annoying!!


    Fortunately had a spare cheap Nikon SDHC 4GB (class 4 I think, it's unlabelled) that the MBP detected, so could use that.


    I've been sent DVD-R's of photos of the wedding, but the boody MBP doesn't read them either... It tells me the disks are blank, but they work on my PC. Not sure if this is something different or the same. Has anyone else with the SD problem had a problem with DVD's? I think a trip to the apple shop is needed, but don't have the time.

  • jean_louis Level 1 (0 points)

    I can confirm that my Sandisk Extrme Pro 45 m/bs 16GB SDHC card does appear/mount if the card is left in the machine when when restarting. Subsequently removing and reinserting the card DOES NOT make it mount/appear.


    I have a new 2011 15" Macbook Pro. I ported all my setting acorss from a previous macbook so there could be a link though I never tried inserting the SD card before porting my account across.


    This is very frustrarting given that it worked on my OLD MACBOOK.

  • ikosx Level 1 (75 points)

    I have the same issue with my SanDisk 32GB USB Flash drive.


    It works fine in my old iMac 2009 an two or three old Mac in my office but in my New 15" 2.2 , it will get corrupted or it cant read......

Previous 1 2 3 4 Next