Previous 1 6 7 8 9 10 Next 171 Replies Latest reply: Aug 22, 2012 3:49 AM by Massimo75 Go to original post
  • Graphics Brian Level 1 (10 points)
    Come on folks, this isn't windoze... Apple doesn't release a ton of updates and patches for the Mac OS each week! How annoying would that be if Software Update nagged you every time you sat down at your computer? Enough complaining. _This forum is for discussion and solutions._ This is not for us to address Jailbroken or other unrecommended/unauthorized use of Apple hardware or software. It's a way for us to share experience and resolutions with one another. What a great way for Apple to further expand it's product support beyond Apple Phone Support!

    Of course a thread this size has gotten into the right hands at Apple. Don't get bent out of shape if the human you talk to at Apple Support isn't immediately aware of this issue. This is not the only thing people call them about. When you call Apple Support you are talking to a regular person with basic know how and training based in a call center. You are not speaking with an advanced systems engineer!

    *Temporary Solution (while we wait for Apple to address the issue):*
    *Boot in 32-bit mode if you need to tether via USB.*

    Please post if you are experiencing the issue. Let us know if you have any other normal circumstances surrounding the issue. Please post any other resolutions that may help the group. Please post as soon as anyone has discovered Apple has released the update that addresses USB tethering in 64-bit mode.

    Please do not reply to this post if you intend to complain about Apple, my new MacBook Pro, or ME! Maybe some of you should get a Windows laptop if you don't like Apple. Good luck there! I'm sure you can even find a forum for that out there to share your thoughts on that. I'm staying put.

    Any useful, helpful, informative posts welcome!
  • Lord Zero Level 1 (0 points)
    ehh, the most passionate apple lovers have a right to be annoyed and complaining when they buy 4K in products from apple plus fees to iPhone's provider to use a feature that completely crashes their system.
  • black6 Level 2 (160 points)
    Lord Zero wrote:
    ehh, the most passionate apple lovers have a right to be annoyed and complaining when they buy 4K in products from apple plus fees to iPhone's provider to use a feature that completely crashes their system.

    Absolutely right.... That kind of money warrants some healthy beta testing, not frozen machines, wifi drops, tethering crashes and SATAIII SSD failures across the board..

    It's simply not good enough no matter how rosy your rose coloured spectacles may be.
  • regriff Level 1 (10 points)
    All - I spoke with Apple a week ago about this issue just to document it with AppleCare in case they later decide to replace equipment. The agent I spoke with was unaware of the situation. I thoroughly explained the issue, known workarounds, and possible conflicts causing the problem. Thereafter, he instructed me to visit and log my report. Apparently developers receive direct feedback from this form submission and it gets logged internally at Apple support so phone techs are aware of the situation. This apparently hadn't been done and he said they rarely read these forums.

    I would HIGHLY recommend that each of your visit and do the same so they get the message. Hopefully they are working on a permanent solution.

  • black6 Level 2 (160 points)
    regriff wrote:
    This apparently hadn't been done and he said they rarely read these forums.

    I reported this bug the first day it happened to me back on March 2nd.. So the guy is spinning you the usual scripted BS...

    This bug should have never seen the light of day because it affects anyone who tries to do it, it's not intermittent which means the scenario was never tested in the first place. QC is at an all time low on all Apple products lately not just these laptops, Iphone 4 death grip being the biggest doosey of any tech released in the last 5 years. If they missed that then what else did do they miss.
  • regriff Level 1 (10 points)
    That all depends on how you "reported" the bug. If you called in and complained, then you didn't report it properly. Your issues is a singularity as far as they're aware. This is what the agent told me. In order for issues to be rolled out to the agents answering the phone, a technician has to submit a "bulletin" of sorts that lists the issue and possible workarounds/solutions. This has clearly not been done as multiple people have posted they have called in and talk to agents that are unaware of the issue. We're talking about a company that knows what they're doing. They obviously have a system and this forum is not a part of it. That system is to use their feedback form and call in numbers to report issues.

    Furthermore, while I agree that this bug should have been worked out before it was released, it's apparent that it's been around for some time, and is not a byproduct of a recent update or new hardware in the early 2011 model. It's only coming to light now because these systems are shipping in 64-bit mode by default.

    Lastly, while you are correct in stating it affects anyone who tries it, we can agree that it's a very small nitch group of users that ever find themselves in this scenario. Most users are running in 32-bit mode, unless they're savvy enough to switch to 64-bit, with a need to use it. Second, most users do not have iPhone's. Third, of those users that have iPhone's and are running a Mac in 64-bit mode, even less of them are tethering for Internet connectivity. So, while you're statement is accurate in saying it happens every time, it's just not frequent enough to be on anyone's radar.

  • heathgm Level 1 (0 points)
    I have this issue too.

    2011 15" high end macbook pro with high res matte screen.
    At first i thought it was a dodgy old usb cable!

    kernel panic when tethering via usb!

    on another note i also cannot use my external dvi monitor, it worked v briefly initially but now nothing comes up on screen.

    I'm sure both of these are driver/software issues, please fix apple!
  • black6 Level 2 (160 points)
    I've always used the feed back forms.. I'm no novice when it comes to Apple products.

    Let me tell you why this latest 'PRO' machine has me so riled.

    3 days in: i have to encode some video in the field for a TV project.. Hard freezes all the way, no work done.. Back to the hotel to check for emails and do some web work, hotel in Asia has no internet but my phones connected to the 3g service so no problem, i'll tether!.... Crashes... tether, crashes again.. no work done..

    10.6.7 fixed my freezing problems, i was one of the lucky few.. See how long that thread is now BTW?

    I blue-toothed the phone to fix my tether issue, i believe i was the first to find that workaround on this very thread, wanna check? I whinge but i'm a helpful whinger..

    This morning i took delivery of my new SATAIII SSD, do you want the miserable story of how that turned out? Don't bother it was rhetorical... I already ordered a replacement SATA cable because i don't have time for Apple to admit the fault (bad signal to noise ratio).

    Can you see my point? I don't use this thing to play facebook or tweet that i'm eating steak and fries, i need a tough, fast and more importantly a reliable machine..

    And no i couldn't return it i was pulled out on assignment in Asia. Let's face it, would a replacement machine have made any difference? Unlikely.

    I think i earned the right to have a ***** about this while at the same time try to get it resolved. What do you reckon?
  • Greg Earle Level 1 (145 points)
    What do I reckon? I reckon you early adopters are foolish. It takes 3 gens for Apple to get new products right. Because of the Cult of Secrecy™ these things never get vetted properly in a wide beta test environment that would show up these issues. They probably give a few samples to people at Disney and Genentech with iron-clad NDAs and think this qualifies as adequate "beta testing". Time and time again it's been shown that it isn't.

    Want to REALLY help Apple get this solved? Stop all the "me too" posts in the thread. Don't waste your time with the Feedback page (a.k.a. cat > /dev/null).

    Sign up as an Apple Developer, and use RADAR to submit a real bug report.

    Then install a debug kernel (easily obtained from the Developer site) and that way when your tethering crashes the thing, you can submit a real bug report that shows the kexts loaded, with symbolic entries (instead of just long hex numbers like "0xFFFF0000DEADBEEF") that are actually useful for Apple engineers.

    While you and everyone else "earned the right to byatch about this", it doesn't do any good. Try some constructive debugging that helps Apple fix the problem.

    [Disclaimer: I have an old 2006 MacBook Pro and a 2010 Mac Pro so I am not in a position to help, but I would if I had a new 2011 MBP.]
  • Lord Zero Level 1 (0 points)
    Anything else we can do, besides become developers, and feel ashamed for buying the latest MBP's? Offer Steve a liver, perhaps?
  • Josh Scott Level 2 (295 points) guys are flooding my inbox.

    I think I'll start a new thread, "I realize there is a USB tethering issue with new MBPs that causes a kernel panic and am waiting for Apple to fix, please only post when you can confirm they have."

    Anyone want to subscribe to that one because this thread has served its purpose. We know there's a problem and Apple has to fix it.

    Time to unsubscribe.
  • rsmseys Level 1 (0 points)
    The reason that this is occurring (and Apple already knows about this bug) is because of the new 64-bit kernel on the hardware. This could also potentially occur on the Mac Pro which supports the new 64 bit kernel as well, but nobody tethers a Mac Pro to an iPhone so it's really not been discovered. The way to simply "fix" this is to boot into 32 bit mode by holding down the '2' and the '3' button on your keyboard while booting and this will cause the kernel to boot into 32-bit mode, thus eliminating the issue as long as you don't reboot back into the 64-bit kernel. You can also set your computer to automatically boot up into 64-bit mode by checking out the article at

    This also only occurs if you are tethering with the cable, so if you use WiFi or Bluetooth the error won't occur. Be careful as your Macbook will choose hardware tethering over Wifi if you are connected with the cable, so if you disable the device on your Mac, you can still have it connected for charging (Wifi tethering will deplete the battery quickly). They are aware of this and are working on a fix, but until then this is really the only viable option you have to eliminate the issue for now. I apologize if this has already been hinted at, I didn't bother reading the large number of posts, but I knew a quick solution to those that are still having issues. Hope this helps, and let us all hope that they release a fix shortly.

  • IanBangkok Level 1 (0 points)
    Same problem...almost new MacBook Pro crashes after few minutes of usb internet tethering to iPhone. BT fine. Have now downgraded to 32 as suggested.
    This seems to work

    Thanks for all the help...I would call support but in Thailand the number doesn't work...
  • billalexander Level 1 (10 points)
    Your reply, while well intentioned, has been more than hinted at in the posts above. Booting into 32 bit mode and/or connecting via Bluetooth/Wifi has been discussed and detailed multiple times. For those new to the post, keep in mind that booting into 32 bit mode is not a "fix", it's a workaround.
Previous 1 6 7 8 9 10 Next