Previous 1 2 3 Next 35 Replies Latest reply: Aug 18, 2011 7:12 PM by MJG196
Mark2011 Level 1 Level 1 (0 points)
It looks like I have some company with at least similar issues. This is very frustrating and support was no help.

ATV 2 worked just great with Windows 7 64-bit and iTunes library until the 4.2 update was loaded. Now ATV 2 keeps telling me to turn on home sharing on a computer but it's already on and iTunes is running, I'm using iTunes 10.2.1.1 and Apple TV2 with latest update 4.2 (2060) and connection over WIFI. Home Sharing is enabled on my computer and ATV2 using the same Apple ID and password. I can get to YouTube and the iTunes store from my ATV 2 without issue.

I've attempted many solutions from what I could find online but no luck:

1. Turned off/on home sharing on both the Apple TV 2 and in iTunes (multiple times)
2. Re-entered my Apple ID and password on both ATV 2 / iTunes
3. Restarted iTunes and ATV 2
4. Restarted the DSL modem/router (ZyXEL PK5000z)
5. Turned the firewall completely off (Norton Internet Security - firewall is off in router)
6. Restored ATV 2 over WIFI
7. Reinstalled iTunes
8. Changed my Apple ID and password then reset in iTunes and ATV 2
9. Renamed my itunes library
10. Disabled QoS upstream/downstream protocol in my DSL modem/router
11. Restored ATV 2 through USB connection in iTunes. This worked for a few minutes but after I turned off ATV 2 and later tried again it was back to it not working...

Any other ideas?

Apple TV 2, Windows 7
  • iminfenix Level 1 Level 1 (0 points)
    Maybe you mean after 4.3 update? Anyway, I've got no home sharing after all fixes, too. Mine is confirmed to be my Actiontec modem from Qwest, which is waiting for firmware upgrade (maybe you're using Qwest, too, because I recognize your modem). I see that qwest has swapped out my modem for yours for other users because of the same issue, and it worked. So, I'm trying to get the ZyXel modem like you.

    Meanwhile, you do know, don't you, that iTunes requires ports to be open, TCP 3689, and UDP 5353. If you can, try that in port forwarding or application in Advanced setup. Let us know if it helps, and if I should go ahead and get the ZyXel from Qwest.
  • Chenks Level 5 Level 5 (7,420 points)
    iminfenix wrote:
    Maybe you mean after 4.3 update?


    there is no 4.3 update, the current and most recent update for appletv is 4.2
  • iminfenix Level 1 Level 1 (0 points)
    Well, for the iPhone, iPad, etc., Home Sharing was just introduced with the 4.3 update. I thought iOS was iOS, so on the ATV, too. But, I don't own an ATV, so I could stand (or be knocked down) corrected.
  • Chenks Level 5 Level 5 (7,420 points)
    iminfenix wrote:
    Well, for the iPhone, iPad, etc., Home Sharing was just introduced with the 4.3 update. I thought iOS was iOS, so on the ATV, too. But, I don't own an ATV, so I could stand (or be knocked down) corrected.


    iOS4.3 is what the appletv software is based on but the appletv software version is 4.2, so you are being corrected.
    if you don't have an appletv why are you trying to assist someone with an appletv issue ?
  • iminfenix Level 1 Level 1 (0 points)
    Chenks wrote:
    if you don't have an appletv why are you trying to assist someone with an appletv issue ?


    Reasonable question.... it's because I was searching for help on "Home Sharing" for iTunes in iOS 4.3, and found that Qwest's Actiontec modem does not support igmp (bonjour). Just trying to help the questioner in his issue.
  • HuggableJunk Level 1 Level 1 (0 points)
    I am on AppleTV2 4.2 with Home Sharing enabled on a win7 machine and a macbook pro.
    I have found that I am able to see my home sharing libraries when I've connected wirelessly. As soon as I plug in the wired connection the home sharing libraries disappear. Prior to the update, wired connection worked.
  • mthhurley Level 1 Level 1 (0 points)
    I have this exact same problem. My ATV just updated to 4.2 and my Mac Mini just updated to the latest iTunes version today (and in turn updated my iphone to 4.3).
    Now my ATV is useless. Keeps saying to enable home sharing and it is. I have wifi connectivity and have tried many of the steps you have. So the big feature I wanted to try (video streaming to the ATV) I can't even try cause the ATV is busted now.

    Clearly, there's an issue here.
  • Nauzo69 Level 1 Level 1 (0 points)
    Hi Mate,
    After spending the past few having techs logging in and out of my computer, finally some lights are shining through. One guy changed my NAS to another IP address, then both of my ATV showed up. But the NAS kept on dropping connection, so the next tech fixed the NAS problem, Apple TV gone. Third guy decided to look down 1 ATV with TCP 3689, and UCP 5353. But now, the other ATV can not do the same thing, since the TCP & UCP will be conflicted.
  • Nauzo69 Level 1 Level 1 (0 points)
    Hi mate, I took on your advise and did the router settings witht he TCP & UDP ports. But my problem is, I have 2 ATV's, which mean they will be conflicted. Any suggestions?
  • Winston Churchill Level 10 Level 10 (86,535 points)
    Having two Apple TV's won't cause any conflicts on the same network, although it will be wise to give them different names.
  • Mark2011 Level 1 Level 1 (0 points)
    Well, I tried a few other things and one worked but again just the first time I tried connecting to the desktop PC with iTunes. I flashed my router with the latest update and the ATV2 could see the iTunes library and I was able to play media. Later in the day I was going to show off to my daughter that I had fixed it and, to my dismay, no go. I tried opening the suggested ports but no luck.

    I then tried loading iTunes on a Win7 laptop and it works perfectly with the ATV2. Both the laptop and the ATV2 are connected to the router wirelessly while the Desktop is connected to the router by Ethernet. Not sure if this is part of the issue as it sounds like this didn't work for others. The only other difference between the laptop and desktop is that the desktop has Win7 SP1 loaded while the laptop does not; now I'm scarred to load it though I don't think that's the issue. All in all, a very vexing situation. Hopefully Apple comes up with a solution soon.
  • EoPocho Level 1 Level 1 (0 points)
    I have tested this extensively. Here is what I have found... When you are using a Windows platform (XP pro and win7 at least), and the Router from FIOS (Actiontec 424), the ATV2 and the PCs can only work together if they are both wired or both wireless. It seems that for PC's, there are effectively two separate networks via the Actiontec - 1 wired and 1 wireless. Getting Apple or Verizon or Actiontec to help solve the issue, however, is another story.

    Any help or ideas would be appreciated as I am now stuck in the mud.
  • Mark2011 Level 1 Level 1 (0 points)
    It is odd that it worked, at least for me, in the mixed wired/wireless environment prior to the ATV2 update.
  • surfnh Level 1 Level 1 (0 points)
    EoPocho.....I have the exact same finding. I have an ATV2 and Macbook both wireless, they can communicate via homesharing no problem. I also have 2 PC's (1 Vista and 1 XP) that are both wired....they communicate via homesharing no problem.

    But, the wired devices cannot communicate with the wireless devices. Low and behold, we have an Actiontec GT724-WG wireless router. As luck would have it, my itunes library is on one of the PC's so it can't talk to the ATV2. Just got this router about a year ago from our DSL provider, I'm thinking I'll call up their tech support in the morning.

    Of course I suppose I could just pick up a wireless USB and convert my main PC to wireless?
Previous 1 2 3 Next