Previous 1 2 3 4 Next 55 Replies Latest reply: Feb 6, 2014 9:12 AM by BeerInTheHand
dgknc Level 1 Level 1 (0 points)
Since I updated to 10.6.7, when I try to take a folder or file off the sidebar that I've put on there (either before or after the update), it won't go. It used to disappear in a puff of smoke; now it just pops back to where it was on the sidebar. Is that a bug in 10.6.7?

MacBook Pro, Mac OS X (10.6.7)
  • Barney-15E Level 8 Level 8 (39,185 points)
    I think they've hardened it a little since so many people were accidentally pulling things off.
    Hold down the command key and drag it off, or right-click and select "Remove from Sidebar."
  • Kappy Level 10 Level 10 (241,640 points)
    A "new feature" that seems to have gone unmentioned. Most be driving people nuts.
  • dgknc Level 1 Level 1 (0 points)
    Thanks - but that doesn't seem to work. If I hold down the 'mouseclick' bar below the touchpad, it opens whatever the cursor is on - then I can drag it to the desktop but it pops right back to the finder when I release the bar. If I hold down the Command key and the 'mouseclick' bar, then I can drag it along with the 'puff of smoke' to the desktop, but when I release it still pops back to the sidebar.
  • Kappy Level 10 Level 10 (241,640 points)
    What item(s) are you trying to remove from the sidebar?
  • dgknc Level 1 Level 1 (0 points)
    I'm trying to remove some files and some folders that I put there. Things that I dragged there from within the Finder, not things like Documents or Downloads that I put there from Settings. Some I put on the sidebar before updating to 10.6.7, some I put there afterwards. None of them will leave the sidebar no matter what I try.
  • dgknc Level 1 Level 1 (0 points)
    Just found the answer myself by trial and error. If you want to take something off the sidebar that you've put there by dragging, hold down Option and Command, then click and drag it to the desktop. It disappears in a puff of smoke just as it used to by simply dragging.
  • dgknc Level 1 Level 1 (0 points)
    Thanks to Kappy and Barney-15E for suggestions.
  • Artdog17 Level 1 Level 1 (0 points)
    Thank you so very much! I've been trying to remove a few folders from Places for several days, since I upgraded! Thanks for the question posting and answers!
  • fHofmann Level 1 Level 1 (0 points)
    Thank you for posting the answer to this!

    To sum this up:
    - dragging +from sidebar+ is crippled to only work with cmd-Key pressed
    - dragging +to sidebar+ works correctly
    - dragging +from dock+ works correctly

    Apple, please change this inconsistent behaviour of items inside sidebar before I get used to pressing cmd all the time.
  • Glenn Leblanc Level 5 Level 5 (6,475 points)
    Just for more information:

    Right click on item in sidebar (or control click) to bring up menu and choose remove from sidebar.

    Oh, I see Barney already posted this.

    Message was edited by: Glenn Leblanc
  • Barney-15E Level 8 Level 8 (39,185 points)
    Apple, please change this inconsistent behaviour of items inside sidebar before I get used to pressing cmd all the time.

    Apple isn't here. Just us users. And, I imagine it was done on purpose since lots of people inadvertently drag things out of the sidebar. And, it does work consistently with the status menu and things in the Toolbars.
  • griffondoor Level 1 Level 1 (0 points)
    Thanks everybody for answering a question I didn't ask. Ya think that Apple would have something about this in sidebar prefs.
  • Tom in London Level 4 Level 4 (1,605 points)
    Yeah. After messing with this for quite a while and finding nothing in the "Help" except the WRONG instructions (which still describe the old way of doing it) I had to come here to find out what was up.

    This must be very confusing for new Mac users. Isn't the Mac OS supposed to be user-friendly?
  • npettijohn Level 1 Level 1 (0 points)
    I had a stuck link to a non-existant folder on the sidebar. In addition to the symptoms described here, I noticed the contextual menu options did not include "Remove from Sidebar" like the working links do. The only option is "Open Sidebar Preferences...", same as when you right-click in Sidebar empty space. I tried dragging to the desktop while holding the Command key and that was the only way that worked. I am unable to recreate this condition; so, I suspect it happened during update to 10.6.7. Thanks for the suggestion!
Previous 1 2 3 4 Next