Previous 1 2 3 Next 198 Replies Latest reply: Jan 29, 2016 1:34 PM by Cannons
AlfredGZ Level 1 (0 points)
"An error occurred loading this content. Try again Later"

I get this message when trying to stream/load some movies, not all. I could stream YOGI BEAR in HD for my kids no problem. I could stream Jacka*3 HD no prob. I can also watch trailers. But I try The Fighter and Hereafter, and get the message all the time. I am afraid to purchase anything else coz I dont know if it will work. I tried rebooting, restoring and software update, but nothing helps. Please help anyone???!!

Alf

APPLE TV 2G, Other OS
  • sandler77 Level 1 (70 points)
    This has been a discussion for several weeks now: http://discussions.apple.com/thread.jspa?threadID=2615363

    Unfortunately, the new Apple TV software update released did not fix this bug. We're all waiting from Apple on this...
  • Ed Anton Level 1 (0 points)
    I've tried multiple rentals on ATV2, both movie and tv show. Same error recurrs: An error occurred loading this content. try again later.

    I've watched part of the movie (The Tourist) now that I'm trying to watch the rest, the error has occurred. Just to test things out, I also rented a television episode. Same error. Please advise on how to remedy these errors.

    Thanks.
  • pmudditt Level 1 (20 points)
    Yes, I have the same error message, I have tried resets and the firewall changes and router reboots but I cannot get a rented movie from iTunes to play at all. My ADSL speed is not great approx 2Mbps but I can view YouTube and movie trailors. I don't appear to have been charged yet and I am hoping because it cannot even begin to play then hopefully I will not be charged. I can Airplay a bought movie from either my iPad or my Win XP PC so I know it can work. I guess next time I'll just rent on my iPad so long as you are allowed to Airplay a rented movie?
  • Brian DXB Level 1 (0 points)
    I'm having the same problem. Can watch trailers but rented a tv show and it will not load. Unfortunately, once you rent in apple tv then you cannot watch it on your mac. The reverse does work though through an apple tv.

    Hope they fix this soon.
  • stitch626 Level 1 (0 points)

    Hi Everyone

    I have this issue too. Just with Tron Legacy, I can see and download other movies but this everytime says "An error has occurred. Try again later" and I tried th next day, I restore my Apple TV, my modem, and anything happens. Hope a fix quickly.

  • movie_watcher_wi Level 1 (0 points)

    I was having the same problems. I was streaming over wireless from my windows 7 pc. I switched to a wired connection (strung a 50ft cable across my house) the probelm went away. My guess is a have a slightly flakey wireless adapter that was good enough to stream short movies and some content.

  • OliverSL Level 1 (20 points)

    I rented Tron Legacy too, none of the solution worked for me:

    - reset with menu and down button

    - turning on/off dolby

    - changing the language

     

    Is this only with Tron? I can download free TV episodes for example

  • ray sharpe Level 2 (470 points)

    Its a HDMI handshake problem. I had this months ago and found a cure.

    I did these things 1. Unplug the hdmi cables. First tv then apple tv 2. Unplug the TV power and the AppleTV power, let them sit 30-60 seconds, 3. Plug in hdmi cables while power is off 4. plug the tv power in first, then the ATV power. This worked for me! (I was told it's an HDCP Handshake error, and the handshake is forced to be done again by unplugging power, but make sure you unplug both devices and plug them in the order above).

  • OliverSL Level 1 (20 points)

    Can you try again with a network cable or force your wifi router to use only wifi-g or wifi-n? The Specs says you need wifi g or n for streaming:

    http://www.apple.com/appletv/specs.html

    "Wi-Fi (802.11 a, b, g, or n) wireless network (wireless video streaming requires 802.11a, g or n) or 10/100BASE-T Ethernet network"

  • OliverSL Level 1 (20 points)

    Hi Ray,

    I tested what you suggest and can confirm that is does not solve the problem. The problem persist.

     

    I also tested using an ethernet cable, the same error appears.

     

    I can watch a TV Series with no problem, my issue is with the Movie Tron.

  • Ken Spiker Level 2 (295 points)

    I have the exact same problem. I posted earlier and got the exact wording of the error message wrong but it's the same as here "An error occurred loading this content..." It happens a lot with streaming Netflix for me and I am able to stream Netflix on my BluRay player and content which AppleTV can't load the BluRay can play the same content just fine. This is nuts, it's been going on for at least 6 months and Apple doesn't fix it.

  • txmac2 Level 1 (0 points)

    Same problem here.  Toy Story 3 HD.  Purchased and on my local iMac.  Connect via ethernet to my Apple TV 2.  I can stream home movies to ATV2 but I cannot stream TS3 to ATV2.  I get the same error message.  TS3 plays fine on my computer.  Frustrating - can't play purchased content on my own TV.

  • chris elly Level 1 (0 points)

    im the same rented Tron today and i get the same message i have done all of the above but no fix i hope i dont get changed UK

  • F Jay Level 1 (0 points)

    I get the same response and I rented two different movies  1st thinking that the Kings Speech was just over sold. So Rented and paid for a second movie.  So I tried something else I and get the same error message and I have been trying to get the movie to download.

     

    I have been at this for about three hours.

     

    "An error occurred loading this content.  Try again later."

     

    Not good!

    How about fixing this Apple?

Previous 1 2 3 Next