Previous 1 7 8 9 10 11 Next 198 Replies Latest reply: Jan 29, 2016 1:34 PM by Cannons Go to original post
  • Th3Cr0w Level 1 Level 1

    Aferr11 - Ha ha! That was great. In fact I wasn't speaking to anyone in here but you. Sure, there are people in here having a hard time with an odd problem, that I myself had. Is it Apple's fault? I would not presume to know that - unlike you, "arrogant enough to make a blanket statement" that Apple's products are all garbage.


    I did want to point out to some that believed it was a single movie title that was the problem, or an ISP issue, or a streaming issue from Apple, etc. that it also happened to me on my own content over WiFi in my own house. I had removed the variables, still had the problem with the same error, etc. And I offered my fix. That may have helped some people less volatile than yourself - either by showing them what it could be, or what it isn't.


    Everyone had experiences to share, important info about their predicament, possible causes (which I suspect are numerous and not from one particular setup or set of circumstances) including user error - hey, it happens - as well as myriad solutions. This is a problem happening to a tiny subset of users. It's frustrating, but that's why these forums are an excellent source of help for people. Helpful people, that is, and not trigger-happy trolls looking to bash Apple, talk about how great everything else is, and threaten not to purchase anymore products. Blah, blah, yada, yada...


    I don't usually take the bait, but you dangled it too close to my face on a night I didn't feel like reading some idjit's diatribe. And no, not an Apple Employee, but yes also an IT professional for 19+ years with 3 university degrees including a Master's (if that's what you were looking for).  If I offended anyone else here, it wasn't my intention and I offer my apologies; my irritation was directed solely at Aferr11.

  • Aferr11 Level 1 Level 1

    Well then surely someone with such qualifications has better things to do then to take the time to lurk blogs and start arguments with complete strangers. Perhaps next time you should offer your solution to a given problem and keep your bs comments to yourself. I do however agree with a number of things you said. First off, I agree with you about apples products. My initial email was a result of frustration on a persistent issue and as I'm sure you know you cannot delete your blogs which I tried to do shortly after posting that rant. I also agree that this a place to resolve issues and I don't want to contribute to turning this blog into a hostile community. This nonsense has no place here. Therefore, I also want to apologize to the community and to apple as well.

  • Th3Cr0w Level 1 Level 1

    Let's chalk it up to two frustrated guys on a bad night, Aferr11. Sorry for starting an argument, and I hope you find a solution to your problem. You may like to know that there are a few other similar discussions on these forums; perhaps your answer is still out there.

  • jennyjen Level 1 Level 1


    1. Unplug the hdmi cables. First tv then apple tv 2. Unplug the TV power and the AppleTV power, let them sit 30-60 seconds, 3. Plug in hdmi cables while power is off 4. plug the tv power in first, then the ATV power. This worked for me! (I was told it's an HDCP Handshake error, and the handshake is forced to be done again by unplugging power, but make sure you unplug both devices and plug them in the order above).


    This should work for any content that is streamed through the Apple TV.

  • bigfeet4littlepeople Level 1 Level 1

    that's great, thanks. but what happens when your tv is mounted to a wall and you can't disconect the  hdmi from the tv ?? This sounds rediculous.


    I got the same issue with the said error in loading prompt and found that it has to do with the servers at itunes being updated with the new content of the day. If you restart your atv it usually goes away.

  • Dackers1 Level 1 Level 1

    I am furious having bought the new apple V and both rented and bought movies in I Tunes that get the error message "this requires and HDCP cabe" and doesn't play when my TV is HDMI, the cable is connected and I can clearly view all trailers...Apple what are you doing about this!!!!

  • Aferr11 Level 1 Level 1

    Thank you Crow, you're a gentleman. My apologies on my childish remarks. 

  • iDeMi Level 1 Level 1

    For me the fix was just to resart the Apple TV. In the menu go to Settings -> General -> Restart.

  • amitkhanna Level 1 Level 1

    For me this was a simple problem / solution - I had bought a tv show while my apple tv was set to HD and then later I had changed the mode to standard. This prevented / gave the error "unable to play content" When I changed the format back to HD the tv show played without any reset / reboot.

  • judefromqc Level 1 Level 1

    I am also getting this error ""An error occurred loading this content. Try again Later". I have tried out all the recommendations in the post and nothing has worked. I have a question to all who have this problem. Are you playing HD videos when this issue happens? That seems to be the case for me. When this issue happens, the only choice I have is to reboot my computer to get this working again. When this happens, my whole internet connection comes down. Now, I am beginning to think that my ethernet adapter may be stop working due to insufficient buffer etc. There may be a way to increase the buffer? I have not seen any configuration options so far anyone providing this tool for PCs. It could also be that the ethernet adapter just cannot handle this. has anyone come across any tools to configure ethernet adapters in PC?

  • scottmanby Level 1 Level 1

    I recently suffered from the same error and was ready to use the ATV for target practice. I tried all of the solutions in this thread to no avail. But I found a blog that commented that it's a result of older network routers with outdated firmware.  I couldn't even get YouTube to work on my iPad or Xbox 360. So I bypassed my router (dlink wbr-1310) and plugged directly into my airport extreme. Now, everything works fine. AirPlay streaming, and YouTube on all my devices.  So give that a try. Worked for me.

  • judefromqc Level 1 Level 1

    Ijust replaced my router with Airport Extreme. I stll have the same issue. May be the problem is with my PC ethernet adapter. May be I have to replace my PC. I am dissappointed that apple seems to act like they do not knw about ths issue and not trying to help its customers.

  • IgMa Level 1 Level 1

    The only thing that worked for me is changing the DNS setting on Apple TV to use Google's DNS, which is It's weird because it's always worked with automatic setup. I have Fios, but I guess they decides to block something. I came across a post about DNS on some other site. Hopefully this will help everyone. By the way, I'm wirelessly connected to a time capsule.

  • Hash80 Level 1 Level 1

    Dear all


    I would like to suggest a solution that i personally discovered and havnt read a single thread for it, not to mention that i have tried all the suggested fixes on the web like restarting, power disconnection, rebooting, etc. the solution that worked well for me is that i went to the general settings on apple tv, itunes settings and turned the video settings to standard definition, and baaaaam


    All the contents that didnt play, are now playing.



    Try it and you will thank me.



  • Best14you Level 1 Level 1


       Sep 12, 2012 9:29 PM    (in response to Whalie

    I had this error problem too. I took the Apple TV back to Best Buy and got another one. I still had the same problem of only previews playing. I eventually fixed it by getting another modem for my internet. You need one that is the docsys 3.0 or greater.

    If you want the one I got that worked then click:

    zilla:en-US:official&client=firefox-a#q=surfboard+6120&hl=en&client=firefox-a&h s  =tG2&rls=org.mozilla:en-US:official&prmd=imvns&source=lnms&tbm=shop&sa=X&ei=dmB R  ULDzNaTtygGx1IDoBQ&ved=0CA4Q_AUoBQ&bav=on.2,or.r_gc.r_pw.r_cp.r_qf.&fp=7546be72 b c55ba3a&biw=758&bih=850


    I did upgrade to a faster internet service with the cable company, but I doubt that really made an impact. My wireless router uses wireless N and that works too with the Apple TV. Good luck.

Previous 1 7 8 9 10 11 Next