Previous 1 3 4 5 6 7 Next 689 Replies Latest reply: Sep 6, 2015 10:21 AM by applefan4310 Go to original post Branched to a new discussion.
  • samboy86 Level 1 (0 points)

    The Dynalink router website has this problem in its FAQs for my Router and it doesnt have a real solution as of yet, but they have recommended people to DOWNGRADE their Firmware for the iPhone problem, but that didnt work either, and yes I have tried both upgrading and downgrading, doesnt work.  I havent upgraded to 4.3.3 purely because I see everyone saying this triggers the home wifi Network issue! I will do that as a last resort if nothing else works. This seems to be a very common problem with iPhone 4 users (wireless works everywhere except at home, and home wirless works with everything except iPhone 4). Maybe an Android would have been a better option -.-

  • GregTB Level 2 (215 points)

    I'm definitely starting be believe that the problem that is causing this to happen is a compatibility problem between the new iOS version, and the routers firmware. Everyone should try updating their home routers firmware. If new firmware is not available, be patient and wait for the manufacturer to release an update, or buy a new router.


    - Greg

  • maaat Level 1 (0 points)

    ..with the newest firmware of my router I still have this problems. Interesting is the fact that my home wifi connection works sometimes after searching it for some time very well, but sometimes not, without any rules. In some rooms of my house it absolutly doesn´t work even my other macs, iPad etc works and find and show the wifi and use this connection easy while I can only see the Wifi in my iPhone without the possibility to connect to internet. Close to my station I can use my wifi-connection with my 3GS for hours until it breaks without reason and  I have to restart my iPhone....

    Slowly I really get tired of this big problem and I can´t understand that Apple  is unable to change this costfully problem                                                                                                                             

  • anthonydoc Level 1 (0 points)

    Bear with me if this is a silly q, I have now been asked to connect to my wireless network which I have done. Well I think i have, I know have the wifi signal in top left of phone however the phone provider is also there with bars , so am I wifi connected or not , anyone?

  • Korthal Level 2 (185 points)

    Essentially yes. If your IP Address isn't a 169.254.x.x (Self Assigned IP) and your bars are showing a reception (WiFi Bars) then yeah, you'll be using WiFi.


    If you want to double check, disable 3G & Cellular Data within Settings and try connecting to Safari. If it works, you're on WiFi.

  • anthonydoc Level 1 (0 points)

    Yes I have turned off cell and 3G and it looks fine now weird it just connected straight away this morning, last q can you make and receive calls in wifi am sure you can't thus how can I be one million percent sure that my data allowance is not effected when on wifi, I believe unwed to turn off roaming ?

  • fliskfreya Level 1 (0 points)

    Not just a router problem.


    I connect my iphone at work to my mac by wifi to share the macs internet connection, this is no longer possible. Tried uninstalling and installing the network again, switching off cellular data allows it to connect, but it switches off again as you look at it, and will not reconnect.


    Bizarrely after work on the way home it connected to a free wifi on another parked bus.

  • hfoster02 Level 1 (0 points)

    I was having this problem since I updated to iOS 4.3.3 yesterday, though I only realised it today when I went into use my college wifi network as I just presumed it was my home network that I was having problems with. Did the whole forget network and re-enter password thing for the home network, wifi symbol still wasn't coming up though it said it was connected. Turned on airplane mode, tried using Safari and the internet worked, so it was connected despite the symbol not being there. Then the airplane mode symbol wouldn't go when I turned it off, so I turned the phone off, turned it on again and all seems to be normal now.

  • William Donelson Level 4 (2,495 points)

    What frustrates me?


    Not a PEEP out of Apple. Never is. Know why? Might affect the share price. Pretty insulting.


    I have followed and tried everything here. I have a limited amount of data from my 3G connection per month. Apple is making us use that up.


    Come on! Make a comment, or "We're Sorry" - other companies do.


    btw- A neighbour's daughter can connect with an old non-updated iPhone 3 just fine, still.

  • deggie Level 9 (52,662 points)

    What company does that? And why would they say "I'm Sorry" to all those who aren't having any issues?


    Call AppleCare and go over the situation with them. If the problem can't be resolved at that level they will issue you a case number and elevate your situation. This way Apple engineers will have information regarding your setup and can use the data to work on any bugs that have been introduced and issue an update. Without that information it may never be resolved.

  • Roman.Moscow Level 1 (0 points)

    Hello all! I bought today iPhone4, launched for the first time it was updated.WI-FI doesn't work as is?

    p.s sorry for my English)

  • maaat Level 1 (0 points)

    After 5 days Problems at my home-WLAN with my iPhone 3GS After upgrading to 4.3.2, (it some times worked, sometimes not ) and after trying everything which I found written here at this forum, I powered down my FritzBox for over 10 minutes today. I am not really shure about it but it seem to work now as it worked before  updating to 4.3.2. First time  after 5! days I have no break since 5 hours ! I really don't have any explanation for that way but maybe it works ?

    If someone makes the same experience please let me know.

    Sorry for my bad English ....good luck to all of us !

  • shiuan Level 1 (0 points)

    I read through the thread till thus far and I think it is indeed an update problem, because I have the same problems right now.

    I'm updating the iPhone 4 software for a family member, I did that one first, internet stopped working even though I can get onto Wifi in the house no problem.

    Other iPhone 4s we have in the house (there are two others), using the SAME Wifi connection, but just running the previous firmware, do NOT have this problem.


    I think the issue must lie in the new software upgrade. Hope they fix this soon!!!

  • shiuan Level 1 (0 points)

    CORRECTION: found a possible workaround that has just restored my WIFI connectivity after update!


    Go to WIFI

    Find the network you're currently connected to

    Click the arrow next to the name to reveal the IP stats

    Click "Forget this Network"

    And then re-scan for networks, and re-enter the password, voila, worked for me!


    I think the trick is to reset whatever settings the iPhone had stored for your home WIFI, so that it re-initiates the process to get a new dynamic IP with DHCP.


    Hope this helps, people!

  • s_roden Level 1 (0 points)

    I tried this but it didn't work for me.   It shows that I am connected to wi-fi under settings but no symbol.  It still is in 3G.   I've tried everything and can't get a wi-fi!!!!

Previous 1 3 4 5 6 7 Next