Previous 1 42 43 44 45 46 Next 689 Replies Latest reply: Sep 6, 2015 10:21 AM by applefan4310 Go to original post Branched to a new discussion.
  • kalai005 Level 1 Level 1 (0 points)

    its actually worked for me. thank you soo much

  • AgentSeb Level 1 Level 1 (0 points)

    I tried it and it worked. It is a miracle. This issue was bugging me since forever.

    We are a family of four with a total of 16 devices (cell phones, ipad, pc, Wii, Dvd, Printers...) connecting to our Netgear wifi router. And some devices kepts being disconnected (never the pc...) without me understanding why.

    Then, with this fix, 100% of these problems have been solved in the following 15 seconds...

    Thank you thank you thank you!!!!

  • hhelmbold Level 1 Level 1 (0 points)

    Problem Solved....  I upgraded my iPhone 4s and iPhone 4 to iOS7 and suddenly everything works perfectly again! A while back Apple brought out a patch that was only for iPhone 4s - after this patch the problem was solved. A little while later they brought out iOS 6.1.2 and the problem was back!


    My point is.... Apple is very quick to cover up problems and tell people all kinds of stuff to try and hide their mistakes or make it look like a "feature"


    My next phone will most definately not be an iPhone and Apple will not see me as a client ever again!

  • samwillhelp Level 1 Level 1 (125 points)

    I was having connecting issues when I updated to iOS 7, but this solved it for me:

  • EBtheDESIGNER Level 1 Level 1 (0 points)

    I found a solution! After trying changing all sorts of settings on both my iphone 4 and my home wifi router through Airport, i found the issue with connecting my iphone to the home wifi was solved simply by changing one setting through the Airport Utility. I changed my wireless home network radio channel (2.4GHz channel) to manual and selected channel 10.


    This setting can be changed by:

    Going into airport utility, select "edit" Airport Express,

    select "Advanced",

    select "Wi-Fi Settings",

    select "Radio Channel",

    turn off Automatic Channel on the 2.4GHz Channel,

    and then selecting number "10" from the drop down menu.


    So happy!! after hours of frustratingly trying different settings to see what worked, im relieved to have actually found a solution!

    I dont usually sign up to post helpful things like this but thought id try and save any of you some long, dreadful hours messing about. Good luck!

  • EBtheDESIGNER Level 1 Level 1 (0 points)

    And you can download Airport Utility free from the app store, but do it on an ipad or macbook obviously if your iphone wont connect.

  • NurulAzhwar Level 1 Level 1 (0 points)

    I also is having this problem.. But unfortunately my phone inside setting for Wifi, i even cannot switch it on.. It always been off and could not turn it on at all. Please help me on this issue. I really hate this thing happened coz it will makes me exceed my data plan...

  • mrsdvn24 Level 1 Level 1 (0 points)

    thank u very much oberoak .. it did worked for me ..ur d best.

    oberoak wrote:


    try worked for my iphone 4s


    settings > general > reset > Reset Network settings.


    Message was edited by: mrsdvn24

  • dercument Level 1 Level 1 (0 points)

    Thanks for the great tip. It did not work by turning off my wireless printer but figured out that my IP cams were causing this problem. Swyched them off and my 4S is conneting like crazyyyy. Thanks again

  • brit_brit Level 1 Level 1 (0 points)

    I have also been having this issue and it did happen right after the upgrade. I have always been able to connect to my home and my work wifi.  I now can only connect to my work wifi if I am sitting right next to it, from my desk I can no longer (even though it is an option to join, it won't allow).  At home, I can no longer sit in my living room or be in my kitchen and connect, I have to be in the hallway near my computer room.  My husband has an iPhone 4, I have the 4s...his works fine and has had NO problems.  Me on the otherhand....I can't connect at any place that offers free wifi, yet he can.  It makes me so mad...I called Apple to get help and of course they want me to pay and I am not doing that...I should not have this issue.  I can guarentee that after my contract is up...I will NEVER have another Apple product as it ***** trying to find someone to help you.  I have tried ALL that I can that each person on every website has suggested, except for restore and I truly don't want to have to that as I am worried I wouldn't back everything up correctly.  I have come to a point of giving up...and just dealing with it...but it still makes me so mad.

  • LYoder Level 1 Level 1 (0 points)

    Thank you for re-posting!  This 'fix' worked for me as well.

  • kxae Level 1 Level 1 (0 points)

    The same here. Thanks.

  • brit_brit Level 1 Level 1 (0 points)

    I finally contacted apple on their website. They then set me up an appt at the apple store and when I went they tried connecting to wifi. The phone was shot and they gave me a brand new b/c I still had warranty.

  • jhemm Level 1 Level 1 (0 points)

    I think I am having a similar issue with the new update. I just downloaded the latest update and can not connect to wi-fi at all. In my setting the wi-fi option is grayed out. Any fix-it would be awesome

  • hui.tan Level 1 Level 1 (0 points)

    I also have the same problem as well...I am using Iphone4s now, even I restore my network or reset my phone, I still can't connect to my house wifi and even others wifi as well..


    Hopefully can solve it asap!!!