Previous 1 2 3 Next 416 Replies Latest reply: May 13, 2013 2:28 PM by LOtang
sander81 Level 1 (0 points)

I bought this week an iMac Mid 2011.

I have done every update from " software update", but i have an issue with the wireless connection.

Sometime the wi-fi connection freezes and internet doesn't work (ping with router fails). To solve I have to disconnect airport and re-connect.

The router wireless works (i have 4 pc + 2  mac + iphone, and i have this problem only with this iMac). In windows (bootcamp) wireless works fine.

Yesterday, when i opened Network Utility, opening the airport interface (en1) I had a kernel panic (this happened 2-3 times). So I reinstalled MacOsX.

Today I have the same issue with the wi-fi, but when i open network utility i have not kernel panic.


Someone has this problem?!


Solutions? Next week I'll call apple support to see if this is a known problem

iMac, Mac OS X (10.6.7)
  • rkaufmann87 Level 9 (55,283 points)

    You can call AppleCare today, they're open in the US on Saturdays however because you don't state where you're located I can't vouch for your country.


    You can try some fundamentals such as repairing Disk Permissions in Disk Utility, resetting the SMC and resetting the PRAM.


    It also could be a simple issue with the DNS settings your ISP is using. Macs can be sensitive to these, if you are not familiar with DNS setting please read MacWorlds DNS Troubleshooting article and then make the follow change:


    1. System preferences

    2. Network

    3. Click Advanced

    4. Click DNS tab

    5. Click + sign

    6. Add

    7. Click + sign

    8. Add

    9. Click OK.

    10. Exit System Preferences

    11. Try out your iMac and report what happened.



  • mwidmann Level 1 (5 points)

    I noticed a very similar problem with my new 21" iMac. It became a bit better after the EFI upgrade, but still I have ping timeouts to my Time Capsule. This doesn't happen with my MacBook Air or the old MacBook Pro that the iMac should replace.

  • sander81 Level 1 (0 points)




    I reset smc and pram, alredy tried to repair disk permission (i also reinstalled macosx )


    Then I changed DNS and disabled IPV6

    I noticed this problem happens 2-5 minutes after the boot

    I tried to ping my router without success, but i can see that during pinging in the "network utility" the interface is up with a IP but sent packets are always the same, packets received increase slowly (1 per second). no collisions and no errors in that window



    in the "console log" i saw these strange events:



    May  7 22:17:12 iMac Apple80211 framework[122]: Scan() error -3905 (Timeout)

    May  7 22:17:12 iMacApple80211 framework[122]: __performScan() failed (-3905)

    May  7 22:17:24 iMac Apple80211 framework[122]: Scan() error 16 (Resource busy)

    May  7 22:17:24 iMac Apple80211 framework[122]: __performScan() EBUSY, sleep 1 sec, try again

    May  7 22:17:25 iMac Apple80211 framework[122]: Scan() error 16 (Resource busy)

    May  7 22:17:25 iMac Apple80211 framework[122]: __performScan() EBUSY, sleep 1 sec, try again

    May  7 22:17:26 iMac Apple80211 framework[122]: Scan() error 16 (Resource busy)

    May  7 22:17:26 iMac Apple80211 framework[122]: __performScan() EBUSY, sleep 1 sec, try again

    May  7 22:17:27 iMac Apple80211 framework[122]: Scan() error 16 (Resource busy)

    and so on…


    any ideas?

  • rkaufmann87 Level 9 (55,283 points)

    I had another idea, take a look at the connections sequence in the Network Preference. I've included a picture of mine for an example. If you want the system to be on wi-fi that should be the top choice, if you want it to be Ethernet that should be listed at the top. Believe it or not those aren't random, you can change the sequence by clicking where I've indicated in the graphic and can easily have the order changed.


    Screen shot 2011-05-07 at 4.06.12 PM.jpg

  • TroyG Level 1 (5 points)

    Hi sander81 - Unfortunately I can't offer much help at this point in time, but I'm experiencing the same problem. My 27" 2011 iMac is frequently losing it's connection from my router.  I have 5 other Apple devices (Mac's, iPhone, iPad, Apple TV's) connected to the same router, and no issue with those.  If I Turn Off/Turn On the Airport, it magically reconnects, and everything works fine.  In 4 hours of using the iMac, it's done it about 6 times so far.


    I have the Console open, so if I do see something of interest, I'll let you/others know.  Same if I happen to find a resolution to the issue.

  • sander81 Level 1 (0 points)

    thank you for your help rkaufmann, but unfortunately changing that order don't solve the problem


    Troy, I have this issue only one time  2-5 minutes after the boot (imac 27'' like you).

    Do you use a router 5Ghz (wireless 802.11n) or 2,4 (wireless 802.11g)? I have a linksys e3000 but this problem happens in both configurations. At the end I think could be a driver/firmware problem with the new wireless adapter (with 3 antennas).

    If I'll have any news I'll update this thread, thank you

  • mwidmann Level 1 (5 points)

    I have a small update. It looks like the issues with the wifi are driver related. I Installed Windows 7 64bit in Bootcamp and tried all kinds of tests there. The network is very stable and no disconnect/connect issues.


    What I also discovered is that the room I placed my iMac in is not very well covered by my time capsule. The quality must still be fine as the other devices (macbook air, ipad2, iphone) don't show issues. Maybe it's related to power consumption or something like that.


    Screen shot 2011-05-09 at 06.35.28.jpg

    This is how it looks like. The RSSI should be higher as I understood, but it still should be fine and stable as it works flawlessly in windows.

  • TroyG Level 1 (5 points)

    Sander - very similar.  Happens once after reboot, and doesn't happen again.  Can fix he problem by cycling the AirPort off and then on.


    Oddly, I have a Cisco E3000 as well, though I've changed the firmware to DD-WRT, so hard to tell if it's related or not.

  • Ray Davis Level 1 (0 points)

    I have also just purchased a mid 2011 27inch 3.4Ghz i7 iMac and have a Wifi related issue, I orginally connected to an Apple Airport Extreme and all was well, I then put the iMac to sleep, when I woke it up I noticed that web pages in Safari kept timing out, including trying to get to my local ADSL routers admin web page. I then disconnected from the Apple Airport Extreme and re-connected, I still had the same timeout issue. I then disconnected and connected via wireless N to my wireless ADSL router directly, the performance/timeout issue then went away.


    I am therefore not sure if this is an issue connecting to the Apple Airport Extreme or any Wirless router, I have not applied the latest firmare update for the Airport Extreme but I have to the iMac.


    Not sure if this is related but in another thread I noted that I have also had what are possibly bluetooth issues where there seem to be keyboard and mouse inputs occuring that did not come from the corresponding keyboard or mouse. For example the volume being changed with the on-screen volume bar appearing and in Safari the web pages scrolling down. As I say this may not be related but I would be interested if you are seeing the same issue.

  • sander81 Level 1 (0 points)

    Very interesting Troy, I have DD-WRT like you in my linksys.  I'm not at home and I don't remember the version, but should be one of these: (or a Branslayer release).

    This evening I'll try with another access point or using ad-hoc with another mac

  • hardbase Level 1 (0 points)

    Got the same issue here in Germany (FritzBox 7270 and latest 27inch 3.4Ghz i7 iMac. Couldn't solve the problem yet. As TroyG said i could only handle it with cycling the AirPort off and then on. Hope Apple will fix it asap...

  • sander81 Level 1 (0 points)

    I tried with an old access-point (802.11g) only 2 times because I haven't time, but with that I have no problems

  • wifiguru Level 2 (240 points)


    What wireless router do you have ? Have you checked if there is a firmware upgrade for your wireless router ? What version are you using ?

    Have you tried updating to 10.6.7 on your iMac ?

    Can you also post the details in the kernel panic so someone here with more knowledge might be able to help ?

  • wifiguru Level 2 (240 points)

    Troy, what version of ddwrt firmware are you using on the E3000 ?

Previous 1 2 3 Next