Previous 1 2 3 Next 38 Replies Latest reply: Jan 13, 2013 12:14 PM by IPv6Freely Go to original post
  • jcspencer01 Level 1 Level 1 (0 points)

    i took it to apple with your post up and told them to do all of that.. still didnt work. should i try it again?

  • kplkumar Level 1 Level 1 (0 points)

    Want to let you know that the remote computer I am trying to connect to had 3GB switch enabled. I did this since I wanted Visual Sudio to use more memory than the standard 2GB.

    This prevented me from doing RDP.

     

    I am not sure if this helps. But I am assuming that you had not even got to this point... you still have trouble even establishing the VPN connection using Network Connect.

     

    If that is the case, I am afraid I know not what else to do. I am sorry dude.

  • IPv6Freely Level 1 Level 1 (0 points)

    Not sure why that earlier nonsense was already selected as the correct answer.

    Linc Davis wrote:

     

    That's a third-party VPN client. Contact the vendor for tech support.

    Well THAT is a worthless reply... this is not the 3rd party vendor's issue.

     

    This is a known issue with Apple and Java. It is detailed in Juniper KB2221: http://kb.juniper.net/InfoCenter/index?page=content&id=KB22221&smlogin=true

    The Juniper engineering team  has determined that this is a bug in Java 1.6.0_29 and the same has been reported to Apple. The Apple bug reference number is 10519204. You can contact Apple, by referring the bug number, for the latest status update.

    There are two workarounds:

    - First, your IT department needs to disable host checker until Apple fixes the issue.

    - The second is to connect to your VPN using Safari and launching Network Connect once connected.

     

    Feel free to flag my answer as correct, because it is.

  • kplkumar Level 1 Level 1 (0 points)

    Can you please my answer as correct? Thanks.

  • IPv6Freely Level 1 Level 1 (0 points)

    kplkumar wrote:

     

    Can you please my answer as correct? Thanks.

    But your answer wasn't correct as it didn't even offer a suggestion to the actual issue. This has nothing to do with RDP, and has everything to do with connecting to a Juniper SA/MAG using Network Connect.app on OSX Lion.

  • kplkumar Level 1 Level 1 (0 points)

    Hey IPv6Freely

     

    My message was a request to, mtoddb dated Oct 7, 2011 10:15 AM (in response to kplkumar)

     

    There were a few employees in our company who also had the same problem and used my resolution

    posted here, Aug 16, 2011 5:25 PM (in response to jcspencer01). Please see page 1.

     

    I also had the RDP problem and I mentioned that as a point of discussion in response to jcspencer01

     

    Cheers mate!

  • IPv6Freely Level 1 Level 1 (0 points)

    Yea, I don't think booting into 32-bit mode is a very good workaround.

     

    Just connect through Safari. Problem solved, until Apple comes up with a fix.

     

    My solution is the only correct one so far.

  • kplkumar Level 1 Level 1 (0 points)

    I could connect through any browser, it downloads and installs the NC client. After that, there is no need to use Safari or any other browser. You can launch Network Connect directly.

     

    Besides, there are posters in this thread for whom even Safari does not work.

     

    I am and few other employees are all using my workaround (even today), and as the post clearly says it's not just restarting in 32 bit mode.

     

    What I think is happening here, is the way Network Connect is configured in the servers.

    Perhaps we both are missing a scenario.

     

    And please mind you, this is not a race between who's answer is right. It's also about getting problems solved.

  • IPv6Freely Level 1 Level 1 (0 points)

    It is definitely how NC is configured. If host-checker is enabled, it fails with the errors in the original post.

     

    Again, this is a known issue, detailed in Juniper KB2221. There is nothing Juniper can do about it until Apple fixes the root cause.

     

    I'm certainly not missing a scenario.

  • kplkumar Level 1 Level 1 (0 points)

    host-checker enabled - it fails with the error above. This happened to me and I resolved it using the 32-bit restart method and some tweaking with Java plugins.

    Earlier, I spoke to Juniper and Apple, and they could not resolve it. Perhaps the KB2221 was published after.

    Anyway, it did start working using my workaround.

     

    host-checker disabled - it works. You mention that using Safari you can login. Whereas the fact remains that NC get's downloaded the first time and then on it can be accessed on it's own. Nothing to do with Safari by itself.

     

    I appreciate you pointed us all to this famous KB2221, and we acknowledge your help. It seem like you need this acknowledgement. So be happy now and leave this thread alone.

     

    Thanks again.

  • IPv6Freely Level 1 Level 1 (0 points)

    No need to get snarky.

     

    Yes, if you log into your VPN through Safari, it will launch NC and connect just fine.

     

    I'm well aware that after you connect initially, NC installs and can be run on its own. But with this bug, if you run Network Connect.app, the connection fails with the error in the original post. If you connect in Safari and allow it to launch NC, it will connect without issue.

     

    If you have anything useful to contribute, please feel free.

  • sxrxrr Level 1 Level 1 (0 points)

    I use 10.6.8 and Safari 5.1.2.  I have held off running the Java update because of this issue.  Apple won't communicate to me any status and we all know that Juniper is saying to wait for Apple to fix it.  I read that someone seems to have a functional workaround.  Can some clearly explain the workaround, please?  If it really does work I will give it a try.

     

    Also, is there any site where one can read the latest Apple status on a give problem number?  I have an Apple Developer ID yet I find no Apple site with that information.

     

    Thanks.

  • IPv6Freely Level 1 Level 1 (0 points)

    For me, the workaround is simply to log into your SSL VPN in Safari rather than Network Connect.app, and then launch Network Connect (if it doesn't launch automatically) from there. It's a pain, but it works.

     

    Also keep in mind this only matters if your SSL VPN requires hostchecker. If hostchecker isn't enabled, you'll have no issue.

     

    I don't know of any way to check the status of Apple fixing the issue. I hope it's soon, as I have a lot of customers running Juniper SA/MAG who this could potentially affect.

  • DougC174 Level 1 Level 1 (0 points)

    this appears to be fixed in the R33 release Apple pushed a few days back. I can now connect when running the application directly.

  • IPv6Freely Level 1 Level 1 (0 points)

    Confirmed.

     

    Java version 1.6.0_33-b03-424 now allows Juniper SSL VPN sign-in via Network Connect.app, rather than being required to launch via Safari.

     

    Thank you Apple for fixing this!