1 2 3 4 5 Previous Next 74 Replies Latest reply: Apr 22, 2014 4:44 AM by Schoey S Go to original post
  • 30. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    AUSSIESoph Level 1 Level 1 (0 points)

    I too had "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off." every minute as it randomly recognised then ejected my my WD passport - admittedly I did drop the WD passport which disconnected earlier that day.  Im running OS X 10.7.2

    After some serious anxiety I managed to work out it wasnt my external hard drive that was the problem - it worked fine on my desktop.

    After surfing for the fix, I fiddled and fiddled and in the last 30 mins, no eject problems (so fingers crossed it's the real fix).

     

    Utilities - Disk Uitilities - Select Macintosh HD - First Aid - Repair Disk Permissions

    (this is a snap of the log:

    Group differs on “Library/Java”; should be 0; group is 80.

    2011-12-31 10:43:35 +1100: Permissions differ on “Library/Java”; should be drwxr-xr-x ; they are drwxrwxr-x .

    2011-12-31 10:43:35 +1100: Repaired “Library/Java”

    2011-12-31 10:43:42 +1100: User differs on “usr/share/collabd/coreclient/locales/zh_CN.lproj”; should be 94; user is 0.

    2011-12-31 10:43:42 +1100: Group differs on “usr/share/collabd/coreclient/locales/zh_CN.lproj”; should be 94; group is 0.

    2011-12-31 10:43:42 +1100: Repaired “usr/share/collabd/coreclient/locales/zh_CN.lproj”

    2011-12-31 10:43:42 +1100: User differs on “usr/share/collabd/coreclient/public/locales/zh_CN.lproj”; should be 94; user is 0.

    etc etc

     

    After Permission Repair completed, I just clicked on the Passport drive and in First aid - Verify and repair.

     

    So far it is still looking good! Phew! Now Im dashing out to buy another hard drive to back up just in case!!

  • 31. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    stevefrommaidenhead Level 1 Level 1 (0 points)

    I have the same problems with my new iMac and 2 new 2Tb drives - if I disconnect the drives it's OK, as soon as I add 1 or both, I get the same message every few minutes - it's a Mac issue as I put the same drives onto my windows PC same cables etc and no problems??

  • 32. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    Adnan Kashmiri Level 1 Level 1 (0 points)

    Hi,

     

    I was facing the same issue with my WD 1 TB My Passport Essentials SE drive and below is my experience and hope it helps:

     

    - I bought the drive a few months ago and immediately installed the WD SmartWare software that came with the drive. I set up a security password on it and was facing the random ejects from day one. I tried everything and was finally annoyed to the point that i deleted the Smartware software from my MacBook Pro 17" and was using the drive without it. The problem went away.

     

    Today I decided to change the password I had set through the WD software and downloaded the SmartWare software to do so. And I have started facing the same problem again now.

     

    Therefore my conclusion is that it has something to do with the WD SmartWare software, and I even tried changing the sleep options inside SmartWare but it doesnt help.

     

    I hope this was helpful because it is annoying the crap out of me, that the drive keeps ejecting. I dont think WD is a bad brand, but this is a serious issue..

     

    Good Luck..

  • 33. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    Richard E. Cooke Level 2 Level 2 (220 points)

    You made a good start, but now you have to be methodical.

     

    i posted this a few months ago, its the general-purpose diagnostic procedure for electronic devices.  If you follow it, you will either figure out the true root cause on your own, or you will be able to post enough information for people like me to figure it out for you.

     

    If you want to find answers or get help (especially from me) then you have to do this, in order:

     

    - Google your drive make and model, see if anybody else is having the same problem. If you are the only person on the planet with drive "XYZ" with a problem then chances are you have a hardware problem in the drive, computer, hub, or cables (not necessarily in that order).

     

    - if there is a support site for the drive post a question there about your symptoms (and read/search previous posts). Again, if your the only person in the world with a problem...

     

    - Search this thread for you drive make (not model) to see if there have been other problems with their products (actually this is a good idea for a google search too). I tell clients to do this BEFORE they buy something  - "buyer beware"!

     

    - Do some experiments. Try the drive on other computers, different cables, no hub, different USB jacks. Try READiNG only small files, then large. Try WRITING small files, then large. Try it after it's been OFF overnight. Try it after the computer and hub have been OFF overnight. Try it with nothing else running on the computer. Change the drive format, does it matter if it's exFAT, NTFS, or OSX Journaled?

     

    - Post your symptoms and test results here. If you want help and not just platitudes and "me too"s you must include the drive make, model and any other potentially useful info like date of manufacturer, the disk drive make/model iniside. Go into System Profiler and grab all the USB info.

     

    - Check to see if the drive has the same USB chip ID as the two we have already found in problem drives. Googling the chip ID sometimes can tell you quite quickly if there is a problem and a fix.

     

    I know this is potentially a lot of work, I go through this process nearly weekly for clients. The problems change, but the process remains the same.

     

    The only "quick fix" is to find a solution or workaround with Google. I will spend a few hours reading every post even remotely related to a problem, looking for clues to the problem or a fix. In most cases a workaround is acceptable - it depends on how annoying the workaround is.

  • 34. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    Afrian Level 1 Level 1 (0 points)

    The problem solved, just uninstall WD SmartWare.

     

    Thanks Grendel.....

  • 35. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    JuliettaFaraday Level 1 Level 1 (0 points)

    I have the same issue -

    WD passport external hard drive

    Macbook Pro 13" OSX 10.6.8

     

    I've worked with the external drive fine until today. Yesterday I was doing heavy duty video saving and optimizing in imovie, and it worked fine, today, with no changes in anything, I keep getting the "The Drive was not ejected properly" message, as it ejects itself seconds after I try to connect it via USB.

     

    I have a lot of important files on there ... I really hope I can get it to work again! Tips most gratefully appreciated.

  • 36. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    JuliettaFaraday Level 1 Level 1 (0 points)

    I don't have SmartWare, and turning off the "put hard drives to sleep whenever possible setting" didn't do anything either. Rather worried ....

  • 37. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    JuliettaFaraday Level 1 Level 1 (0 points)

    @AUSSIESophe - I tried your solution, but I couldn't get the external drive to stay connected for long enough to repair. It ejects itself within a few seconds of connecting.

  • 38. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    rodosteo Level 1 Level 1 (0 points)

    Thanks Grendel. I followed your instructions. Unistalled the WD software and reformatted the drive. All good now.

    I am on a 13" MacBook Pro running Mac OS X 10.6.8 and using a WD My Passport 500GB.

     

    Thankfully the drive is new and I have just started to use it. Obviously this solution will not work for those who have stuff on the drive that they want to keep as the reformatting does delete everything.

     

    Just for the record I contacted WD support before finding this thread and they told me it was a problem with my MAC and haven't replied to any emails I have sent since.

  • 39. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    ThumbDriveMan Level 1 Level 1 (0 points)

    Hello everybody!

     

    In my experience, disabling the screensaver seems to keep the drive from ejecting on its own. You guys might wanna give it a try too.

  • 40. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    ThumbDriveMan Level 1 Level 1 (0 points)

    Update: It's the WD smarware software that seems to be the culprit. I uninstalled it and the problem is solved for good. There is no need to format the hard drive.

  • 41. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    tingotanca Level 1 Level 1 (0 points)

    Not that I don't believe you, but what about those of us who don't have, never had that WD stuff? To me it's still a interaction, an unhappy one at that, between hardware, software and connections (see my latest post in this respect: https://discussions.apple.com/message/19152554#19152554)

     

    Glad you've got it solved, though.

  • 42. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    benttop Level 1 Level 1 (0 points)

    I've just finished reading dozens upon dozens of messages in this thread and several others. To a person, those concluding they have solved it and it is "xxx" fail to see that others have the same problem but do not have "xxx" in their systems.

     

    I see two common denominators in all of this. One is USB or Firewire connections. The other is Time Machine. It took me a while to realize it, but my problems here started when I reconfigured Time Machine to include my Seagate GoFlex Pro drive. I had been using the Seagate drive for almost a year without any such issues. At that point I was using Firewire, and not having a second cable to try, I switched the GoFlex Pro to USB. It still randomly ejects. Thus those of you who have concluded it is a WD software issue are probably in for a rude surprise one of these days.

     

    One thing I have NOT seen here or in any other thread is anyone complaining about this error with a Thunderbolt drive. I'm thinking this might be a fairly significant observation, but perhaps I've just missed it. I've had a Promise 4TB Thunderbolt drive connected to my Mac Mini Server for over a year and it's never spontaneously ejected. And I now have a G-Raid with Thunderbolt 4TB connected to this Macbook Pro and it also has never ejected, even though the Seagate GoFlex continues to blink out every day.

     

    I'm going to pick up a second G-Raid Thunderbolt drive and move all the files off of my Seagate. I can always repurpose that drive somewhere else. If my suspicions are correct, my problems should disappear. If I'm wrong, well at least I'll have more storage space.

  • 43. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    benttop Level 1 Level 1 (0 points)

    OK, replying to my own post here, for an update.

     

    I've moved all of my data to a G-Tech Thunderbolt external drive and disconnected the Seagate GoFlex drive (USB). Two days in and no disconnect notices.

     

    Of course I changed several things in this transition - I changed drive manufacturer, which means the communication to the drive is different right off the bat. But the new drive communicates via Thunderbolt, so there's another difference, and the new drive requires no extra software, so there's another factor. Naturally I had to reconfigure Time Machine to back up the new drive instead of the old one, so there's a "touch" as well.

     

    The good news is I'm 48 hours in and I have not seen the eject message. I'll believe it's permanent after a couple of weeks, but things are looking up.

     

    My theory is that there may be an issue with a combination of Time Machine, USB/Firewire and 3rd party software. That holds water when you compare to the variety of folks here who have entirely different HDD's but found a solution by removing the driver software or shutting off Time Machine. There it is.

  • 44. Re: External Hard Drive Randomly Ejects From MacBook Pro - "The Disk Was Not Ejected Properly"
    tingotanca Level 1 Level 1 (0 points)

    Yes, although... not using TimeMachine nor any special driver software here – just plugin LaCie Firewire drives and USB drives and keys from a variety of manufacturers.