Previous 1 8 9 10 11 12 Next 379 Replies Latest reply: Aug 18, 2014 11:43 AM by dbreakey Go to original post
  • Eitetsu Oomoto Level 1 Level 1 (0 points)

    Hi forks,


    I have exactly same trouble for printing. I got the message, "D [24/Jun/2011:22:36:10 +0900] [Job 140] printer-state-message="/usr/libexec/cups/backend/lpd failed"


    After I have recovered (copy) the file /usr/libexec/cups/backend/lpd from another Mac still running 10.6.7, the printing to Xerox DocuPrint C3200A become fine.


    Currently, the state of the folder "/usr/libexec/cups/backend" on my Mac Pro is as following:

    sh-3.2# ls -l

    total 3016

    lrwxr-xr-x  1 root  admin       69 Apr 20 18:47 HP-Fax -> /Library/Printers/hp/Fax/

    -rwxr-xr-x  1 root  wheel   122384 Jun  8 08:53 bluetooth

    lrwxr-xr-x  1 root  wheel      109 Apr 20 18:47 canonijnetwork -> ../../../../Library/Printers/Canon/BJPrinter/Plugins/BJNP/canonijnetwork.bundle /Contents/MacOS/canonijnetwork

    -rwx------  1 root  wheel    57344 Apr 30 07:45 dnssd

    -rwxr-xr-x  1 root  wheel    54880 May 24  2010 epsonfirewire

    lrwxr-xr-x  1 root  wheel       68 Apr 20 18:45 fax -> ../../../../System/Library/Printers/Libraries/Fax/Contents/MacOS/Fax

    lrwxr-xr-x  1 root  wheel        3 Apr 20 18:45 http -> ipp

    -rwx------  1 root  wheel   106096 Apr 30 07:45 ipp

    -rwx------  1 root  wheel    93024 Jun 27 19:54 lpd  <-- it is from 10.6.7

    -rwx------  1 root  wheel    93024 Apr 30 07:45 lpd.orig <-- it is original in 10.6.8

    lrwxr-xr-x  1 root  wheel        5 Apr 20 18:45 mdns -> dnssd

    -rwxr-xr-x  1 root  wheel    61008 Oct 26  2010 riousbprint

    -r-x------  1 root  wheel  2796752 Apr 28 09:26 smb

    -r-xr-xr-x  1 root  wheel    66576 Apr 30 07:45 snmp

    -r-xr-xr-x  1 root  wheel    79328 Apr 30 07:45 socket

    -r-xr-xr-x  1 root  wheel    91792 Apr 30 07:45 usb



    I guess the cause of this trouble exists in dynamic libraries, which are the basis for 10.6.8.

    The following is the references for dynamic libraries in lpd.orig and lpd.

    sh-3.2# otool -L lpd.orig


              /usr/lib/libcups.2.dylib (compatibility version 2.0.0, current version 2.8.0)

              /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundat ion (compatibility version 150.0.0, current version 550.42.0)

              /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/System Configuration (compatibility version 1.0.0, current version 293.8.0)

              /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

              /usr/lib/libresolv.9.dylib (compatibility version 1.0.0, current version 41.0.0)

              /System/Library/Frameworks/Security.framework/Versions/A/Security (compatibility version 1.0.0, current version 55002.0.0)

    sh-3.2# otool -L lpd    


              /usr/lib/libcups.2.dylib (compatibility version 2.0.0, current version 2.8.0)

              /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundat ion (compatibility version 150.0.0, current version 550.42.0)

              /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/System Configuration (compatibility version 1.0.0, current version 293.6.0)

              /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.1)

              /usr/lib/libresolv.9.dylib (compatibility version 1.0.0, current version 41.0.0)

              /System/Library/Frameworks/Security.framework/Versions/A/Security (compatibility version 1.0.0, current version 37594.0.0)



    I think that the version of the dynamic libraries used in /usr/libexec/cups/backend/lpd is different a little from 10.6.7 and 10.6.8.


    I can't investigate this glitch any more. It is Apple's duty.



    Eitetsu Oomoto from Japan

  • marshalfrombeverly hills Level 1 Level 1 (0 points)

    It is so frustrating when an update actually has a detromental effect. Ahrrr

  • JohnnyM28 Level 1 Level 1 (0 points)

    This solution worked for my system (Xerox Docucolor 242).  I removed the printer, replaced the 4 backend folder files with files from another Mac in the office that had not been updated, repaired disk permissions and restarted.  Back to printing.


    You would think someone would have tested this update with Xerox printers.  Quality control must either be in a big hurry or they're just not on the ball.

  • Mike Benns Level 1 Level 1 (10 points)

    Thanks all for helpful hints on here... finally sorted it using IP printing. However this is not a long term solution. Apple, please sort this asap!!

  • Reinhard Arnhold Level 1 Level 1 (10 points)

    Hi sames problem at my side:


    did the combo update

    using IP printer

    Konicaminolta magicolor 4650DN


    I'll try to restore cups directory via Timemachine thsi evening.

  • stuartfromyork Level 1 Level 1 (0 points)


  • Lykeios Level 1 Level 1 (0 points)

    I made an automated patch for this issue.

    This patch automatically applies solutions suggested in this thread.

    Try this :


    If you want to know what this patch does, open this app with AppleScript Editor.

  • PrepressGuy Level 1 Level 1 (0 points)

    Thanks, everyone. Replaced ldp file and I'm making money again. You guys saved me.

  • rafavalles Level 1 Level 1 (0 points)

    Lykeios I hope you can help me out. I do run the patch you suggested but now I dont get Paused, I just get Conecction Atemps, but from all the Printers even the ones that do work, hope you can help me out.  I just cant find the paths you mention


    Is like you were using some kind of Windows Explorer path bar


    I dont know hopw to do that on my iMac


    Hope you can  help me fx it with out reinstall OSX and TimeMachine

  • Chanfan98020 Level 1 Level 1 (20 points)

    Lykeios, nice script (although I would of course suggest anyone trying it verify it's contents for their own). Replaces the four suggested files, and I can confirm it resolved my particular issue (Bonjour queue to Xerox Fiery).

  • john slavin1 Level 1 Level 1 (70 points)

    Lykeios:  Thanks so much.  Ran the script and it solved the problem.  Don't know if it's necessary, but I first reset the printing system,  then applied the script, reset the printing system again, restarted the Mac and then added the printer back in.  Worked like a charm.  Incidentally, I had brought in the dnssd file from a mac at home that I hadn't updated because the log indicated that was the problematic file, but it didn't help, so obviously one of the other files was also problematic.  I am using Bonjour with a Toshiba e-studio 450.


    John S

  • kthersh Level 1 Level 1 (0 points)

    I'm in the same boat, one of my computers has been fixed, but now on another one I get errors that all printers won't work even the one's that would before. Is there a way to reset the whole backend folder?


    Computer that fixed is an imac running 10.6.8, computer that won't fix is a mac mini running 10.6.8.

  • ostrichtom Level 1 Level 1 (5 points)

    After installing 10.6.8 on my 2011 MacBook Pro, I, too, had the printing problem - my Canon PIXMA MP990 would time out after each print. I print to it wirelessly. I was uncomfortable replacing a file in a hidden System folder, so I tried the other suggestion somewhere on this posting. I went to the Print & Fax pref pane and CTRL-clicked on the printer. I then selected Reset Printing System. I then had to reload the printer and reset its paper handling and ink preferences because the original ones had been deleted. However, now my printing is running is it did before the 10.6.8 update. All this is using Apple's own method of fixing, rather than applying a kluge.

  • kthersh Level 1 Level 1 (0 points)

    Well an employee here replaced the whole backend folder rather than the four files within discusssed earlier, would it be possible to replace the whole backend folder from a different computer that is still on 10.6.7, or is there a way to reset it back to normal somehow? Thanks.

  • rafavalles Level 1 Level 1 (0 points)

    Im sorry, but I never neede to go on the system files before since I switch to Mac 9 years ago.


    I run the Script some of the users kindly upload, but It didnt work in my case. Have to Restore from System Disk and Time Machine, but Im still on 10.6.8 problem, Paused.


    I see some other users of Docucolor 242/252/260 have restore from Backups earlier of June 25. I want to try that fix, but honestly I dont see files the way you do, I dont know if its because my system is in Spanish.


    Im attaching a view of my folders I hope someone can tell me how to do it.


    I dont see things like /usr/libexec/cups/backend



Previous 1 8 9 10 11 12 Next