Previous 1 13 14 15 16 17 Next 250 Replies Latest reply: Jan 18, 2014 3:15 PM by mrhmm Go to original post
  • tashi5445 Level 1 (0 points)

    How come Apple company is not solving our problem. I called them many times but they never solved my sleeping issue.

  • Simonron Level 1 (5 points)

    ...because they think it's been answered...

    ...several posibilities:

         Something in the print buffer

         Internet sharing enabled


    Clear your buffer and turn off internet and possibly bluetooth sharing and see if that helps.

  • buttonbag Level 1 (0 points)

    Hi all,


    This is a new feature in lion. It happens when you have an external display hooked up to your macbook and switched on and the mag safe is connected. I like this because I can now connect it to and hide it behind my TV when I'm at home and control it with the bluetooth keyboard and magic trackpad from the couch across the room.


    If you need it to go to sleep mode, just turn off the external display while the lid is closed or unplug the mag safe.


    Message was edited by: buttonbag

  • Anic264b Level 1 (20 points)

    Hmm… My computer has this issue but I can't either leave the internal display alone nor unplug the magsafe connector. But… wait… perhaps it's because it's a Mac Pro?

    So, no, this issue is not (or, at least, not only) related to an external display connected.

  • Markosys Level 1 (0 points)

    Using pmset -g worked brilliantly to identify the 'imposing' process.  In my case, it was a print job mistakenly queued to a shared printer that was offline.  Deleting the print job restored my Mac's ability to slumber.  Thanks!


    MacBook Pro 15-inch, Early 2011

    Mac OS X Lion 10.7.4 (11E53)

  • Mentel Level 1 (0 points)

    Thanks Markosys, pmset -g worked for me. I realised that my problem was created by "boom" an audio booster.


    Because when my mbp 13" goes in sleep, when I get back from sleep, the audio does not work, like boom frozen, I have to ALT-CLICK on the audio icone and click headset.


    When I did pmset -g I saw that my displaysleep was imposed by pid 141, which was /usr/sbin/coreaudiod , by ALT-Clicking the imposing disapeared and sleep worked again.


    Here we go

  • Romowest Level 1 (0 points)

    This worked for me from an early post....


    Called the tech support line and this is what ultimately worked for me. Caveat emptor:


    1) Trash this folder


    Macintosh HD > Library > Preferences > SystemConfiguration


    2) Re-boot


    3) Now sleeps and wakes OK (so far!)


    4) Empty trash"

  • ApexRon Level 1 (0 points)

    I now have OS 10.8.2 and the same problem exists as in the prior release.


    However, my issue is not caused by a defect but by an oversight in Apple's usability requirements for OS.


    I have an external display for my MacBook Pro that is used as a second (not mirror) display. The Apple requirements assume that if I have a second (not mirror) display I must also have an external keyboard. Therefore, when I close the MacBook Pro I must want to use the second (not mirror) display as a primary with my external (non-existent in my case) keyboard. Consequently the MacBook Pro does not sleep unless I use the OS pulldown or keyboard keys to force it.


    Had the Apple requirements people the proper foresight they would written the requirements such that an option would be added to System Preferences that if I checked a box, the MacBook Pro would go to sleep when the lid was closed.

  • dsmbp Level 1 (0 points)

    thanks a lot, solved my problem.

  • Mortfell Level 1 (0 points)

    Using pmset -g worked for me, but

    If you prefer to NOT use the terminal, for "pmset -g" this fellow has created a simple graphical program that tells you the name of any process preventing your mac from sleeping.

  • mrhmm Level 1 (0 points)

    Breaking News I found a Solution!


    I have a Mac Pro 1,1 that does not have a wifi card nor Bluetooth. The issue I am having is loosing my Internet connection after waking from sleep. My network preferences indicated the ethernet cable was unplugged when I know that wasn't really the issue. I was convinced this had to do with Lion because it didn't occur in the previous operating system.


    Here is what I did to prove my case.

    1. 1) I installed a new disk image of Lion and checked if the Internet would drop after sleep. Sure enough it did.
    2. I plugged my Internet connection directly to the computer instead of going through my router. That didn't stop the issue.
    3. I did every recommendation on the Internet I could find. That was unsuccessful.


    What Worked?

    1. I downgraded to the original 10.4.7 on another internal hard drive that was being used. During the install I received an error and operating system failed to install.
    2. After researching on the WWW, a  Mac user mentioned that you should unplug your "FireWire drives" before installing. Sure enough, the install completed succesfully after removing my WD FireWire external hard drive. Just as I suspected there were no issues with the Internet dropping after waking from sleep, it worked perfectly!

    So is Lion to Blame?

    Just as I was getting ready to officially point the finger at Lion, I decided to run one more test.

    1. Start up Lion without my FireWire hard drive connected.
    2. Put the computer to sleep and check to see if the Internet will drop anytime  with the next 24 hrs.
    4. Celebrate like a hero, the problem is gone.



    In my opinion this issue is probably still related to Lion since it seemed to pop up on the radar just after I upgraded to this operating system. My theory is perhaps communication to my FireWire hard drive is delaying the wake from sleep function and as a result causes the handshaking opportunity to regain the tcp/ip connection to fail. Sort of like missing the bus!


    P.S. I hope someone who is more technical wouldn't mind looking into this further. Perhaps understanding why my FireWire drive causes the Ethernet connection to drop will shed light on this long lasting plague. I'm also curious how I can fix this issue so I can keep my hard drive plugged in. Thanks for any help.

Previous 1 13 14 15 16 17 Next