Previous 1 2 3 Next 132 Replies Latest reply: Sep 4, 2015 4:02 PM by travel4life08
Roger OSX Level 1 (0 points)

I ran top -o cpu and I see:

 

646- AGAdminServi 100.1 05:44.39 7/1   1    76   N/A   N/A    N/A    N/A

 

I tracked this down to be Citrix.. but.. I umm.. don't have citrix/didn't install it

 

this was never a problem until I installed Lion

 

Anyone know how to literally just tear this out of my system(wherever it is hiding)?

 

I read other posts about /Library/Application Support/Citrix.. but I dont have that folder etc

 

I basically can't use my MBP anymore due to this


MacBook Pro, Mac OS X (10.7)
  • Roger OSX Level 1 (0 points)

    Welp, I solved it after I posted this.. so will provide solution:

     

    sudo launchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist

  • mahbool Level 1 (0 points)

    Thanks you solved my problem!

  • jimish Level 1 (0 points)

    Roger OSX,

     

    I'm having the same issue, could you explain your solution to those of us less savvy?

     

    Thanks

    jimish

  • BZ Level 1 (25 points)

    This worked great. Thanks for figuring it out.

     

    BZ

  • Roger OSX Level 1 (0 points)

    For some reason (I don't know why yet).. this AGAdminService "citrix agent process" is being loaded as a Admin User Installed System Daemon (I think that is right.. )

     

    That command up above, will basically remove the file that OSX uses to "start it up, and keep it running"  (launchctl is a tool for modifying these semi-invisible/system wide processes)

     

    sudo executes the command "as the root/admin user".. so you'll be prompted to enter your password

     

    If you do not use citrix and yet you are having this problem, it is a "very safe" thing to do.. it technially isn't even deleting stuff.. just disabling that item for starting/running

  • jimish Level 1 (0 points)

    Gave it a try and it worked! Many thanks

  • jkuzmick Level 1 (0 points)

    Thank you! I was killing myself trying to figure it out.

  • rafaelsantoni Level 1 (0 points)

    This is a good thing to know. My CPU temperature dropped almost instantly once I unloaded the process. However, I do use the Citrix Access Gateway, which is what this is for, and now I can't run it. AG provides much needed network resources access for me via the VPN.

     

    Does anyone here know if unloading it permanently disables it or can I reload it?

     

    I checked the MAN page for launchctl and it seems like just like the unload option, there is a load option. Even if I "reload" it, my Access Gateway won't run.

     

    Any ideas folks?

  • DLH2 Level 1 (0 points)

    I have installed Lion and my Citrix Access Gatway (version 2.0.1 (72) won't connect:  Cannot log on at this time, SSL Error: Peer Hostname mismatch. 

     

    Anyone able to access Citrix Gatway VPN using Lion?  I have to get on my VPN.  any ideas?

  • MarkOnMac Level 1 (0 points)

    Thanks so much. My MacBook is now running cool and efficiently. I can now go on to explore Lion.

  • AndyR:CH Level 1 (0 points)

    I had the same heat/performance problem today with my Mac Book Pro 13" Early 2009. Installed Lion yesterday. Spotlight indexing was successfully done yesterday. Today there were only iTunes on standby, Mac App Store and some Finder windows open..

     

    EDIT: Sorry this post was landing in the wrong thread..

  • BeatriceK Level 1 (0 points)

    Thanks!

    My MBA was really noicy and burning hot. Now it is quiet and cool again.

  • jaredcoe Level 1 (0 points)

    Same thing is happening with my 2007 Core2Duo.  I checked the activity monitor and found that Finder was using 90-105% of the CPU.  After shutting finder down it cooled off and the fan slowed down.  Weird.

  • maartenfromvianen Level 1 (0 points)

    Thanks, both my MBPs are working fine again!

Previous 1 2 3 Next