Previous 1 2 3 4 5 6 Next 132 Replies Latest reply: Sep 4, 2015 4:02 PM by travel4life08 Go to original post
  • Valantine Level 1 Level 1

    I still don't get what you wrote down can you please write down the process of this in a form for a dummy. THX

  • Wraith_Commander Level 1 Level 1

    Terminal does not obscure your password with asterisks, nor does it print the characters. You type your password in, the field will still be blank, hit enter.

  • Wraith_Commander Level 1 Level 1

    ronald272 wrote:


    Please help. First I apologize for asking these questions, as I am a technical novice and new to apple. I installed Lion and immediate had a cut in the batterly life and my computer runs hot. I do hav citrix plug in installed and noticed under activitiy the "AGAdminService MAC" is running at 100%. I went into the applications folder and dragged both the Citrix plugin icon and folder to the trash can. No change. I then went into the Finder file but things look different. I don't see the normal items I use to see, like my hard drive, movies, photo, etc...Is this normal with Lion? All I see is : All files, Air drop, desktop, my name, applications, documents and IDisk.


    I was looking to try go to the directory/library/launchdaemons to delete but cannot find. Did something change? Am I looking in the wrong place?


    So should I launch terminal and use the process described in the links? Will this disable my ability to use citrix to connect to my work? If this is what I should do, can someone give me the exact text to paste in? Do I start with

    "sudo lauchctl unload -w /libray/launchdaemons/com.citrix.adadminservice.plist"? Do I include the "sudo" part ?


    Any help would be greatly appreciated. 

    Ronald, your finder is hiding the system library by default. It's supposed to prevent people going in and deleting files they shouldn't.


    You can unhide your user library with chflags nohidden ~/Library

    Also, Finder is set to obscure the hard drive. You can find this by going into Finder->Preferences and hitting the Sidebar tab and selecting your hard drive.


    I would check to see if there's an update available to Citrix.

  • christiancee Level 1 Level 1

    This is what I did and I hope that it will help those without the Citrix file. Maybe there's another way that works for you. We just want our macs to work again.


    Hi, my MBP has all the symptoms after installing OS X Lion, Battery takes 6-7 hours to charge, runs out in an hour after fully charged, got super hot, not charging but only starts charging after 1-2 mins or more. Fans running full speed while just running safari that drains the battery fast. My system does not have "citrix" problem. So I called Apple support and they suspected there's inconsitency with the "battery full Charge Capacity and cycle count". It turned out to be normal, not sure why.


    Anyway, they told me to erase and reinstall Snow Leopard then Lion after backing up my data in time machine, I did that and it and restored from Time Machine. After reinstalling Lion everything seems normal. So I restored all of the 600GB data from Time Machine (took about took about 8-9 hours), I deleted some of those "ultilities, tuning, management" apps which I have downloaded before and now, it is as quiet as it once was.


    Good luck!

  • ronald272 Level 1 Level 1

    Still working?  If so, is there anyway you would detail the exacts steps you took to erase and reinstall? Did you back up using Time machine first, then format your harddrive (if so how), then place the original disk in and turn on computer, install SL, then reinstall lion, then somehow reinstall from Time machine?


    Any help would be great as I need to do the same thing

  • eplaya Level 1 Level 1

    Hi Roger, I followed your advice and it wirked quiete great. But is had an important impact on the VPN and blocks Mail from sending mails when VPN is on. I would like to rever the command or reinstal AGAdminservice. Can I ask you id you have any idea where to get it?

    Thank you very much in advance!


  • Kees de Wit Level 1 Level 1

    Terminal does not provide feedback of any kind on entering passwords. When prompted, just punch in your password and hit enter.

    If a new line appears with your username in it and you can input more text/commands, you succesfully removed the file. If something went wrong, a line of text describing the error will appear.

  • christiancee Level 1 Level 1

    Hi Ronald, maybe you would want to backup everything then uninstall or delete those apps that you suspect which are not compatible with Lion first and see how the computer reacts? Or try resetting the SMC first or any solution listed here by these great users whom spent time reply. As I do not have Citrix, this is my option. Please read thru before trying any of these. Hope it helps...


    Reinstalling everything takes a long time but if you still wanna give it a try, please backup your most recent data with Time Machine before you try-


    1 - Reinstalling Lion (with your current running OS X Lion)

    Shut down your computer

    Turn it on again while holding on the "option" button.

    You will see 2 options to boot from - Your hard disk & Recovery disk.

    Click on recovery, you will get options like

    • Restore from Time Machine
    • Reinstalling OSX Lion - This will bring you to "Download Lion" window. (Which you will have to dl again)


    2 - Reinstalling Snow Leopard

    If you still want to reinstall SL, I think you will need to erase your HDD (from disk utilities and start installing LS from DVD that came with your computer thereafter.

    After installing LS, monitor if your ststem is ok.


    3 - Reinstalling Lion (downloaded copy from appstore or a fresh copy you have saved before)

    Download Lion from App Store again if you do not have a copy from the last download.

    If you want to create a bootable OS X Lion onto a thumbdrive so you don't have to always dl Lion from appstore, see here.

    Then install Lion as normal.


    4 - Restoring data from Time Machine

    Shut down and turn on your computer, while holding on "option".


    Restore from Time Machine you last backedup.


    5 - If the problem persist, maybe it's some of the apps causing problems, especially those "system tools, ultilities apps from third party)



    While you are on Snow Leopard, Time machine does not work if you have backed up from Lion. (Told by Apple Support).

    I am not a technical person, use this method which have worked for me at your own risk.

    600GB of data (more than 6 hours to restore from Time Machine)

  • Forti-4T Level 1 Level 1

    Hi there Roger,


    1000 times thanks, you saved my day, my life an probabbly my MB!!! A while ago I tried out Citrix on SL for testing purposes just to reach my business mails by private MB and after upgrade to Lion I realized, whatever I did, even when I did nothing, my fan speed was at 6200rpm and CPU temperature was around 80°C..... Didn´t know that it could freaking Citrix bothering me with that.....

    After checking activity control and googling that AGAdmin -thing I found in the activity monitor I tried out your solution and here we gooooooo: WELCOME BACK to a quiet life with my MB!!!! I just dropped my Mickey Mouse Ear Protection!!!


    Thank you soooooo much!!!!!!


    BTW: CPU temperature went down from above 80°C to 53°C through that....CPU usage is down 3-5% from 51% before! I´m so unbelievably happyyyyy! Thanks Thanks Thank!!

    I still can´t believe there was a citrix process running, although I didn´t start Citrix at all....!!

  • ronald272 Level 1 Level 1

    Could you tell me exactly what you did to correct the problem? Also how do determine CPU temp? Lastly, assuming you did something with citrix does it still function?

  • Forti-4T Level 1 Level 1

    Hi Ronald,


    I installed Citrix a while ago just for checking my business mails with my private MacBook. After getting an iPad I didn´t need my MB anylonger but kept Citrix still installed. After upgrading Snow Leo to Lion I realized that fan problem, which I couldn´t explain to myself until yesterday. I downloaded iStat (freeware) to monitor major system performances. iStat is an app you can install on your dashboard. I just told me, that CPU temp was always very high and that CPU usage was over 50% in general although no intensive programms were running. So I startet the OS internal activity monitor and found that AGAdmin process in system processes. I googled it and found this forum. I tried out that sudo command for terminal and just copied Rogers command for pasting it in terminal, after that it just added my login password for the MacBook and here we go. Process was killed, CPU usage went down, fan speed either!

    I can´t tell you if Citrix is working anylonger, as I completely removed it from my system as is is absolutely unneccessary for me on my private MB. So maybe try it out before by cloning your working system with CCC (Carbon Copy Cloner) before you kill the process. If there is a problem for you afterwards you can easily backup to your old system by the cloned image of CCC.


    Hope that helps so far. Best wishes and good luck!


  • pier paolo bertelli Level 1 Level 1

    Solved for good, downgraded to SL. Fans quiet and double lenght battery.

  • Xankyard Level 1 Level 1

    I totally agree, please provide step-by-step instructions on how to go through the command process


    After launching the terminal, do I first enter this [one command line]:

    sudo launchctl unload -w


    And then this [the second command line]:



    OR should the "-w" be attached to the "/Library/..." or what?
    I just don´t get it, please help!

  • xwitek Level 1 Level 1

    Great, thanks...

  • SaxDaddy Level 1 Level 1

    Roger OSX,

    Thanks for this tip.  It worked for me as well.  The pecular thing is I too noticed the AGAdminService was hogging up the, ummm, "lion's share" of CPU (sorry).  But I never installed the Citrix Access Gateway client.  I did install the Citrix Online Plug-In version 11.2 which we use to provide Windows published apps to Mac users.  I just tested it and my Citrix published apps worked ONLY when I switched the client to use Java (downloaded from the Apple support site) instead of the native Citrix client.  The Java client is slower and has less functionality but it does work.


    I'll forward your solution and my discoveries to our Citrix Support Engineer for review and update this post with any relevant info. 



Previous 1 2 3 4 5 6 Next