Previous 1 2 3 4 Next 2,670 Replies Latest reply: Apr 23, 2014 2:58 PM by ElJefeGrande Go to original post
  • rtmns7 Level 1 (0 points)

    Applecare trick


    Restart computer without power cord hold down:  "command" "option" "P" "R" 

    Wait until you hear the 2nd chime then relase this fixed my problem until I moved to a different location with a differet router

  • nipper123 Level 1 (0 points)

    I saw this Lion bug in the 11A511 developer releases on a 2008 MBP and reported it to Apple Engineering then along with a bunch of test files they requested—was hoping it would be fixed before the GM release but seems not. What sometimes works for me is:


    1. Delete plists related to airport/wifi in Preferences.

    2. Switch wifi on and off from within the Preferences Network pane not from the desktop wifi icon


    YMMV but this has worked most times for me.


    Hope the 10.7.1 release will put this to bed.

  • paul246 Level 1 (0 points)

    Looks like I spoke too soon. Back to it's old tricks. This is really odd...tell me if I'm wrong here, because i might be...should my ip address be different every time i connect? When i manually put in an ip i wrote down MONTHS ago it seems to work fine for a bit (until it eventually slows down and shuts off altogether) but when it does things automatically its a different ip, and wont connect at all. What gives?  For the people saying this is new to Lion it definitely isn't.  From what i've seen on my extensive reaearch it's been happening to people gradually since the 10.0.2 "upgrade".

  • nipper123 Level 1 (0 points)

    BTW, there is also an airport plist in /Library/Preferences/System Configuration 

  • andyberlin Level 1 (0 points)

    Same problem here.

    After installing Lion on my 2010 MacBook Pro last night it seemed to work fine.

    Did the Lion install on my iMac 2009 this morning and since then Wifi is behaving weird on BOTH computers.

    Dropping connections, slowing down, iChat sometimes takes forever to connect (if at all).

    Hope this is getting fixed soon...Annoying.

  • jdcliff Level 1 (0 points)

    Exact same issue!  I've installed Lion on my 2010 MBP with not issues, but when I installed it on my aluminum uni-body late 2008's a no-go.


    It's all shiny and new looking, but I can't turn Wi-Fi on.  I've deleted .plist files and reset my PRAM and other such suggestions with no luck yet. 


    Am I missing anything?

  • sserschens Level 1 (0 points)

    I have similar wifi problems. When I put my MBP to sleep and wake it up WiFi doesn't work. I have to turn WiFi off and back on to get it to work.

  • jdcliff Level 1 (0 points)

    I can't even get Wi-Fi to turn on.  It just freezes!

  • jasmelthomas Level 1 (0 points)

    This seems to be working for me:


    Open System Preferences -> Network

    Click the little gear drop down and choose Set Service Order

    Make Wi-Fi be the top

    Click Bluetooth PAN and then choose Make Service Inactive in the gear drop down button


    Of course if you need to use Bluetooth you can try leaving that on. Maybe it's just having Wi-Fi be the top of the service order.

  • rlovegreen Level 1 (0 points)

    After upgrading my early 2008 MBP to Lion, I also couldn't even get WiFi to turn on.  Tried from the status bar icon, network preferences...nothing.


    I shut down and restarted the machine a couple of times and it started working.


    No explanation, no error, just wouldn't turn on.


    You might try a couple of shutdown/restarts if you haven't already.

  • Carles from Barcelona Level 1 (0 points)

    Hi every one,


    Abast is the problem!!! I uninstall Abast and everything ok. Is not sufficient disable Abast is necessary uninstall.


    Thank you for your help!!! and sorry for my English, I'm from Catalonia (Barcelona)



  • ligiateres Level 1 (0 points)

    Hi and thanks to whoever say it was avast!! i had been having the same problem with the wifi since I installed the Lion 2 days ago and talked to Apple and they didnt know what was it. I just UNISTALL the Avast as he said u need to unistall it and automatically my wifi is back and running!!


    good luck to the rest



  • Reboooot Level 1 (0 points)

    Sorry to say no avast on my machine and still no wi-fi. I spent a lot of time on the Abobe site and there are lots of people talking about the Java Runtime I wonder does Avast use that as well as Adobe?

  • galmeida-us Level 1 (0 points)

    After installing Lion I had problems with Wi-Fi, reseting SMC did the trick for me:

  • m-pertz Level 1 (0 points)

    I had an issue where I can connect to wifi, but I cannot browse the internet or do anything internet related. I tried to create a new profile and it did nothing, I then did a erase and reinstall and restored from time machine. Still did not work. I then uninstalled Avast, which to do that you have to launch Avast and go to the bolded icon on the top left corner and click on uninstall Avast and everything has been working perfectly since.

Previous 1 2 3 4 Next