Previous 1 99 100 101 102 103 Next 2,670 Replies Latest reply: Apr 23, 2014 2:58 PM by ElJefeGrande Go to original post
  • shaheeb Level 1 Level 1



    I've just tried the downgrade to the SL drivers as indicated in a previous post, but my macbook pro simply lost access to the wifi card altogether.  The little wifi icon in the menu bar reported "No Hardware Installed".  I had used the backup option in Kext Wizard, and was able to simply restore back to the original state.


    This is a brand new macbook pro 15" (has to be late 2011 since I got it about 4 days ago).  Running

    Mac OS X Lion 10.7.2 (11C2002)


    Card Type:          AirPort Extreme  (0x14E4, 0xD6)

      Firmware Version:          Broadcom BCM43xx 1.0 (

    IO80211 Family:          4.1.1 (411.1)


    Incidentally, when I performed the downgrade, and looked up the system information, the IO80211 Family was reading 3.1.1 (311.1), but listed no other information at all.


    Any advice?





  • Rico1111 Level 1 Level 1

    WOW!!!! SILENCE! Where did everyone go? Has everyone fixed their wifi issues? Mine has been okay after changing the channel in airport ....well sort of stays connected for a good amount of time ...I still get dropped but not as much.

    Shaheeb..sorry can't offer any advice.....hope u get it all straightened out.

  • Cyclic Level 1 Level 1

    Yeah.  I have to say, I made a few major changes, and haven't seen the issue lately.  First, I have been using Chromium.  Second, I changed my home router settings:

    Fragmentation Length (256-2346)
    CTS/RTS Threshold (1-2347)2307
    Preamble Mode




    And last but not least, I updated from Lion 10.7.0 to 10.7.1 about 2 weeks ago.  All seems pretty solid and normal now. Even starbucks connection seems fine.


    I will report back if the flakes that don't melt return.

  • emd3 Level 1 Level 1

    Went to Apple store and meet with a Genius.  We reset Safari, went to one location, Automatic, under network settings and put the DNS on Automatic as well. So far that seems to be working.  When I wake my MBP up it connects and so far I have not had a dropoff in 4 days. So thats all I have. 


    I can't believe it was that easy but the acid test will be when I go hame and try my office router where I was having real problems.  So more on that after I get home on the 5th.



  • Rico1111 Level 1 Level 1

    Glad to hear that some are having good results with adjustments to routers ...emd3 Right back at ya and everyone else HAPPY NEW YEAR!!!    Was starting to wonder if anyone was still having issues or I missed an actual release patch! lol......

  • torndownunit Level 1 Level 1

    Someone asked about updates a few posts ago.  Things seem to be running 'decently' for me at this point.  I do get drops, but I will go days without one.  I am still not happy with speeds at times though.  But it's been a couple of weeks now and things the drops are infrequent.


    The problem is I tried every fix in this thread before something stuck.   I THINK it was a combination of DHCP renewal (one of my last posts likely mentions this and a link to a video), and starting up from the recovery disk and repairing/fixing permissions.   Those are the last 2 fixes I tried, and they seem to have stuck (knock on wood).


    I'm sorry to anyone who hasn't got it fixed.  I feel your pain.  I am glad to have mine working, but the fact that I had to go through a dozen fixes on a new computer is ridiculous.

  • Kevanojb Level 1 Level 1

    I had a woeful connnection that seems to have appeared over the last few weeks.   I run an iMac 27" with 100mb internet, so have experienced a good service previously with the Lion update.  My ethernet and wifi were affected.  I believe, through my own trial and error that there must have been conflicting DHCP's causing the issue.  You may have the same problem.


    This works, after having reinstalled, messed about with every setting, contacted Apple, emailed friends etc....


    Choose Edit Locations under Network - via System Preferences or right clicking the wifi signal icon and choosing Open Network Preferences


    Select + (plus sign)  to add a location and name it anything you want, select this new location


    Go to Advanced (outer menu)


    Renew DHCP lease.  It takes a short time for you to be able to 'Apply' but you don't need to at thsi time,  as it works from here on,and Apply will be available shortly in any event.


    Get rid of your old Location


    Reboot computer


    The new settings should have reverted to a previous good connection.


    This worked for me, and I'm back to an iMac abd connection I bought a few months back.





  • jeroen184 Level 1 Level 1

    Rico, still here. Can you try for me the solution that worked for me?



    I have the same issue with a brand new Lion iMac (Dec 2011), not with a Snow Leopard MacBook Pro (May 2011). When I switch off N-Band of my AVM Fritz!Box router (operating in 801.11b-g ONLY) the problem disappears. If connected to a Time Capsule on 802.11n: no problem.

    Seems to me it's Apple 802.11n in Lion causing the problem, and maybe only in certain Airport cards.

    Hope this helps, seen no Apple fix yet.

  • iFinFan Level 1 Level 1



    I bought new iMac 21" few days ago, but it still had Snow Leopard. Have same issues, wifi keeps dropping every 5-15 minutes even though the airport icon on the top show all ok.


    I tried all the thing mentioned in this thread and many other, nothing has worked.


    Usually can connect back just by clicking home network again (even though it shows I am connected already), after few seconds starts to work.


    Now today I made a simple thing - turn off my computer, unplug the modem/router (I mean really unplug from the wall, not just switch off). Then turn on computer, put power back to router and everything has been fine for few hours already. I have no idea how permanent this solution is, but if that problem comes back I will just nicely carry this **** machine back to shop (had 30 days return guarantee without needing to explain any reason for return)


    Looks good at the moment, but never know....

  • jeroen184 Level 1 Level 1



    That weirds me out, all complaints are on Lion!


    Can you check one thing, in system profiler, whether the Airport card has Atheros, and the 802.11 Family has 4.0.x or so? Somehere in Discussions I recall an issue with this chipset and the 4.0 driver, which you are NOT supposed to have instaleld in SL.


    Did you disable n-band in your router? Unplugging it daily seems settings related, but quite annoying mi guess.


    Good luck!

  • iFinFan Level 1 Level 1

    Ok, I am faaaar away from being expert in these things and all the terms and technic but here's what I can tell - hopefully they are what you meant + some other info - if not the ones you meant - you can of course ask again:


    Version 10.6.8


    Card Type:    AirPort Extreme  (0x168C, 0x9A)

      Firmware Version:    Atheros 9380:

      Locale:    ETSI

      Country Code:    FI


    Current Network Information:

      PHY Mode:    802.11n

      Channel:    1

      Country Code:    FI

      Network Type:    Infrastructure

      Security:    WPA2 Personal

      Signal / Noise:    -44 dBm / -102 dBm

      Transmit Rate:    144

      MCS Index:    15


    Firewall Settings:


      Mode:    Allow all incoming connections

      Firewall Logging:    No

      Stealth Mode:    No

  • iFinFan Level 1 Level 1

    By the way... after router poweroff and restart, now country code is FI - it used to be before ES

  • iFinFan Level 1 Level 1

    Dropped again 5 hours of use. This piece of ---- is going back to store.

  • jeroen184 Level 1 Level 1

    Please read this (reposting) from Joao in Portugal: and


    Apple will not confirm if you call them! Nor did my ISP!


    You have the affected chipset. See, my MacBook shows a Broadcom set and IO80211 family 3.2. The bad one should read Atheros (which you have) and IO80211 family 4.0.x (which is from Lion) or so. That combo is affected, somehow. In my case disabling N-Band in the WiFi router itself remedies the problem, can't tell you why.


    Software Versions:

      Menu Extra:    6.2.2 (622.2)

      configd plug-in:    6.2.5 (625.6)

      System Profiler:    6.0.1 (601.1)

      Network Preference:    6.2.2 (622.2)

      AirPort Utility:    5.5.3 (553.20)

      IO80211 Family:    3.2 (320.1)



      Card Type:    AirPort Extreme  (0x14E4, 0xD6)

      Firmware Version:    Broadcom BCM43xx 1.0

      Locale:    ETSI

      Country Code:    NL

      Supported PHY Modes:    802.11 a/b/g/n

      Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

      Wake On Wireless:    Supported

      Status:    Connected

      Current Network Information:


    Do you have IO80211 family 4, then read the linked files, and see if you want to try. The rest of my Mac is fine, but this issue is indeed horrible. Best of luck!

  • iFinFan Level 1 Level 1

    Since I have a chance to return this Mac to store anyway until end of this month, I will. They have now ran out of Macs at the moment, but should have brand new ones soon. So I'll just get a new one then and hope it has everything ok with it already and no need to have any extra hassle. Meanwhile just have to endure this problem.


    Thanks for that link - I hadnt seen that before - I will save it  just in case if need at some point